aboutsummaryrefslogtreecommitdiff
path: root/textproc/xlhtml/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-17 15:21:32 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-17 15:21:32 +0000
commitca06e7b452e9a9ef8aac391c92b9cc4984b99cc1 (patch)
tree736aa5dd559949969ca786cd4860b93cea5fbed9 /textproc/xlhtml/Makefile
parente4789de0d903aa2669ad4435a6924e66b9b8d6fe (diff)
downloadports-ca06e7b452e9a9ef8aac391c92b9cc4984b99cc1.tar.gz
ports-ca06e7b452e9a9ef8aac391c92b9cc4984b99cc1.zip
Notes
Diffstat (limited to 'textproc/xlhtml/Makefile')
-rw-r--r--textproc/xlhtml/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/textproc/xlhtml/Makefile b/textproc/xlhtml/Makefile
index 46596675705f..7339ec6da14d 100644
--- a/textproc/xlhtml/Makefile
+++ b/textproc/xlhtml/Makefile
@@ -6,29 +6,29 @@
#
PORTNAME= xlhtml
-PORTVERSION= 0.5.1
-PORTREVISION= 1
+PORTVERSION= 0.5
+PORTEPOCH= 1
CATEGORIES= textproc
-MASTER_SITES= http://chicago.sourceforge.net/xlhtml/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= chicago
EXTRACT_SUFX= .tgz
MAINTAINER= coop9211@uidaho.edu
-COMMENT= Utilities converting Excel and PowerPoint files to HTML and text
+COMMENT= Convert Excel and PowerPoint files to HTML and text
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOMAKE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= ppthtml.1 xlhtml.1
-post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/xlhtml
- ${INSTALL_MAN} ${WRKSRC}/xlhtml/README \
- ${PREFIX}/share/doc/xlhtml/README.xlhtml
- ${INSTALL_MAN} ${WRKSRC}/ppthtml/README \
- ${PREFIX}/share/doc/xlhtml/README.ppthtml
+post-install:
+.for dir in xlhtml ppthtml
+ @${MKDIR} ${DOCSDIR}/${dir}
+ cd ${WRKSRC}/${dir} && \
+ ${INSTALL_DATA} ChangeLog README THANKS ${DOCSDIR}/${dir}
+.endfor
.endif
.include <bsd.port.mk>