aboutsummaryrefslogtreecommitdiff
path: root/textproc/xml-parse.el
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-11 19:21:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-11 19:21:47 +0000
commit1b481b766e7a0cf26ea68fdcbd0ad7e5bf5d04d9 (patch)
treeee14f84d67df580876d41d0611941216a22e0150 /textproc/xml-parse.el
parent61d735c6f8299359fd955030c23b2200c23e2792 (diff)
downloadports-1b481b766e7a0cf26ea68fdcbd0ad7e5bf5d04d9.tar.gz
ports-1b481b766e7a0cf26ea68fdcbd0ad7e5bf5d04d9.zip
Notes
Diffstat (limited to 'textproc/xml-parse.el')
-rw-r--r--textproc/xml-parse.el/Makefile32
-rw-r--r--textproc/xml-parse.el/distinfo2
-rw-r--r--textproc/xml-parse.el/pkg-descr8
-rw-r--r--textproc/xml-parse.el/pkg-plist1
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/xml-parse.el/Makefile b/textproc/xml-parse.el/Makefile
new file mode 100644
index 000000000000..307b4536ba3a
--- /dev/null
+++ b/textproc/xml-parse.el/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xml-parse.el
+# Date created: March 09 2005
+# Whom: Dryice Liu <dryice@liu.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xml-parse.el
+PORTVERSION= 1.5
+CATEGORIES= textproc elisp
+MASTER_SITES= http://www.newartisans.com/johnw/Emacs/ \
+ http://bsdchat.com/dist/dryice/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= dryice@liu.com.cn
+COMMENT= Code to efficiently read/write XML data with Elisp
+
+EMACS_PORT_NAME?= emacs21
+
+.if ${EMACS_PORT_NAME} != "emacs21"
+PORTNAMESUFFIX= ${PKGNAMESUFFIX}
+.endif
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${PREFIX}/${EMACS_SITE_LISPDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/xml-parse.el/distinfo b/textproc/xml-parse.el/distinfo
new file mode 100644
index 000000000000..b105fa39405c
--- /dev/null
+++ b/textproc/xml-parse.el/distinfo
@@ -0,0 +1,2 @@
+MD5 (xml-parse.el) = da71a4e2c2642df4735f9a4685c7cb4d
+SIZE (xml-parse.el) = 11442
diff --git a/textproc/xml-parse.el/pkg-descr b/textproc/xml-parse.el/pkg-descr
new file mode 100644
index 000000000000..c2bbc7ce10ad
--- /dev/null
+++ b/textproc/xml-parse.el/pkg-descr
@@ -0,0 +1,8 @@
+The approach taken by xml-parse.el is to read XML data into Lisp
+structures, and allow those same Lisp structures to be written out as
+XML. It should facilitate the manipulation and use of XML by Elisp
+programs.
+
+
+Author: John Wiegley
+WWW: http://www.newartisans.com/johnw/emacs.html
diff --git a/textproc/xml-parse.el/pkg-plist b/textproc/xml-parse.el/pkg-plist
new file mode 100644
index 000000000000..4c359530261b
--- /dev/null
+++ b/textproc/xml-parse.el/pkg-plist
@@ -0,0 +1 @@
+%%EMACS_SITE_LISPDIR%%/xml-parse.el