aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlada-gps
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-17 09:00:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-17 09:00:30 +0000
commit648db49f382199d3758915ff89cdcdc180e27ec8 (patch)
treed805169fc19478da16bf91dbfe5247e335f5c83d /textproc/xmlada-gps
parent83d56ee6e5f187bbe5adcf8f74022b164f6f17a8 (diff)
downloadports-648db49f382199d3758915ff89cdcdc180e27ec8.tar.gz
ports-648db49f382199d3758915ff89cdcdc180e27ec8.zip
Notes
Diffstat (limited to 'textproc/xmlada-gps')
-rw-r--r--textproc/xmlada-gps/Makefile77
-rw-r--r--textproc/xmlada-gps/distinfo6
-rw-r--r--textproc/xmlada-gps/files/patch-Makefile.in11
-rw-r--r--textproc/xmlada-gps/files/patch-schema_schema-validators-extensions.adb18
-rw-r--r--textproc/xmlada-gps/files/patch-schema_schema-validators-restrictions.adb11
-rw-r--r--textproc/xmlada-gps/files/patch-shared.gpr.in9
-rw-r--r--textproc/xmlada-gps/pkg-descr19
-rw-r--r--textproc/xmlada-gps/pkg-plist37
8 files changed, 89 insertions, 99 deletions
diff --git a/textproc/xmlada-gps/Makefile b/textproc/xmlada-gps/Makefile
index 07b0560ac647..cb5163d616ac 100644
--- a/textproc/xmlada-gps/Makefile
+++ b/textproc/xmlada-gps/Makefile
@@ -1,53 +1,54 @@
-# New ports collection makefile for: xmlada-gcc
-# Date created: 24 Dec 2006
-# Whom: hopet@ics.muni.cz
+# New ports collection makefile for: xmlada-gps
+# Date created: 31 Dec 2006
+# Whom: John Merryweather Cooper
#
# $FreeBSD$
#
-PORTNAME= xmlada
-PORTVERSION= 5.0.4
+PORTNAME= xmlada-gps
+PORTVERSION= 3.1.3
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= gnuada
-PKGNAMESUFFIX= -gcc
-DISTNAME= gnat-gcc-xmlada-4.1.1_gnat_5.04a-r6.src
-EXTRACT_SUFX= .rpm
+MASTER_SITES= http://libre.adacore.com/
+EXTRACT_SUFX= -src.tgz
-MAINTAINER= hopet@ics.muni.cz
-COMMENT= An XML parsing library for Ada 95, port for lang/gnat-gcc41
+MAINTAINER= john_m_cooper@yahoo.com
+COMMENT= The Ada Unicode and XML Library
-BUILD_DEPENDS= ${LOCALBASE}/bin/gcc41/gcc41:${PORTSDIR}/lang/gnat-gcc41
-
-EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
-
-.if !defined(NOPORTDOCS)
-BUILD_DEPENDS+= makeinfo:${PORTSDIR}/print/texinfo \
- pdftex:${PORTSDIR}/print/teTeX
-.endif
-
-WRKSRC= ${WRKDIR}/xmlada-gnat-5_04a
+BUILD_DEPENDS= gnatmake:${PORTSDIR}/lang/gnat
CONFLICTS= xmlada-[0-9]*
-CONFIGURE_ENV+= PATH=${LOCALBASE}/bin/gcc41:${PATH} CC=${LOCALBASE}/bin/gcc41/gcc41
-MAKE_ENV+= PATH=${LOCALBASE}/bin/gcc41:${PATH} CC=${LOCALBASE}/bin/gcc41/gcc41
-
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-
-ADACFLAGS?= # none
-CFLAGS= ${ADACFLAGS}
+USE_GMAKE= yes
-XMLADAPKGNAME= xmlada-gnat-5_04a.tar.bz2
+# Check for GNAT sources.
+.if !exists(${DISTDIR}/${DISTFILE}) && !defined(PACKAGE_BUILDING)
+ECHO_MSG= ${PRINTF}
+IGNORE=Because of licensing and registration restrictions, you must fetch\n \
+ the source distribution manually. Please access\n \
+ http://libre.adacore.com/\ with a web browser, register\n \
+ (It's free!) and log in. Download the source files:\n\n \
+ \t${DISTFILE}\n\n \
+ and place them in ${DISTDIR}\n
+ ${ECHO_MSG} ${IGNORE}
+.endif
-do-extract:
- if [ ! -d ${WRKDIR} ]; then \
- ${MKDIR} ${WRKDIR}; \
- fi
- ( cd ${WRKDIR} && \
- rpm2cpio.pl <${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | ${CPIO} -i ${XMLADAPKGNAME} && \
- tar jxf ${XMLADAPKGNAME} )
+WRKSRC= ${WRKDIR}/xmlada-2.1
+DOCSDIR= ${PREFIX}/share/doc/xmlada
+MAKE_ENV= "INSTALL_DATA=${INSTALL_DATA}" \
+ "INSTALL_SCRIPT=${INSTALL_SCRIPT}"
+
+# Weird permission problems creep up on install unless done explicitly
+# this way.
+do-install:
+ @(cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install)
+# Manual install of info file since it lacks an entry field
+.if !defined(NOPORTDOCS)
+ @(cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install_docs)
+ @install-info --entry "XmlAda" ${DOCSDIR}/xml.info \
+ ${DOCSDIR}/dir
+.endif
.include <bsd.port.mk>
diff --git a/textproc/xmlada-gps/distinfo b/textproc/xmlada-gps/distinfo
index de3c15cff1d7..5d942df7f293 100644
--- a/textproc/xmlada-gps/distinfo
+++ b/textproc/xmlada-gps/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnat-gcc-xmlada-4.1.1_gnat_5.04a-r6.src.rpm) = ed706dabe25e0d3d81c1db419eb2e010
-SHA256 (gnat-gcc-xmlada-4.1.1_gnat_5.04a-r6.src.rpm) = 80ac743dec2068d6d4fe0003d1496cd4c36ae1807fa8ed591aaa2465f222908b
-SIZE (gnat-gcc-xmlada-4.1.1_gnat_5.04a-r6.src.rpm) = 374751
+MD5 (xmlada-gps-3.1.3-src.tgz) = 6673657fd6e05e4d4e7c3f843b1201d3
+SHA256 (xmlada-gps-3.1.3-src.tgz) = a9fbee538185f27541c813bf3c7ecd97dead86166c43e54db8ad841d9d57846a
+SIZE (xmlada-gps-3.1.3-src.tgz) = 686514
diff --git a/textproc/xmlada-gps/files/patch-Makefile.in b/textproc/xmlada-gps/files/patch-Makefile.in
deleted file mode 100644
index 639fdbb683de..000000000000
--- a/textproc/xmlada-gps/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Sun Dec 24 23:38:00 2006
-+++ Makefile.in Sun Dec 24 23:38:17 2006
-@@ -30,7 +30,7 @@
-
- .PHONY: all obj clean install install_dirs
-
--all: obj
-+all: obj docs
-
- obj: force
- ${GNATMAKE} -Punicode/unicode.gpr -XMODE=${MODE} -XLIBRARY_TYPE=${LIBRARY_TYPE}
diff --git a/textproc/xmlada-gps/files/patch-schema_schema-validators-extensions.adb b/textproc/xmlada-gps/files/patch-schema_schema-validators-extensions.adb
new file mode 100644
index 000000000000..47470082b930
--- /dev/null
+++ b/textproc/xmlada-gps/files/patch-schema_schema-validators-extensions.adb
@@ -0,0 +1,18 @@
+--- schema/schema-validators-extensions.adb.orig Tue Jan 2 10:16:54 2007
++++ schema/schema-validators-extensions.adb Tue Jan 2 10:19:58 2007
+@@ -199,13 +199,13 @@
+ begin
+ Had_Extension := True;
+
+- if Validator.Base.Block_Restriction and then Had_Restriction then
++ if Validator.Base.Block_Restriction then
+ Validation_Error
+ ("Restrictions of type """
+ & Get_Local_Name (Validator.Base) & """ are forbidden");
+ end if;
+
+- if Validator.Base.Block_Extension and then Had_Extension then
++ if Validator.Base.Block_Extension then
+ Validation_Error
+ ("Extensions of type """
+ & Get_Local_Name (Validator.Base) & """ are forbidden");
diff --git a/textproc/xmlada-gps/files/patch-schema_schema-validators-restrictions.adb b/textproc/xmlada-gps/files/patch-schema_schema-validators-restrictions.adb
new file mode 100644
index 000000000000..7bf9514d52e0
--- /dev/null
+++ b/textproc/xmlada-gps/files/patch-schema_schema-validators-restrictions.adb
@@ -0,0 +1,11 @@
+--- schema/schema-validators-restrictions.adb.orig Tue Jan 2 10:28:58 2007
++++ schema/schema-validators-restrictions.adb Tue Jan 2 10:30:55 2007
+@@ -201,7 +201,7 @@
+ begin
+ Had_Restriction := True;
+
+- if Validator.Base.Block_Restriction and then Had_Restriction then
++ if Validator.Base.Block_Restriction then
+ Validation_Error
+ ("Restrictions of type """
+ & Get_Local_Name (Validator.Base) & """ are forbidden");
diff --git a/textproc/xmlada-gps/files/patch-shared.gpr.in b/textproc/xmlada-gps/files/patch-shared.gpr.in
deleted file mode 100644
index 029f84db45bc..000000000000
--- a/textproc/xmlada-gps/files/patch-shared.gpr.in
+++ /dev/null
@@ -1,9 +0,0 @@
---- shared.gpr.in.orig Mon Dec 25 00:14:30 2006
-+++ shared.gpr.in Mon Dec 25 00:14:48 2006
-@@ -1,5 +1,5 @@
- project Shared is
-- Version := "@XMLADA_MAJOR_VERSION@.@XMLADA_MINOR_VERSION@";
-+ Version := "@XMLADA_MAJOR_VERSION@";
-
- type Library_Type_Type is ("relocatable", "static");
- Library_Type : Library_Type_Type := external ("LIBRARY_TYPE", "relocatable");
diff --git a/textproc/xmlada-gps/pkg-descr b/textproc/xmlada-gps/pkg-descr
index 2d36a28d0bdb..4826a6af6946 100644
--- a/textproc/xmlada-gps/pkg-descr
+++ b/textproc/xmlada-gps/pkg-descr
@@ -1,16 +1,5 @@
-XML/Ada is a set of modules that provide a simple manipulation of XML
-streams. It supports the whole XML 1.0 specifications, and can parse
-any file that follows this standard (including the contents of the
-DTD).
+The XmlAda library includes a set of Ada2005 packages to manipulate XML
+input. It implements the XML 1.0 standard, as well as support for
+namespaces and a number of other optional standards related to XML.
-It also provides support for a number of other standard associated
-with XML, like SAX and DOM.
-
-In addition, It includes a module to manipulate Unicode streams, since
-this is required by the XML standard.
-
-This version of GtkAda is designed to be used with lang/gnat-gcc41.
-
-WWW: https://libre2.adacore.com/xmlada/
-WWW: http://gnuada.sourceforge.net/
-Author: Petr Holub <hopet@ics.muni.cz>
+WWW: http://libre.adacore.com/
diff --git a/textproc/xmlada-gps/pkg-plist b/textproc/xmlada-gps/pkg-plist
index b153352fe759..4072f5306fb3 100644
--- a/textproc/xmlada-gps/pkg-plist
+++ b/textproc/xmlada-gps/pkg-plist
@@ -200,16 +200,11 @@ lib/gnat/xmlada_input.gpr
lib/gnat/xmlada_sax.gpr
lib/gnat/xmlada_schema.gpr
lib/gnat/xmlada_unicode.gpr
-lib/libxmlada_dom.so
-lib/libxmlada_dom.so.2
-lib/libxmlada_input_sources.so
-lib/libxmlada_input_sources.so.2
-lib/libxmlada_sax.so
-lib/libxmlada_sax.so.2
-lib/libxmlada_schema.so
-lib/libxmlada_schema.so.2
-lib/libxmlada_unicode.so
-lib/libxmlada_unicode.so.2
+lib/libxmlada_dom.a
+lib/libxmlada_input_sources.a
+lib/libxmlada_sax.a
+lib/libxmlada_schema.a
+lib/libxmlada_unicode.a
lib/xmlada/dom-core-attrs.ali
lib/xmlada/dom-core-cdata_sections.ali
lib/xmlada/dom-core-character_datas.ali
@@ -230,16 +225,11 @@ lib/xmlada/input_sources-file.ali
lib/xmlada/input_sources-http.ali
lib/xmlada/input_sources-strings.ali
lib/xmlada/input_sources.ali
-lib/xmlada/libxmlada_dom.so
-lib/xmlada/libxmlada_dom.so.2
-lib/xmlada/libxmlada_input_sources.so
-lib/xmlada/libxmlada_input_sources.so.2
-lib/xmlada/libxmlada_sax.so
-lib/xmlada/libxmlada_sax.so.2
-lib/xmlada/libxmlada_schema.so
-lib/xmlada/libxmlada_schema.so.2
-lib/xmlada/libxmlada_unicode.so
-lib/xmlada/libxmlada_unicode.so.2
+lib/xmlada/libxmlada_dom.a
+lib/xmlada/libxmlada_input_sources.a
+lib/xmlada/libxmlada_sax.a
+lib/xmlada/libxmlada_schema.a
+lib/xmlada/libxmlada_unicode.a
lib/xmlada/sax-attributes.ali
lib/xmlada/sax-encodings.ali
lib/xmlada/sax-exceptions.ali
@@ -363,14 +353,15 @@ lib/xmlada/unicode-names-yi_radicals.ali
lib/xmlada/unicode-names-yi_syllables.ali
lib/xmlada/unicode-names.ali
lib/xmlada/unicode.ali
+%%PORTDOCS%%%%DOCSDIR%%/dir
%%PORTDOCS%%%%DOCSDIR%%/xml.html
%%PORTDOCS%%%%DOCSDIR%%/xml.info
%%PORTDOCS%%%%DOCSDIR%%/xml.pdf
share/gps/plug-ins/xmlada_gps.py
-@dirrmtry share/gps/plug-ins
-@dirrmtry share/gps
+@dirrm share/gps/plug-ins
+@dirrm share/gps
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/xmlada
@dirrm lib/gnat/xmlada
-@dirrmtry lib/gnat
+@dirrm lib/gnat
@dirrm include/xmlada