aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlada
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-11-10 11:27:07 +0000
committerJohn Marino <marino@FreeBSD.org>2013-11-10 11:27:07 +0000
commit9842c519956976c1c767cf8ff29797d17d8e599f (patch)
treed32a9a1135808ade4b1a0e270458457ee1df804a /textproc/xmlada
parent80611e4cb729933512bb3514deb1d8edd7c3aaa4 (diff)
downloadports-9842c519956976c1c767cf8ff29797d17d8e599f.tar.gz
ports-9842c519956976c1c767cf8ff29797d17d8e599f.zip
Notes
Diffstat (limited to 'textproc/xmlada')
-rw-r--r--textproc/xmlada/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/textproc/xmlada/Makefile b/textproc/xmlada/Makefile
index dcb127c425d9..c9ee80715b76 100644
--- a/textproc/xmlada/Makefile
+++ b/textproc/xmlada/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xmlada
PORTVERSION= 4.4.0.0
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://downloads.dragonlace.net/src/
@@ -12,18 +13,15 @@ COMMENT= Adacore XML suite for the Ada language
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_BZIP2= yes
-USES= ada
-
-DESTINY= ${WRKDIR}/destino
-MAKE_ENV+= DESTDIR=${DESTINY}
+USES= ada gmake
+NO_MTREE= yes
MAKE_JOBS_UNSAFE= yes
+NO_LICENSES_INSTALL= yes
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -48,17 +46,15 @@ post-patch:
.endif
post-install:
- ${RM} -rf ${DESTINY}${PREFIX}/share/doc/xmlada/_sources
- ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
- @cd ${DESTINY}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
- ${SORT} > ${WRKDIR}/PLIST.all
- @cd ${DESTINY}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | ${SORT} -r | \
+ ${RM} -rf ${STAGEDIR}${PREFIX}/share/doc/xmlada/_sources
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${SORT} > ${TMPPLIST}
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | ${SORT} -r | \
${SED} -e '/lib\/gnat$$/d' -e '/share\/doc$$/d' -e '/share\/gps/d' \
- -e 's/^/@dirrm /g' >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @${CAT} ${WRKDIR}/PLIST.all >> ${TMPPLIST}
+ -e 's/^/@dirrm /g' >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${TMPPLIST}
.include <bsd.port.mk>