aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlenc
diff options
context:
space:
mode:
authorErnst de Haan <znerd@FreeBSD.org>2002-10-11 23:22:46 +0000
committerErnst de Haan <znerd@FreeBSD.org>2002-10-11 23:22:46 +0000
commita562b66e5d14824a01b110810652774fe8874be1 (patch)
tree2ea65cee479032a88f416c4ab6ee76653713b933 /textproc/xmlenc
parentb7c02cfa3914b5dd10f01caf2f511b15bb27b8b2 (diff)
downloadports-a562b66e5d14824a01b110810652774fe8874be1.tar.gz
ports-a562b66e5d14824a01b110810652774fe8874be1.zip
Notes
Diffstat (limited to 'textproc/xmlenc')
-rw-r--r--textproc/xmlenc/Makefile37
-rw-r--r--textproc/xmlenc/distinfo1
-rw-r--r--textproc/xmlenc/pkg-comment1
-rw-r--r--textproc/xmlenc/pkg-descr5
-rw-r--r--textproc/xmlenc/pkg-plist57
5 files changed, 101 insertions, 0 deletions
diff --git a/textproc/xmlenc/Makefile b/textproc/xmlenc/Makefile
new file mode 100644
index 000000000000..d8a421fdf778
--- /dev/null
+++ b/textproc/xmlenc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: JUMP Ultimate Math Package
+# Date created: June 13, 2002
+# Whom: Ernst de Haan <znerd@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlenc
+PORTVERSION= 0.2
+CATEGORIES= textproc java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xmlenc
+
+MAINTAINER= znerd@FreeBSD.org
+
+BUILD_DEPENDS= ${ANT}:${PORTSDIR}/devel/jakarta-ant
+
+USE_JAVA= 1.1+
+
+PLIST_SUB+= T=${TARGET_DIR:S/^${PREFIX}\///}
+TARGET_DIR?= ${PREFIX}/share/java/${PORTNAME}-${PORTVERSION}
+ANT?= ${LOCALBASE}/bin/ant
+ANT_TARGET= jar apidocs
+
+do-build:
+ @cd ${WRKSRC} && ${ANT} ${ANT_TARGET}
+
+do-install:
+ @${ECHO} -n ">> Creating directory ${TARGET_DIR}..."
+ @${MKDIR} ${TARGET_DIR}
+ @${ECHO} " [ DONE ]"
+
+ @${ECHO} -n ">> Copying files..."
+ @${CP} -r ${WRKSRC}/* ${TARGET_DIR}
+ @${ECHO} " [ DONE ]"
+
+.include <bsd.port.mk>
diff --git a/textproc/xmlenc/distinfo b/textproc/xmlenc/distinfo
new file mode 100644
index 000000000000..b9c7deda8adf
--- /dev/null
+++ b/textproc/xmlenc/distinfo
@@ -0,0 +1 @@
+MD5 (xmlenc-0.2.tar.gz) = 1b247be3e7611c008b4cd98084d4f2dd
diff --git a/textproc/xmlenc/pkg-comment b/textproc/xmlenc/pkg-comment
new file mode 100644
index 000000000000..02da97e3af23
--- /dev/null
+++ b/textproc/xmlenc/pkg-comment
@@ -0,0 +1 @@
+Light-weight XML encoding library for Java
diff --git a/textproc/xmlenc/pkg-descr b/textproc/xmlenc/pkg-descr
new file mode 100644
index 000000000000..3e4fb6ef05ed
--- /dev/null
+++ b/textproc/xmlenc/pkg-descr
@@ -0,0 +1,5 @@
+Light-weight XML encoding library for Java. It fills the gap
+between a light-weight parser like SAX, and a heavy-weight XML
+output library, like JDOM.
+
+WWW: http://xmlenc.sourceforge.net/
diff --git a/textproc/xmlenc/pkg-plist b/textproc/xmlenc/pkg-plist
new file mode 100644
index 000000000000..366d40a669f4
--- /dev/null
+++ b/textproc/xmlenc/pkg-plist
@@ -0,0 +1,57 @@
+%%T%%/src/examples/org/znerd/xmlenc/examples/simple/Main.java
+%%T%%/src/main/org/znerd/xmlenc/XMLEncoder.java
+%%T%%/src/tests/org/znerd/xmlenc/tests/AllTests.java
+%%T%%/src/tests/org/znerd/xmlenc/tests/XMLEncoderTests.java
+%%T%%/build/src/main/org/znerd/xmlenc/XMLEncoder.java
+%%T%%/build/classes/main/org/znerd/xmlenc/XMLEncoder.class
+%%T%%/build/apidocs/org/znerd/xmlenc/class-use/XMLEncoder.html
+%%T%%/build/apidocs/org/znerd/xmlenc/package-use.html
+%%T%%/build/apidocs/org/znerd/xmlenc/package-summary.html
+%%T%%/build/apidocs/org/znerd/xmlenc/package-tree.html
+%%T%%/build/apidocs/org/znerd/xmlenc/package-frame.html
+%%T%%/build/apidocs/org/znerd/xmlenc/XMLEncoder.html
+%%T%%/build/apidocs/overview-tree.html
+%%T%%/build/apidocs/index-all.html
+%%T%%/build/apidocs/deprecated-list.html
+%%T%%/build/apidocs/allclasses-frame.html
+%%T%%/build/apidocs/index.html
+%%T%%/build/apidocs/packages.html
+%%T%%/build/apidocs/serialized-form.html
+%%T%%/build/apidocs/package-list
+%%T%%/build/apidocs/help-doc.html
+%%T%%/build/apidocs/stylesheet.css
+%%T%%/build/xmlenc.jar
+%%T%%/build.xml
+@dirrm %%T%%/src/examples/org/znerd/xmlenc/examples/simple
+@dirrm %%T%%/src/examples/org/znerd/xmlenc/examples
+@dirrm %%T%%/src/examples/org/znerd/xmlenc
+@dirrm %%T%%/src/examples/org/znerd
+@dirrm %%T%%/src/examples/org
+@dirrm %%T%%/src/examples
+@dirrm %%T%%/src/main/org/znerd/xmlenc
+@dirrm %%T%%/src/main/org/znerd
+@dirrm %%T%%/src/main/org
+@dirrm %%T%%/src/main
+@dirrm %%T%%/src/tests/org/znerd/xmlenc/tests
+@dirrm %%T%%/src/tests/org/znerd/xmlenc
+@dirrm %%T%%/src/tests/org/znerd
+@dirrm %%T%%/src/tests/org
+@dirrm %%T%%/src/tests
+@dirrm %%T%%/src
+@dirrm %%T%%/build/src/main/org/znerd/xmlenc
+@dirrm %%T%%/build/src/main/org/znerd
+@dirrm %%T%%/build/src/main/org
+@dirrm %%T%%/build/src/main
+@dirrm %%T%%/build/src
+@dirrm %%T%%/build/classes/main/org/znerd/xmlenc
+@dirrm %%T%%/build/classes/main/org/znerd
+@dirrm %%T%%/build/classes/main/org
+@dirrm %%T%%/build/classes/main
+@dirrm %%T%%/build/classes
+@dirrm %%T%%/build/apidocs/org/znerd/xmlenc/class-use
+@dirrm %%T%%/build/apidocs/org/znerd/xmlenc
+@dirrm %%T%%/build/apidocs/org/znerd
+@dirrm %%T%%/build/apidocs/org
+@dirrm %%T%%/build/apidocs
+@dirrm %%T%%/build
+@dirrm %%T%%