aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlformat
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-02-08 23:28:17 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-02-08 23:28:17 +0000
commit6428a01e3b5a75d7dd28810b693132cf4bc168d9 (patch)
treeffa7ce9b6898efcc2e08707e34064a07c348f4d4 /textproc/xmlformat
parent2fd906090039534cc803dfc36e555bd192119ac0 (diff)
downloadports-6428a01e3b5a75d7dd28810b693132cf4bc168d9.tar.gz
ports-6428a01e3b5a75d7dd28810b693132cf4bc168d9.zip
Notes
Diffstat (limited to 'textproc/xmlformat')
-rw-r--r--textproc/xmlformat/Makefile43
-rw-r--r--textproc/xmlformat/distinfo2
-rw-r--r--textproc/xmlformat/pkg-descr5
-rw-r--r--textproc/xmlformat/pkg-plist26
4 files changed, 76 insertions, 0 deletions
diff --git a/textproc/xmlformat/Makefile b/textproc/xmlformat/Makefile
new file mode 100644
index 000000000000..d150f6b5aa97
--- /dev/null
+++ b/textproc/xmlformat/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: xmlformat
+# Date created: 8 Feb 2004
+# Whom: Hiroki Sato <hrs@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= xmlformat
+PORTVERSION= 1.02
+CATEGORIES= textproc
+MASTER_SITES= http://www.kitebird.com/software/xmlformat/
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= An XML Document Formatter
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= BUGS ChangeLog INSTALL LICENSE README TODO
+
+DOCSRCDIR2= ${WRKSRC}/docs
+DOCSDIR2= ${DOCSDIR}/docs
+DOC_FILES2= API catalog.xml \
+ tutorial.html tutorial.pdf tutorial.xml \
+ xmlformat.conf xmlformat.html xmlformat.pdf xmlformat.xml
+
+EXSRCDIR= ${WRKSRC}/docs/examples
+EXDIR= ${DOCSDIR}/docs/examples
+EX_FILES= doc1.xml doc2.conf1 doc2.conf2 doc2.conf3 \
+ doc2.conf4 doc2.xml
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/xmlformat.pl ${PREFIX}/bin/xmlformat
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S,^,${DOCSRCDIR1}/,} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S,^,${DOCSRCDIR2}/,} ${DOCSDIR2}
+ ${MKDIR} ${EXDIR}
+ ${INSTALL_DATA} ${EX_FILES:S,^,${EXSRCDIR}/,} ${EXDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/xmlformat/distinfo b/textproc/xmlformat/distinfo
new file mode 100644
index 000000000000..606278a7a3e5
--- /dev/null
+++ b/textproc/xmlformat/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmlformat-1.02.tar.gz) = 0fd53db6e015a9da8d81fc3a75685554
+SIZE (xmlformat-1.02.tar.gz) = 136660
diff --git a/textproc/xmlformat/pkg-descr b/textproc/xmlformat/pkg-descr
new file mode 100644
index 000000000000..ba3ca601e1c0
--- /dev/null
+++ b/textproc/xmlformat/pkg-descr
@@ -0,0 +1,5 @@
+xmlformat is a configurable formatter (or "pretty-printer") for
+XML documents. It provides control over indentation, line-breaking,
+and text wrapping. These properties can be defined on a per-element basis.
+
+WWW: http://www.kitebird.com/software/xmlformat/
diff --git a/textproc/xmlformat/pkg-plist b/textproc/xmlformat/pkg-plist
new file mode 100644
index 000000000000..90a0b1ac88b8
--- /dev/null
+++ b/textproc/xmlformat/pkg-plist
@@ -0,0 +1,26 @@
+@comment $FreeBSD$
+bin/xmlformat
+%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc2.conf1
+%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc2.conf2
+%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc2.conf3
+%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc2.conf4
+%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc1.xml
+%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc2.xml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/examples
+%%PORTDOCS%%%%DOCSDIR%%/docs/API
+%%PORTDOCS%%%%DOCSDIR%%/docs/catalog.xml
+%%PORTDOCS%%%%DOCSDIR%%/docs/tutorial.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/tutorial.pdf
+%%PORTDOCS%%%%DOCSDIR%%/docs/tutorial.xml
+%%PORTDOCS%%%%DOCSDIR%%/docs/xmlformat.conf
+%%PORTDOCS%%%%DOCSDIR%%/docs/xmlformat.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/xmlformat.pdf
+%%PORTDOCS%%%%DOCSDIR%%/docs/xmlformat.xml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%