aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlgen
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-18 06:03:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-18 06:03:27 +0000
commitad1dd645389d6b30b95dae4a7d6967afc4c98867 (patch)
treeeb99166962e871cc85db7decfde27e244aa42caf /textproc/xmlgen
parent8165280e06bdc04d852bad44ab20164fed53d3e4 (diff)
downloadports-ad1dd645389d6b30b95dae4a7d6967afc4c98867.tar.gz
ports-ad1dd645389d6b30b95dae4a7d6967afc4c98867.zip
Notes
Diffstat (limited to 'textproc/xmlgen')
-rw-r--r--textproc/xmlgen/Makefile20
-rw-r--r--textproc/xmlgen/distinfo2
-rw-r--r--textproc/xmlgen/pkg-descr9
-rw-r--r--textproc/xmlgen/pkg-plist11
4 files changed, 42 insertions, 0 deletions
diff --git a/textproc/xmlgen/Makefile b/textproc/xmlgen/Makefile
new file mode 100644
index 000000000000..fe792e67cfe5
--- /dev/null
+++ b/textproc/xmlgen/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sébastien Santoro <dereckson@gmail.com>
+# $FreeBSD$
+
+PORTNAME= xmlgen
+PORTVERSION= 1.4
+CATEGORIES= textproc tcl
+MASTER_SITES= SF/tclxml/${PORTNAME}/v${PORTVERSION}
+
+MAINTAINER= dereckson@gmail.com
+COMMENT= Write XML documents using Tcl
+
+USE_TCL= 83+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ cd ${WRKSRC} && ${TCLSH} bras-sa PKGDIR=${PREFIX}/lib/${PORTNAME} DOCDIR=${PREFIX}/share/doc/${PORTNAME} CGIDIR=${PREFIX}/www/${PORTNAME} install
+
+.include <bsd.port.post.mk>
diff --git a/textproc/xmlgen/distinfo b/textproc/xmlgen/distinfo
new file mode 100644
index 000000000000..cf1bbf8d0386
--- /dev/null
+++ b/textproc/xmlgen/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xmlgen-1.4.tar.gz) = 2e35025db5ff9ec8867907618c91d49d72fe93f26956ec2043ce751bc3a7b654
+SIZE (xmlgen-1.4.tar.gz) = 59075
diff --git a/textproc/xmlgen/pkg-descr b/textproc/xmlgen/pkg-descr
new file mode 100644
index 000000000000..d238558107ca
--- /dev/null
+++ b/textproc/xmlgen/pkg-descr
@@ -0,0 +1,9 @@
+xmlgen is a TCL package to write XML documents in Tcl.
+
+This XML code is expressed by TCL code, which is translated.
+
+Every tag is made into a markup command which takes attributes and
+the element's content as parameters and then prints the XML tagged
+content. Of course, the content again can contain markup commands.
+
+WWW: http://tclxml.sourceforge.net/
diff --git a/textproc/xmlgen/pkg-plist b/textproc/xmlgen/pkg-plist
new file mode 100644
index 000000000000..29821c4afdac
--- /dev/null
+++ b/textproc/xmlgen/pkg-plist
@@ -0,0 +1,11 @@
+lib/xmlgen/htmlgen.tcl
+lib/xmlgen/pkgIndex.tcl
+lib/xmlgen/sidenav.tcl
+lib/xmlgen/tab.tcl
+lib/xmlgen/xmlgen.tcl
+share/doc/xmlgen/htmlgen.html
+share/doc/xmlgen/overview.html
+share/doc/xmlgen/sidenav.html
+share/doc/xmlgen/xmlgen.html
+@dirrm share/doc/xmlgen
+@dirrm lib/xmlgen