aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlppm/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-03 11:02:53 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-03 11:02:53 +0000
commitc3d216f7dca32f3cf491114307cf6d27a3639dfd (patch)
tree191cde6f6ef77858d2b90db500e68e71ce810de6 /textproc/xmlppm/Makefile
parentf3a33351b0f0ce8cff0ac3282f59dfbbbd2279cb (diff)
downloadports-c3d216f7dca32f3cf491114307cf6d27a3639dfd.tar.gz
ports-c3d216f7dca32f3cf491114307cf6d27a3639dfd.zip
Notes
Diffstat (limited to 'textproc/xmlppm/Makefile')
-rw-r--r--textproc/xmlppm/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/textproc/xmlppm/Makefile b/textproc/xmlppm/Makefile
index 2cf652b9d82c..d3286e71103b 100644
--- a/textproc/xmlppm/Makefile
+++ b/textproc/xmlppm/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= xmlppm
-PORTVERSION= 0.98.1
+PORTVERSION= 0.98.2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.cs.cornell.edu/People/jcheney/xmlppm/
@@ -24,19 +24,18 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
USE_ICONV= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+MAKE_ARGS= CC="${CXX}" CFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lexpat -liconv"
+.if !defined(NOPORTDOCS)
PORTDOCS= README
+.endif
+
PLIST_FILES= bin/xmlppm bin/xmlunppm
post-patch:
- @${REINPLACE_CMD} -e \
- 's|^CC|#CC|g ; \
- s|^CPPFLAGS|#CPPFLAGS|g ; \
- s|^CFLAGS|#CFLAGS|g ; \
- s|$$(CC)|$$(CXX)|g ; \
- s|$$(CFLAGS)|$$(CXXFLAGS)|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^CC|#CC|' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xmlppm ${PREFIX}/bin