aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlppm
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-15 04:09:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-15 04:09:09 +0000
commit1bdf10e1da34183b6ab830b979c8cff8a7ef0816 (patch)
tree6267b7575ff5724483b7e2a00725cf55a9abf3e5 /textproc/xmlppm
parent72e6d66a800b480b0aba3e997c93db643609cc5d (diff)
downloadports-1bdf10e1da34183b6ab830b979c8cff8a7ef0816.tar.gz
ports-1bdf10e1da34183b6ab830b979c8cff8a7ef0816.zip
Notes
Diffstat (limited to 'textproc/xmlppm')
-rw-r--r--textproc/xmlppm/Makefile30
-rw-r--r--textproc/xmlppm/distinfo1
-rw-r--r--textproc/xmlppm/files/patch-Makefile12
-rw-r--r--textproc/xmlppm/pkg-comment1
-rw-r--r--textproc/xmlppm/pkg-descr8
-rw-r--r--textproc/xmlppm/pkg-plist2
6 files changed, 54 insertions, 0 deletions
diff --git a/textproc/xmlppm/Makefile b/textproc/xmlppm/Makefile
new file mode 100644
index 000000000000..cecf88d1b101
--- /dev/null
+++ b/textproc/xmlppm/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: xmlppm
+# Date created: May 15, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlppm
+PORTVERSION= 0.95.2
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.cs.cornell.edu/People/jcheney/xmlppm/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= expat.2:${PORTSDIR}/textproc/expat2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
+
+do-install:
+ @(cd ${WRKSRC} ; ${INSTALL_PROGRAM} xmlppm xmlunppm ${PREFIX}/bin)
+
+.include <bsd.port.mk>
diff --git a/textproc/xmlppm/distinfo b/textproc/xmlppm/distinfo
new file mode 100644
index 000000000000..f6bbbdb5359e
--- /dev/null
+++ b/textproc/xmlppm/distinfo
@@ -0,0 +1 @@
+MD5 (xmlppm-0.95.2-src.tar.gz) = d8de4389d735df3806c1cf72bfd03068
diff --git a/textproc/xmlppm/files/patch-Makefile b/textproc/xmlppm/files/patch-Makefile
new file mode 100644
index 000000000000..3a5dee160556
--- /dev/null
+++ b/textproc/xmlppm/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig Sat May 12 03:21:58 2001
++++ Makefile Tue May 15 11:59:08 2001
+@@ -1,7 +1,6 @@
+-CC = gcc
+ #XPPMFLAGS = -DELTPREC_P=1 -DATTPREC=1 -DCHARPREC=1 -DELTORDER=5 -DATTORDER=5 -DCHARORDER=5 -DATTS -DCHAR -DSYMS
+-CFLAGS = $(XPPMFLAGS) -O2 -Wall -ansi
+-LFLAGS = -lexpat -lm
++CFLAGS += -I%%LOCALBASE%%/include
++LFLAGS = -L%%LOCALBASE%%/lib -lexpat -lm
+ #LFLAGS = /usr/lib/libexpat.a -lm
+
+ BINARIES = xmlppm xmlunppm
diff --git a/textproc/xmlppm/pkg-comment b/textproc/xmlppm/pkg-comment
new file mode 100644
index 000000000000..2651dd2cfb11
--- /dev/null
+++ b/textproc/xmlppm/pkg-comment
@@ -0,0 +1 @@
+XML-Conscious PPM Compression
diff --git a/textproc/xmlppm/pkg-descr b/textproc/xmlppm/pkg-descr
new file mode 100644
index 000000000000..bcee1485b302
--- /dev/null
+++ b/textproc/xmlppm/pkg-descr
@@ -0,0 +1,8 @@
+XMLPPM is a data compression program that compresses XML files from 5 to
+30% better than any existing text or XML-specific compressors. It is a
+combination of the well-known Prediction by Partial Match (PPM) algorithm
+for text compression, first described by Cleary and Witten in 1984, and an
+approach to modeling tree-structured data called Multiplexed Hierarchical
+Modeling (MHM) that I have developed.
+
+WWW: http://xmlppm.sourceforge.net/
diff --git a/textproc/xmlppm/pkg-plist b/textproc/xmlppm/pkg-plist
new file mode 100644
index 000000000000..dc589840cf56
--- /dev/null
+++ b/textproc/xmlppm/pkg-plist
@@ -0,0 +1,2 @@
+bin/xmlppm
+bin/xmlunppm