aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlpull
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-01 15:12:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-01 15:12:51 +0000
commitd54e26320d84193b1f56e795d837aef015835955 (patch)
tree51a47871874e5f95c5f5bba079fea4199b59f04d /textproc/xmlpull
parentd12a56ef2ddbff20fcec0d5f10cd1364e002c9ad (diff)
downloadports-d54e26320d84193b1f56e795d837aef015835955.tar.gz
ports-d54e26320d84193b1f56e795d837aef015835955.zip
Notes
Diffstat (limited to 'textproc/xmlpull')
-rw-r--r--textproc/xmlpull/Makefile54
-rw-r--r--textproc/xmlpull/distinfo2
-rw-r--r--textproc/xmlpull/pkg-descr18
3 files changed, 74 insertions, 0 deletions
diff --git a/textproc/xmlpull/Makefile b/textproc/xmlpull/Makefile
new file mode 100644
index 000000000000..d0ac6f3e2032
--- /dev/null
+++ b/textproc/xmlpull/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: xmlpull
+# Date created: 2004-03-30
+# Whom: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlpull
+PORTVERSION= 1.1.3.4a
+CATEGORIES= textproc java
+MASTER_SITES= http://www.xmlpull.org/v1/download/
+DISTNAME= ${DISTNAME_PREFX}_src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= herve.quiroz@esil.univ-mrs.fr
+COMMENT= Common API for XML Pull Parsing (XmlPull)
+
+BUILD_DEPENDS= ${ANT}:${PORTSDIR}/devel/apache-ant
+
+USE_JAVA= 1.3+
+DISTNAME_PREFX= ${PORTNAME}_${PORTVERSION:S/./_/g}
+WRKSRC= ${WRKDIR}/${DISTNAME_PREFX}
+
+ANT?= ${LOCALBASE}/bin/ant
+ANT_TARGET= jar
+.if !defined(NOPORTDOCS)
+ANT_TARGET+= javadoc
+PORTDOCS= ABOUT.txt README_DOWNLOAD.html THANKS.txt addons.html \
+ api_impl build.txt changes.html faq.html features.html \
+ javadoc_stylesheet.css properties.html quick_intro.html \
+ quick_write.html run.txt
+.endif
+JARFILE= ${DISTNAME_PREFX}.jar
+DESTJARFILE= ${PORTNAME}.jar
+PLIST_FILES+= ${JAVAJARDIR:S,^${PREFIX}/,,}/${DESTJARFILE}
+
+do-build:
+ @cd ${WRKSRC} && ${ANT} ${ANT_TARGET}
+
+do-install:
+ @${ECHO_CMD} -n ">> Installing JAR as ${JAVAJARDIR}/${DESTJARFILE}..."
+ @${CP} ${WRKSRC}/build/lib/${JARFILE} ${JAVAJARDIR}/${DESTJARFILE}
+ @${ECHO_CMD} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_CMD} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+.for DOCFILE in ${PORTDOCS}
+ @${CP} -r ${WRKSRC}/doc/${DOCFILE} ${DOCSDIR}/
+ @${ECHO_CMD} -n " ${DOCFILE}"
+.endfor
+ @${ECHO_CMD} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/xmlpull/distinfo b/textproc/xmlpull/distinfo
new file mode 100644
index 000000000000..b8633bb488d4
--- /dev/null
+++ b/textproc/xmlpull/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmlpull_1_1_3_4a_src.tgz) = 777cb6c9f732ba6de60d480ebdfede3a
+SIZE (xmlpull_1_1_3_4a_src.tgz) = 130319
diff --git a/textproc/xmlpull/pkg-descr b/textproc/xmlpull/pkg-descr
new file mode 100644
index 000000000000..f539d0cb13c0
--- /dev/null
+++ b/textproc/xmlpull/pkg-descr
@@ -0,0 +1,18 @@
+Common API for XML Pull Parsing (XmlPull) is an effort to define a simple and
+elegant pull parsing API that will provide a standardized way to do pull XML
+parsing from J2ME to J2EE.
+
+It is a minimalist API: very easy to implement standalone or on top of existing
+parser. The API allows both fast high level iteration (using next() method) and
+low level tokenizing (using nextToken() token) and is designed for easy
+building on top of it SAX, XML pull parsers that uses iterators with event
+objects, or even DOM implementations. To support J2ME and real small
+implementation parsing of DOCDECL is optional (but DOCDECL can be reported if
+requested).
+
+The aim is to provide a similar but orthogonal pull parsing basis to widely
+successful push parsing SAX API. The XmlPull API is in public domain in hope
+that it will be embraced by Java developers (conformance tests are under LGPL
+license to minimize risk of incompatible implementations).
+
+WWW: http://www.xmlpull.org