aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlroff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2005-06-14 18:17:57 +0000
committerHiroki Sato <hrs@FreeBSD.org>2005-06-14 18:17:57 +0000
commite01a593485cff8e694b319b3c44cf00ce548a354 (patch)
treeeefa0bab3fcd62d7bc5f4ff97d99d7b3cf906630 /textproc/xmlroff
parentea45f63c5c85262431d08134e27dffb36a2741b0 (diff)
downloadports-e01a593485cff8e694b319b3c44cf00ce548a354.tar.gz
ports-e01a593485cff8e694b319b3c44cf00ce548a354.zip
Notes
Diffstat (limited to 'textproc/xmlroff')
-rw-r--r--textproc/xmlroff/Makefile4
-rw-r--r--textproc/xmlroff/distinfo4
-rw-r--r--textproc/xmlroff/files/patch-expr::fo-expr-eval.c170
-rw-r--r--textproc/xmlroff/files/patch-fo-context-util.c158
-rw-r--r--textproc/xmlroff/files/patch-libfo::fo-doc-gp.c26
-rw-r--r--textproc/xmlroff/files/patch-property::fo-property-util.c29
-rw-r--r--textproc/xmlroff/pkg-plist25
7 files changed, 297 insertions, 119 deletions
diff --git a/textproc/xmlroff/Makefile b/textproc/xmlroff/Makefile
index 4e2f108dfb25..effdfdbacbd9 100644
--- a/textproc/xmlroff/Makefile
+++ b/textproc/xmlroff/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= xmlroff
-PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTVERSION= 0.3.3
+PORTREVISION= 0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/textproc/xmlroff/distinfo b/textproc/xmlroff/distinfo
index 07cada8a662e..a2516d0bbbf2 100644
--- a/textproc/xmlroff/distinfo
+++ b/textproc/xmlroff/distinfo
@@ -1,2 +1,2 @@
-MD5 (xmlroff-0.3.2.tar.gz) = 451907a30fa50ad1db00d540933c067a
-SIZE (xmlroff-0.3.2.tar.gz) = 2452081
+MD5 (xmlroff-0.3.3.tar.gz) = d826a67b71bae7b1eb4477f4868bc8c8
+SIZE (xmlroff-0.3.3.tar.gz) = 2472041
diff --git a/textproc/xmlroff/files/patch-expr::fo-expr-eval.c b/textproc/xmlroff/files/patch-expr::fo-expr-eval.c
index 53e064bfa0a8..f0693e272204 100644
--- a/textproc/xmlroff/files/patch-expr::fo-expr-eval.c
+++ b/textproc/xmlroff/files/patch-expr::fo-expr-eval.c
@@ -1,6 +1,43 @@
---- expr/fo-expr-eval.c.orig Mon Feb 28 20:55:34 2005
-+++ expr/fo-expr-eval.c Thu Mar 3 10:55:21 2005
-@@ -1240,14 +1240,22 @@
+--- expr/fo-expr-eval.c.orig Tue Apr 26 07:13:16 2005
++++ expr/fo-expr-eval.c Wed Jun 15 01:07:29 2005
+@@ -1283,6 +1283,9 @@
+ */
+
+ FoDatatype *result_datatype = NULL;
++ FoDatatype *stack_second = NULL;
++ FoDatatype *stack_third = NULL;
++ FoDatatype *stack_fourth = NULL;
+
+ /* First stack entry */
+ FoDatatype *stack_first = fo_expr_context_pop_stack (context);
+@@ -1304,7 +1307,7 @@
+ }
+
+ /* Second stack entry */
+- FoDatatype *stack_second = fo_expr_context_pop_stack (context);
++ stack_second = fo_expr_context_pop_stack (context);
+
+ /* Handle possible conditions for second stack entry. */
+ if (stack_second == NULL)
+@@ -1324,7 +1327,7 @@
+ }
+
+ /* third stack entry */
+- FoDatatype *stack_third = fo_expr_context_pop_stack (context);
++ stack_third = fo_expr_context_pop_stack (context);
+
+ /* Handle possible conditions for third stack entry. */
+ if (stack_third == NULL)
+@@ -1344,7 +1347,7 @@
+ }
+
+ /* fourth stack entry */
+- FoDatatype *stack_fourth = fo_expr_context_pop_stack (context);
++ stack_fourth = fo_expr_context_pop_stack (context);
+
+ /* Handle possible conditions for fourth stack entry. */
+ if (stack_fourth == NULL)
+@@ -1383,9 +1386,11 @@
static void
eval_padding_expr (FoExprContext *context)
{
@@ -13,107 +50,44 @@
if (name == NULL)
{
- /* If not a name, then one to four <padding-width> values. */
-
-+ FoDatatype *result_datatype;
-+ FoDatatype *stack_first;
-+ FoDatatype *stack_second;
-+ FoDatatype *stack_third;
-+ FoDatatype *stack_fourth;
-+
- do
- {
- FoDatatype *intermediate_value = NULL;
-@@ -1345,10 +1353,10 @@
- * A fifth entry on the stack indicates an error.
- */
-
-- FoDatatype *result_datatype = NULL;
-+ result_datatype = NULL;
-
- /* First stack entry */
-- FoDatatype *stack_first = fo_expr_context_pop_stack (context);
-+ stack_first = fo_expr_context_pop_stack (context);
-
- /* Handle possible conditions for top stack entry. */
- if (stack_first == NULL)
-@@ -1367,7 +1375,7 @@
- }
-
- /* Second stack entry */
-- FoDatatype *stack_second = fo_expr_context_pop_stack (context);
-+ stack_second = fo_expr_context_pop_stack (context);
-
- /* Handle possible conditions for second stack entry. */
- if (stack_second == NULL)
-@@ -1387,7 +1395,7 @@
- }
-
- /* third stack entry */
-- FoDatatype *stack_third = fo_expr_context_pop_stack (context);
-+ stack_third = fo_expr_context_pop_stack (context);
-
- /* Handle possible conditions for third stack entry. */
- if (stack_third == NULL)
-@@ -1407,7 +1415,7 @@
- }
-
- /* fourth stack entry */
-- FoDatatype *stack_fourth = fo_expr_context_pop_stack (context);
-+ stack_fourth = fo_expr_context_pop_stack (context);
-
- /* Handle possible conditions for fourth stack entry. */
- if (stack_fourth == NULL)
-@@ -1575,6 +1583,12 @@
- static void
- eval_border_color_expr (FoExprContext *context)
- {
-+ FoDatatype *result_datatype = NULL;
-+ FoDatatype *stack_first;
-+ FoDatatype *stack_second;
-+ FoDatatype *stack_third;
-+ FoDatatype *stack_fourth;
-+
+@@ -1745,11 +1750,12 @@
/* If not 'inherit', then one to four <color> or 'transparent' values. */
do
{
-@@ -1658,10 +1672,10 @@
- * A fifth entry on the stack indicates an error.
- */
-
-- FoDatatype *result_datatype = NULL;
-+ result_datatype = NULL;
-
- /* First stack entry */
-- FoDatatype *stack_first = fo_expr_context_pop_stack (context);
-+ stack_first = fo_expr_context_pop_stack (context);
-
- /* Handle possible conditions for top stack entry. */
- if (stack_first == NULL)
-@@ -1680,7 +1694,7 @@
- }
-
- /* Second stack entry */
-- FoDatatype *stack_second = fo_expr_context_pop_stack (context);
-+ stack_second = fo_expr_context_pop_stack (context);
-
- /* Handle possible conditions for second stack entry. */
- if (stack_second == NULL)
-@@ -1700,7 +1714,7 @@
++ gchar *name;
+ FoDatatype *intermediate_value = NULL;
+
+ fo_expr_context_skip_blanks (context);
+
+- gchar *name = parse_ncname (context);
++ name = parse_ncname (context);
+
+ if (name != NULL)
+ {
+@@ -1902,6 +1908,8 @@
+ FoDatatype *width_datatype = NULL;
+ FoDatatype *style_datatype = NULL;
+ FoDatatype *color_datatype = NULL;
++ FoDatatype *stack_second;
++ FoDatatype *stack_third;
+
+ /* First stack entry */
+ FoDatatype *stack_first = fo_expr_context_pop_stack (context);
+@@ -1941,7 +1949,7 @@
}
- /* third stack entry */
-- FoDatatype *stack_third = fo_expr_context_pop_stack (context);
-+ stack_third = fo_expr_context_pop_stack (context);
+ /* Second stack entry */
+- FoDatatype *stack_second = fo_expr_context_pop_stack (context);
++ stack_second = fo_expr_context_pop_stack (context);
- /* Handle possible conditions for third stack entry. */
- if (stack_third == NULL)
-@@ -1720,7 +1734,7 @@
+ /* Handle possible conditions for second stack entry. */
+ if (stack_second == NULL)
+@@ -1984,7 +1992,7 @@
}
- /* fourth stack entry */
-- FoDatatype *stack_fourth = fo_expr_context_pop_stack (context);
-+ stack_fourth = fo_expr_context_pop_stack (context);
+ /* Third stack entry */
+- FoDatatype *stack_third = fo_expr_context_pop_stack (context);
++ stack_third = fo_expr_context_pop_stack (context);
- /* Handle possible conditions for fourth stack entry. */
- if (stack_fourth == NULL)
+ /* Handle possible conditions for third stack entry. */
+ if (stack_third == NULL)
diff --git a/textproc/xmlroff/files/patch-fo-context-util.c b/textproc/xmlroff/files/patch-fo-context-util.c
index 6e977867231b..ea5baf2d92ef 100644
--- a/textproc/xmlroff/files/patch-fo-context-util.c
+++ b/textproc/xmlroff/files/patch-fo-context-util.c
@@ -1,6 +1,6 @@
---- fo-context-util.c.orig Mon Jan 10 14:05:08 2005
-+++ fo-context-util.c Mon Jan 10 14:05:42 2005
-@@ -922,6 +922,8 @@
+--- fo-context-util.c.orig Mon May 2 04:22:17 2005
++++ fo-context-util.c Wed Jun 15 01:28:36 2005
+@@ -926,6 +926,8 @@
FoContextPropertyFunc absolute_func;
FoContextPropertyFunc relative_func;
FoDatatype *shorthand_component;
@@ -9,7 +9,7 @@
g_return_if_fail (current_context != NULL);
g_return_if_fail (parent_context != NULL);
-@@ -933,9 +935,9 @@
+@@ -937,9 +939,9 @@
0);
*/
@@ -21,3 +21,153 @@
if (padding != NULL)
{
+@@ -1207,6 +1209,31 @@
+ FoProperty *prop_color;
+ FoDatatype *initial_color;
+
++ FoProperty *border_color;
++ FoDatatype *border_color_tblr;
++ FoDatatype *border_color_component;
++ FoProperty *border_style;
++ FoDatatype *border_style_tblr;
++ FoDatatype *border_style_component;
++ FoProperty *border_width;
++ FoDatatype *border_width_tblr;
++ FoDatatype *border_width_component;
++ FoProperty *border;
++ FoDatatype *border_wsc;
++ FoDatatype *border_component;
++ FoProperty *border_bottom;
++ FoDatatype *border_bottom_wsc;
++ FoDatatype *border_bottom_component;
++ FoProperty *border_left;
++ FoDatatype *border_left_wsc;
++ FoDatatype *border_left_component;
++ FoProperty *border_right;
++ FoDatatype *border_right_wsc;
++ FoDatatype *border_right_component;
++ FoProperty *border_top;
++ FoDatatype *border_top_wsc;
++ FoDatatype *border_top_component;
++
+ g_return_if_fail (current_context != NULL);
+ g_return_if_fail (parent_context != NULL);
+ g_return_if_fail (FO_IS_CONTEXT (current_context));
+@@ -1223,93 +1250,93 @@
+
+ initial_color = fo_property_get_value (prop_color);
+
+- FoProperty *border_color = fo_context_get_border_color (current_context);
++ border_color = fo_context_get_border_color (current_context);
+
+- FoDatatype *border_color_tblr = NULL;
++ border_color_tblr = NULL;
+
+ if (border_color != NULL)
+ {
+ border_color_tblr = fo_property_get_value (border_color);
+ }
+
+- FoDatatype *border_color_component;
++ border_color_component;
+
+- FoProperty *border_style = fo_context_get_border_style (current_context);
++ border_style = fo_context_get_border_style (current_context);
+
+- FoDatatype *border_style_tblr = NULL;
++ border_style_tblr = NULL;
+
+ if (border_style != NULL)
+ {
+ border_style_tblr = fo_property_get_value (border_style);
+ }
+
+- FoDatatype *border_style_component;
++ border_style_component;
+
+- FoProperty *border_width = fo_context_get_border_width (current_context);
++ border_width = fo_context_get_border_width (current_context);
+
+- FoDatatype *border_width_tblr = NULL;
++ border_width_tblr = NULL;
+
+ if (border_width != NULL)
+ {
+ border_width_tblr = fo_property_get_value (border_width);
+ }
+
+- FoDatatype *border_width_component;
++ border_width_component;
+
+- FoProperty *border = fo_context_get_border (current_context);
++ border = fo_context_get_border (current_context);
+
+- FoDatatype *border_wsc = NULL;
++ border_wsc = NULL;
+
+ if (border != NULL)
+ {
+ border_wsc = fo_property_get_value (border);
+ }
+
+- FoDatatype *border_component;
++ border_component;
+
+- FoProperty *border_bottom = fo_context_get_border_bottom (current_context);
++ border_bottom = fo_context_get_border_bottom (current_context);
+
+- FoDatatype *border_bottom_wsc = NULL;
++ border_bottom_wsc = NULL;
+
+ if (border_bottom != NULL)
+ {
+ border_bottom_wsc = fo_property_get_value (border_bottom);
+ }
+
+- FoDatatype *border_bottom_component;
++ border_bottom_component;
+
+- FoProperty *border_left = fo_context_get_border_left (current_context);
++ border_left = fo_context_get_border_left (current_context);
+
+- FoDatatype *border_left_wsc = NULL;
++ border_left_wsc = NULL;
+
+ if (border_left != NULL)
+ {
+ border_left_wsc = fo_property_get_value (border_left);
+ }
+
+- FoDatatype *border_left_component;
++ border_left_component;
+
+- FoProperty *border_right = fo_context_get_border_right (current_context);
++ border_right = fo_context_get_border_right (current_context);
+
+- FoDatatype *border_right_wsc = NULL;
++ border_right_wsc = NULL;
+
+ if (border_right != NULL)
+ {
+ border_right_wsc = fo_property_get_value (border_right);
+ }
+
+- FoDatatype *border_right_component;
++ border_right_component;
+
+- FoProperty *border_top = fo_context_get_border_top (current_context);
++ border_top = fo_context_get_border_top (current_context);
+
+- FoDatatype *border_top_wsc = NULL;
++ border_top_wsc = NULL;
+
+ if (border_top != NULL)
+ {
+ border_top_wsc = fo_property_get_value (border_top);
+ }
+
+- FoDatatype *border_top_component;
++ border_top_component;
+
+ /* left = start*/
+ /* style */
diff --git a/textproc/xmlroff/files/patch-libfo::fo-doc-gp.c b/textproc/xmlroff/files/patch-libfo::fo-doc-gp.c
index 9fedac71a901..39368fbac1e3 100644
--- a/textproc/xmlroff/files/patch-libfo::fo-doc-gp.c
+++ b/textproc/xmlroff/files/patch-libfo::fo-doc-gp.c
@@ -1,6 +1,22 @@
---- libfo/fo-doc-gp.c.orig Mon Jan 10 13:49:31 2005
-+++ libfo/fo-doc-gp.c Mon Jan 10 13:50:19 2005
-@@ -1065,6 +1065,9 @@
+--- libfo/fo-doc-gp.c.orig Thu Mar 31 16:36:10 2005
++++ libfo/fo-doc-gp.c Tue Jun 14 21:11:30 2005
+@@ -1143,6 +1143,7 @@
+ gint y)
+ {
+ PangoLayoutIter *iter;
++ gint line_number = -1;
+
+ g_return_if_fail (context != NULL);
+ g_return_if_fail (PANGO_IS_LAYOUT (layout));
+@@ -1152,7 +1153,6 @@
+
+ iter = pango_layout_get_iter (layout);
+
+- gint line_number = -1;
+ do
+ {
+ PangoRectangle logical_rect;
+@@ -1202,6 +1202,9 @@
gfloat x,
gfloat y)
{
@@ -10,7 +26,7 @@
g_return_if_fail (FO_IS_DOC_GP (fo_doc));
g_return_if_fail (FO_DOC_GP (fo_doc)->context != NULL);
g_return_if_fail (FO_IS_AREA_LAYOUT (area_layout));
-@@ -1076,9 +1079,9 @@
+@@ -1213,9 +1216,9 @@
* lines that are to be rendered.
*/
@@ -22,7 +38,7 @@
if (line_first > 0)
{
y1 =
-@@ -1086,12 +1089,12 @@
+@@ -1223,12 +1226,12 @@
line_first - 1);
}
diff --git a/textproc/xmlroff/files/patch-property::fo-property-util.c b/textproc/xmlroff/files/patch-property::fo-property-util.c
new file mode 100644
index 000000000000..b18f0139cde6
--- /dev/null
+++ b/textproc/xmlroff/files/patch-property::fo-property-util.c
@@ -0,0 +1,29 @@
+--- property/fo-property-util.c.orig Tue Apr 26 04:09:35 2005
++++ property/fo-property-util.c Tue Jun 14 22:22:38 2005
+@@ -1866,6 +1866,8 @@
+ FoContext *context,
+ GError **error)
+ {
++ FoDatatype *new_style;
++ FoDatatype *new_color;
+ g_return_val_if_fail (datatype != NULL, NULL);
+ g_return_val_if_fail (FO_IS_DATATYPE (datatype), NULL);
+ g_return_val_if_fail (context != NULL, NULL);
+@@ -1886,7 +1888,7 @@
+ return NULL;
+ }
+
+- FoDatatype *new_style =
++ new_style =
+ fo_property_util_validate_style (fo_wsc_get_style (datatype),
+ context,
+ &tmp_error);
+@@ -1897,7 +1899,7 @@
+ return NULL;
+ }
+
+- FoDatatype *new_color =
++ new_color =
+ fo_property_util_validate_color_transparent (fo_wsc_get_color (datatype),
+ context,
+ &tmp_error);
diff --git a/textproc/xmlroff/pkg-plist b/textproc/xmlroff/pkg-plist
index 3d77294f69e9..c56e216a1c74 100644
--- a/textproc/xmlroff/pkg-plist
+++ b/textproc/xmlroff/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
bin/xmlroff
include/libfo-0.3/area/fo-area.h
include/libfo-0.3/datatype/fo-datatype.h
@@ -29,7 +30,7 @@ include/libfo-0.3/property/fo-property.h
include/libfo-0.3/util/fo-hash-table.h
lib/libfo-0.3.a
lib/libfo-0.3.so
-lib/libfo-0.3.so.300
+lib/libfo-0.3.so.303
libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/FoArea.html
%%DOCSDIR%%/FoAreaArea.html
@@ -274,7 +275,6 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-FoDocGP.html
%%DOCSDIR%%/xmlroff-FoError.html
%%DOCSDIR%%/xmlroff-FoFontDesc.html
-%%DOCSDIR%%/xmlroff-FoHashTable.html
%%DOCSDIR%%/xmlroff-FoLayout.html
%%DOCSDIR%%/xmlroff-FoLibfoContext.html
%%DOCSDIR%%/xmlroff-FoNeutralFoIface.html
@@ -287,7 +287,6 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-block-progression-dimensionmaximum.html
%%DOCSDIR%%/xmlroff-block-progression-dimensionminimum.html
%%DOCSDIR%%/xmlroff-block-progression-dimensionoptimum.html
-%%DOCSDIR%%/xmlroff-border.html
%%DOCSDIR%%/xmlroff-float.html
%%DOCSDIR%%/xmlroff-fo-block-area.html
%%DOCSDIR%%/xmlroff-fo-block-block-area.html
@@ -320,7 +319,6 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-keep-with-previouswithin-page.html
%%DOCSDIR%%/xmlroff-marker.html
%%DOCSDIR%%/xmlroff-multi-case.html
-%%DOCSDIR%%/xmlroff-multi-properties.html
%%DOCSDIR%%/xmlroff-multi-switch.html
%%DOCSDIR%%/xmlroff-repeatable-page-master-alternatives.html
%%DOCSDIR%%/xmlroff-repeatable-page-master-reference.html
@@ -345,10 +343,21 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-space-startoptimum.html
%%DOCSDIR%%/xmlroff-space-startprecedence.html
%%DOCSDIR%%/xmlroff.devhelp
-share/xml/libfo-0.3.1/catalog.xml
-share/xml/libfo-0.3.1/libfo-compat.xsl
-share/xml/libfo-0.3.1/xmlroff.fo
-@dirrm share/xml/libfo-0.3.1
+%%DOCSDIR%%/FoHashTable.html
+%%DOCSDIR%%/border.html
+%%DOCSDIR%%/multi-properties.html
+%%DOCSDIR%%/xmlroff-FoTblr.html
+%%DOCSDIR%%/xmlroff-FoWsc.html
+%%DOCSDIR%%/xmlroff-border-bottom.html
+%%DOCSDIR%%/xmlroff-border-left.html
+%%DOCSDIR%%/xmlroff-border-right.html
+%%DOCSDIR%%/xmlroff-border-style.html
+%%DOCSDIR%%/xmlroff-border-top.html
+%%DOCSDIR%%/xmlroff-border-width.html
+share/xml/libfo-0.3.3/catalog.xml
+share/xml/libfo-0.3.3/libfo-compat.xsl
+share/xml/libfo-0.3.3/xmlroff.fo
+@dirrm share/xml/libfo-0.3.3
@unexec rmdir %D/share/xml 2>/dev/null || true
@dirrm %%DOCSDIR%%
@dirrm include/libfo-0.3/util