aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlroff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2006-01-30 15:06:14 +0000
committerHiroki Sato <hrs@FreeBSD.org>2006-01-30 15:06:14 +0000
commitacc76dbe442be2f554595b134d78ec3ef53d4097 (patch)
tree900ed0ada000c58a5a404c12c1fcdb0c5a10df98 /textproc/xmlroff
parent4537b6d6cddc6503a8aaeeab387636d69d520270 (diff)
downloadports-acc76dbe442be2f554595b134d78ec3ef53d4097.tar.gz
ports-acc76dbe442be2f554595b134d78ec3ef53d4097.zip
Notes
Diffstat (limited to 'textproc/xmlroff')
-rw-r--r--textproc/xmlroff/Makefile4
-rw-r--r--textproc/xmlroff/distinfo6
-rw-r--r--textproc/xmlroff/files/patch-fo-fo-block-area.c19
-rw-r--r--textproc/xmlroff/files/patch-fo-fo-repeatable-page-master-alternatives.c17
-rw-r--r--textproc/xmlroff/files/patch-fo-fo-table.c19
-rw-r--r--textproc/xmlroff/files/patch-property-fo-property-dominant-baseline.c28
-rw-r--r--textproc/xmlroff/files/patch-property-fo-property-font-family.c18
-rw-r--r--textproc/xmlroff/files/patch-property-fo-property-id.c15
-rw-r--r--textproc/xmlroff/pkg-plist49
9 files changed, 148 insertions, 27 deletions
diff --git a/textproc/xmlroff/Makefile b/textproc/xmlroff/Makefile
index 1ad37410264b..112c5d082e0c 100644
--- a/textproc/xmlroff/Makefile
+++ b/textproc/xmlroff/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= xmlroff
-PORTVERSION= 0.3.3
-PORTREVISION= 1
+PORTVERSION= 0.3.8
+PORTREVISION= 0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/textproc/xmlroff/distinfo b/textproc/xmlroff/distinfo
index f26be69d1e4b..c6bcaba39615 100644
--- a/textproc/xmlroff/distinfo
+++ b/textproc/xmlroff/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmlroff-0.3.3.tar.gz) = d826a67b71bae7b1eb4477f4868bc8c8
-SHA256 (xmlroff-0.3.3.tar.gz) = b377be29288f62c3057c799e231b7f728eaaad3546700c9b858984db78461e7a
-SIZE (xmlroff-0.3.3.tar.gz) = 2472041
+MD5 (xmlroff-0.3.8.tar.gz) = 58c8995b7c5750806e2fd3a5ce8ad623
+SHA256 (xmlroff-0.3.8.tar.gz) = 3fb17fe3bac3015e499e7d63ccff78b2f8b23dcb0aafed399bbee1b00ac0b843
+SIZE (xmlroff-0.3.8.tar.gz) = 2557105
diff --git a/textproc/xmlroff/files/patch-fo-fo-block-area.c b/textproc/xmlroff/files/patch-fo-fo-block-area.c
new file mode 100644
index 000000000000..e261d8bf0d2c
--- /dev/null
+++ b/textproc/xmlroff/files/patch-fo-fo-block-area.c
@@ -0,0 +1,19 @@
+--- fo/fo-block-area.c.orig Mon Jan 30 21:55:41 2006
++++ fo/fo-block-area.c Mon Jan 30 21:56:28 2006
+@@ -222,6 +222,7 @@
+ GSList *line_heights = NULL;
+ gint line_count, line_index;
+ gint cumulative_height = 0;
++ gchar *font_family = NULL;
+
+ g_return_if_fail (block != NULL);
+ g_return_if_fail (FO_IS_BLOCK (block));
+@@ -312,7 +313,7 @@
+ font_desc =
+ fo_font_desc_copy (fo_doc_get_font_desc (fo_doc));
+
+- gchar *font_family = fo_string_get_value (fo_property_get_value (fo_block_get_font_family (block)));
++ font_family = fo_string_get_value (fo_property_get_value (fo_block_get_font_family (block)));
+ fo_font_desc_set_family (font_desc, font_family);
+ g_free (font_family);
+
diff --git a/textproc/xmlroff/files/patch-fo-fo-repeatable-page-master-alternatives.c b/textproc/xmlroff/files/patch-fo-fo-repeatable-page-master-alternatives.c
new file mode 100644
index 000000000000..c5cbd35bbea7
--- /dev/null
+++ b/textproc/xmlroff/files/patch-fo-fo-repeatable-page-master-alternatives.c
@@ -0,0 +1,17 @@
+--- fo/fo-repeatable-page-master-alternatives.c.orig Mon Jan 30 21:58:24 2006
++++ fo/fo-repeatable-page-master-alternatives.c Mon Jan 30 21:58:43 2006
+@@ -131,12 +131,13 @@
+ GError **error)
+ {
+ GError *tmp_error = NULL;
++ FoNode *child_node = NULL;
+
+ g_return_val_if_fail (fo != NULL, TRUE);
+ g_return_val_if_fail (FO_IS_REPEATABLE_PAGE_MASTER_ALTERNATIVES (fo), TRUE);
+ g_return_val_if_fail (error == NULL || *error == NULL, TRUE);
+
+- FoNode *child_node = fo_node_first_child (FO_NODE (fo));
++ child_node = fo_node_first_child (FO_NODE (fo));
+
+ while (child_node)
+ {
diff --git a/textproc/xmlroff/files/patch-fo-fo-table.c b/textproc/xmlroff/files/patch-fo-fo-table.c
new file mode 100644
index 000000000000..2c95040f7263
--- /dev/null
+++ b/textproc/xmlroff/files/patch-fo-fo-table.c
@@ -0,0 +1,19 @@
+--- fo/fo-table.c.orig Mon Jan 30 21:59:46 2006
++++ fo/fo-table.c Mon Jan 30 22:00:08 2006
+@@ -1700,6 +1700,7 @@
+ FoDatatype *column_proportional = NULL;
+ FoContext *parent_context = NULL;
+ GError *tmp_error = NULL;
++ gchar *string_value = NULL;
+
+ g_return_val_if_fail (error == NULL || *error == NULL, NULL);
+
+@@ -1715,7 +1716,7 @@
+ parent_context =
+ fo_fo_get_context (FO_FO (fo_node_parent (FO_NODE (table_column))));
+
+- gchar *string_value = fo_string_get_value (column_width_string);
++ string_value = fo_string_get_value (column_width_string);
+ column_proportional =
+ fo_expr_eval (string_value,
+ "column-width",
diff --git a/textproc/xmlroff/files/patch-property-fo-property-dominant-baseline.c b/textproc/xmlroff/files/patch-property-fo-property-dominant-baseline.c
new file mode 100644
index 000000000000..7d4e8d583cb1
--- /dev/null
+++ b/textproc/xmlroff/files/patch-property-fo-property-dominant-baseline.c
@@ -0,0 +1,28 @@
+--- property/fo-property-dominant-baseline.c.orig Mon Jan 30 22:02:19 2006
++++ property/fo-property-dominant-baseline.c Mon Jan 30 22:03:47 2006
+@@ -453,12 +453,15 @@
+
+ if (dominant_baseline != FO_ENUM_ENUM_RESET_SIZE)
+ {
++ gchar *font_family = NULL;
++ PangoAttribute *pango_attr = NULL;
++
+ PangoBaseline pango_dominant_baseline =
+ fo_property_dominant_baseline_to_pango_baseline (dominant_baseline);
+
+ font_desc = pango_font_description_new ();
+
+- gchar *font_family = fo_string_get_value (fo_property_get_value (fo_context_get_font_family (context)));
++ font_family = fo_string_get_value (fo_property_get_value (fo_context_get_font_family (context)));
+ pango_font_description_set_family (font_desc, font_family);
+ g_free (font_family);
+
+@@ -473,7 +476,7 @@
+ pango_font_description_set_variant (font_desc,
+ fo_enum_get_value (fo_property_get_value (fo_context_get_font_variant (context))));
+
+- PangoAttribute *pango_attr = pango_attr_dominant_baseline_new (pango_dominant_baseline,
++ pango_attr = pango_attr_dominant_baseline_new (pango_dominant_baseline,
+ font_desc);
+ pango_font_description_free (font_desc);
+ return pango_attr;
diff --git a/textproc/xmlroff/files/patch-property-fo-property-font-family.c b/textproc/xmlroff/files/patch-property-fo-property-font-family.c
new file mode 100644
index 000000000000..91f22eaf4f0f
--- /dev/null
+++ b/textproc/xmlroff/files/patch-property-fo-property-font-family.c
@@ -0,0 +1,18 @@
+--- property/fo-property-font-family.c.orig Mon Jan 30 23:43:52 2006
++++ property/fo-property-font-family.c Mon Jan 30 23:45:58 2006
+@@ -475,13 +475,14 @@
+ fo_property_font_family_new_attr (FoProperty *property)
+ {
+ gchar *pango_font_family;
++ PangoAttribute *pango_attr = NULL;
+
+ g_return_val_if_fail (FO_IS_PROPERTY_FONT_FAMILY (property), NULL);
+
+ pango_font_family =
+ fo_string_get_value (property->value);
+
+- PangoAttribute *pango_attr = pango_attr_family_new (pango_font_family);
++ pango_attr = pango_attr_family_new (pango_font_family);
+
+ g_free (pango_font_family);
+
diff --git a/textproc/xmlroff/files/patch-property-fo-property-id.c b/textproc/xmlroff/files/patch-property-fo-property-id.c
new file mode 100644
index 000000000000..ba2932843720
--- /dev/null
+++ b/textproc/xmlroff/files/patch-property-fo-property-id.c
@@ -0,0 +1,15 @@
+--- property/fo-property-id.c.orig Mon Jan 30 23:46:23 2006
++++ property/fo-property-id.c Mon Jan 30 23:46:44 2006
+@@ -262,10 +262,11 @@
+ {
+ static int count = 1;
+ FoProperty *id;
++ gchar *id_string = NULL;
+
+ id = fo_property_id_new ();
+
+- gchar * id_string = g_strdup_printf ("id-%d",
++ id_string = g_strdup_printf ("id-%d",
+ count++);
+ /* Set the initial value here */
+ fo_property_set_value (id,
diff --git a/textproc/xmlroff/pkg-plist b/textproc/xmlroff/pkg-plist
index cbf89be9750b..95cd35d9367a 100644
--- a/textproc/xmlroff/pkg-plist
+++ b/textproc/xmlroff/pkg-plist
@@ -28,9 +28,11 @@ include/libfo-0.3/libfo/fo-xsl-formatter.h
include/libfo-0.3/libfo/fo-xslt-transformer.h
include/libfo-0.3/property/fo-property.h
include/libfo-0.3/util/fo-hash-table.h
+include/libfo-0.3/util/fo-image.h
+include/libfo-0.3/util/fo-pixbuf.h
lib/libfo-0.3.a
lib/libfo-0.3.so
-lib/libfo-0.3.so.303
+lib/libfo-0.3.so.306
libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/FoArea.html
%%DOCSDIR%%/FoAreaArea.html
@@ -63,6 +65,7 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/FoEnum.html
%%DOCSDIR%%/FoExpression.html
%%DOCSDIR%%/FoFo.html
+%%DOCSDIR%%/FoHashTable.html
%%DOCSDIR%%/FoId.html
%%DOCSDIR%%/FoInlineFoIface.html
%%DOCSDIR%%/FoInteger.html
@@ -129,6 +132,7 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/border-top-color.html
%%DOCSDIR%%/border-top-style.html
%%DOCSDIR%%/border-top-width.html
+%%DOCSDIR%%/border.html
%%DOCSDIR%%/break-after.html
%%DOCSDIR%%/break-before.html
%%DOCSDIR%%/ch02.html
@@ -139,13 +143,14 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/column-number.html
%%DOCSDIR%%/column-width.html
%%DOCSDIR%%/conditional-page-master-reference.html
+%%DOCSDIR%%/conformance.html
%%DOCSDIR%%/content-height.html
%%DOCSDIR%%/content-type.html
%%DOCSDIR%%/content-width.html
%%DOCSDIR%%/context.html
%%DOCSDIR%%/datatypes.html
-%%DOCSDIR%%/declarations.html
%%DOCSDIR%%/debugging.html
+%%DOCSDIR%%/declarations.html
%%DOCSDIR%%/direction.html
%%DOCSDIR%%/directory-structure.html
%%DOCSDIR%%/display-align.html
@@ -164,7 +169,6 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/footnote-body.html
%%DOCSDIR%%/format.html
%%DOCSDIR%%/formatting-objects.html
-%%DOCSDIR%%/generated-properties.html
%%DOCSDIR%%/generating-source.html
%%DOCSDIR%%/grouping-separator.html
%%DOCSDIR%%/grouping-size.html
@@ -200,6 +204,9 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/master-name.html
%%DOCSDIR%%/master-reference.html
%%DOCSDIR%%/media-usage.html
+%%DOCSDIR%%/multi-case.html
+%%DOCSDIR%%/multi-switch.html
+%%DOCSDIR%%/multi-properties.html
%%DOCSDIR%%/multi-property-set.html
%%DOCSDIR%%/multi-toggle.html
%%DOCSDIR%%/node.html
@@ -234,6 +241,8 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/region-end.html
%%DOCSDIR%%/region-name.html
%%DOCSDIR%%/region-start.html
+%%DOCSDIR%%/repeatable-page-master-alternatives.html
+%%DOCSDIR%%/repeatable-page-master-reference.html
%%DOCSDIR%%/right.png
%%DOCSDIR%%/role.html
%%DOCSDIR%%/root.html
@@ -275,11 +284,15 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-FoDocGP.html
%%DOCSDIR%%/xmlroff-FoError.html
%%DOCSDIR%%/xmlroff-FoFontDesc.html
+%%DOCSDIR%%/xmlroff-FoImage.html
%%DOCSDIR%%/xmlroff-FoLayout.html
%%DOCSDIR%%/xmlroff-FoLibfoContext.html
%%DOCSDIR%%/xmlroff-FoNeutralFoIface.html
%%DOCSDIR%%/xmlroff-FoPcw.html
+%%DOCSDIR%%/xmlroff-FoPixbuf.html
+%%DOCSDIR%%/xmlroff-FoTblr.html
%%DOCSDIR%%/xmlroff-FoWrapper.html
+%%DOCSDIR%%/xmlroff-FoWsc.html
%%DOCSDIR%%/xmlroff-FoXmlDoc.html
%%DOCSDIR%%/xmlroff-FoXslFormatter.html
%%DOCSDIR%%/xmlroff-FoXsltTransformer.html
@@ -287,6 +300,12 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-block-progression-dimensionmaximum.html
%%DOCSDIR%%/xmlroff-block-progression-dimensionminimum.html
%%DOCSDIR%%/xmlroff-block-progression-dimensionoptimum.html
+%%DOCSDIR%%/xmlroff-border-bottom.html
+%%DOCSDIR%%/xmlroff-border-left.html
+%%DOCSDIR%%/xmlroff-border-right.html
+%%DOCSDIR%%/xmlroff-border-style.html
+%%DOCSDIR%%/xmlroff-border-top.html
+%%DOCSDIR%%/xmlroff-border-width.html
%%DOCSDIR%%/xmlroff-float.html
%%DOCSDIR%%/xmlroff-fo-block-area.html
%%DOCSDIR%%/xmlroff-fo-block-block-area.html
@@ -297,6 +316,7 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-fo-list-item-area.html
%%DOCSDIR%%/xmlroff-fo-list-item-body-area.html
%%DOCSDIR%%/xmlroff-fo-list-item-label-area.html
+%%DOCSDIR%%/xmlroff-fo-marker-parent.html
%%DOCSDIR%%/xmlroff-fo-page-sequence-area.html
%%DOCSDIR%%/xmlroff-fo-property-border-color.html
%%DOCSDIR%%/xmlroff-fo-region-body-area.html
@@ -318,10 +338,6 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-keep-with-previouswithin-line.html
%%DOCSDIR%%/xmlroff-keep-with-previouswithin-page.html
%%DOCSDIR%%/xmlroff-marker.html
-%%DOCSDIR%%/xmlroff-multi-case.html
-%%DOCSDIR%%/xmlroff-multi-switch.html
-%%DOCSDIR%%/xmlroff-repeatable-page-master-alternatives.html
-%%DOCSDIR%%/xmlroff-repeatable-page-master-reference.html
%%DOCSDIR%%/xmlroff-space-afterconditionality.html
%%DOCSDIR%%/xmlroff-space-aftermaximum.html
%%DOCSDIR%%/xmlroff-space-afterminimum.html
@@ -343,21 +359,10 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-space-startoptimum.html
%%DOCSDIR%%/xmlroff-space-startprecedence.html
%%DOCSDIR%%/xmlroff.devhelp
-%%DOCSDIR%%/FoHashTable.html
-%%DOCSDIR%%/border.html
-%%DOCSDIR%%/multi-properties.html
-%%DOCSDIR%%/xmlroff-FoTblr.html
-%%DOCSDIR%%/xmlroff-FoWsc.html
-%%DOCSDIR%%/xmlroff-border-bottom.html
-%%DOCSDIR%%/xmlroff-border-left.html
-%%DOCSDIR%%/xmlroff-border-right.html
-%%DOCSDIR%%/xmlroff-border-style.html
-%%DOCSDIR%%/xmlroff-border-top.html
-%%DOCSDIR%%/xmlroff-border-width.html
-share/xml/libfo-0.3.3/catalog.xml
-share/xml/libfo-0.3.3/libfo-compat.xsl
-share/xml/libfo-0.3.3/xmlroff.fo
-@dirrm share/xml/libfo-0.3.3
+share/xml/libfo-0.3.8/catalog.xml
+share/xml/libfo-0.3.8/libfo-compat.xsl
+share/xml/libfo-0.3.8/xmlroff.fo
+@dirrm share/xml/libfo-0.3.8
@dirrmtry share/xml
@dirrm %%DOCSDIR%%
@dirrm include/libfo-0.3/util