aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlstarlet
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-20 13:19:39 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-20 13:19:39 +0000
commit867562b78900a1988d4a8060216b413e6e730f1e (patch)
tree826e7946230632ff915c93b2b513073adfbc2fa1 /textproc/xmlstarlet
parent5507476d30c9b38b88472322a84c888a4f84f9ec (diff)
downloadports-867562b78900a1988d4a8060216b413e6e730f1e.tar.gz
ports-867562b78900a1988d4a8060216b413e6e730f1e.zip
Notes
Diffstat (limited to 'textproc/xmlstarlet')
-rw-r--r--textproc/xmlstarlet/Makefile11
-rw-r--r--textproc/xmlstarlet/distinfo4
-rw-r--r--textproc/xmlstarlet/files/patch-configure11
3 files changed, 8 insertions, 18 deletions
diff --git a/textproc/xmlstarlet/Makefile b/textproc/xmlstarlet/Makefile
index 122c395784ab..af003d898bde 100644
--- a/textproc/xmlstarlet/Makefile
+++ b/textproc/xmlstarlet/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= xmlstarlet
-PORTVERSION= 0.9.1
+PORTVERSION= 0.9.5
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= xmlstar
@@ -17,19 +17,20 @@ COMMENT= Command Line XML Toolkit
BUILD_DEPENDS= ${LOCALBASE}/lib/libxml2.a:${PORTSDIR}/textproc/libxml2 \
${LOCALBASE}/lib/libxslt.a:${PORTSDIR}/textproc/libxslt
-USE_REINPLACE= yes
+
USE_ICONV= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libxml-prefix=${LOCALBASE} \
--with-libxslt-prefix=${LOCALBASE} \
--with-libiconv-prefix=${LOCALBASE}
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -liconv"
-PLIST_FILES= bin/xml
MAN1= xmlstarlet.1
+PLIST_FILES= bin/xml
post-patch:
- @${REINPLACE_CMD} -e "s,^CFLAGS,#CFLAGS," \
- -e "s,-lpthread,${PTHREAD_LIBS}," ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|^CFLAGS|#CFLAGS|g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/textproc/xmlstarlet/distinfo b/textproc/xmlstarlet/distinfo
index b7e861f187bf..cb1a9e59f699 100644
--- a/textproc/xmlstarlet/distinfo
+++ b/textproc/xmlstarlet/distinfo
@@ -1,2 +1,2 @@
-MD5 (xmlstarlet-0.9.1.tar.gz) = 62bc68b2d0c8fc688d1c3d999adc3a7a
-SIZE (xmlstarlet-0.9.1.tar.gz) = 300459
+MD5 (xmlstarlet-0.9.5.tar.gz) = 2887b267eac0d972a493b48a3926fd85
+SIZE (xmlstarlet-0.9.5.tar.gz) = 318081
diff --git a/textproc/xmlstarlet/files/patch-configure b/textproc/xmlstarlet/files/patch-configure
deleted file mode 100644
index 8624bc7a9eaa..000000000000
--- a/textproc/xmlstarlet/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Wed Jul 7 05:36:27 2004
-+++ configure Wed Jul 7 05:37:12 2004
-@@ -896,7 +896,7 @@
-
- if test "x$LIBXML_SRC" = "x"
- then
-- LIBXML_VERSION=`$LIBXML_PREFIX/bin/xml2-config --version | sed -e 's/\.//g' -e 's/^\(.\{3\}\).*/\1/'`
-+ LIBXML_VERSION=`$LIBXML_PREFIX/bin/xml2-config --version | sed -e 's/\.//g' -e 's/^\(.\{3,4\}\).*/\1/'`
- if test "$LIBXML_VERSION" -lt 262; then
- { echo "configure: error: xmlstarlet needs at least libxml2 version 2.6.2 (http://www.xmlsoft.org/)" 1>&2; exit 1; }
- fi