aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlwrapp/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-23 02:01:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-23 02:01:46 +0000
commit6b3e90e27059a10dab37bf65ef795f64953f45d4 (patch)
tree3e2cca61448fe80aa97400706bc3014619c47f59 /textproc/xmlwrapp/Makefile
parent28db248e2432528f9e97ff6e27ea34c6eb5a791c (diff)
Notes
Diffstat (limited to 'textproc/xmlwrapp/Makefile')
-rw-r--r--textproc/xmlwrapp/Makefile31
1 files changed, 21 insertions, 10 deletions
diff --git a/textproc/xmlwrapp/Makefile b/textproc/xmlwrapp/Makefile
index 37af9656e65d..132287d70022 100644
--- a/textproc/xmlwrapp/Makefile
+++ b/textproc/xmlwrapp/Makefile
@@ -7,37 +7,48 @@
#
PORTNAME= xmlwrapp
-PORTVERSION= 0.6.2
+PORTVERSION= 0.6.3
CATEGORIES= textproc
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A modern style C++ library for working with XML data
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= boost_iostreams.4:${PORTSDIR}/devel/boost-libs
OPTIONS= XSLT "build libxsltwrap library (requires libxslt)" off
-CONFIGURE_ARGS= --prefix ${PREFIX}
-CPPFLAGS+= -I${LOCALBASE}/include
+USE_GNOME= gnomehack libxml2 pkgconfig
+USE_PERL5_BUILD=yes
USE_AUTOTOOLS= libtool
-USE_GNOME= libxml2 pkgconfig gnomehack
-USE_PERL5_BUILD= yes
+CONFIGURE_ARGS= --disable-silent-rules
USE_LDCONFIG= yes
-WANT_GNOME= yes
-HAS_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.options.mk>
.if defined(WITH_XSLT)
USE_GNOME+= libxslt
+PLIST_SUB+= XSLT=""
.else
CONFIGURE_ARGS+=--disable-xslt
+PLIST_SUB+= XSLT="@comment "
.endif
post-patch:
-.if defined(NOPORTDOCS)
- ${REINPLACE_CMD} 's/docs//' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} '/if test/s|==|=|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} '/^SUBDIRS/s|docs||' ${WRKSRC}/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @(cd ${WRKSRC}/docs && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
.endif
.include <bsd.port.mk>