aboutsummaryrefslogtreecommitdiff
path: root/textproc/xpp3
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-04-04 18:03:12 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-04-04 18:03:12 +0000
commitfc09118e13ea186c29ae1383affbdbaf7db554b9 (patch)
treea0c3bf9e54941cc019946c2fb9d8201c681f1f67 /textproc/xpp3
parentb5d0f2f386c993175ef61175b87636eb2e1c37c1 (diff)
downloadports-fc09118e13ea186c29ae1383affbdbaf7db554b9.tar.gz
ports-fc09118e13ea186c29ae1383affbdbaf7db554b9.zip
Notes
Diffstat (limited to 'textproc/xpp3')
-rw-r--r--textproc/xpp3/Makefile54
-rw-r--r--textproc/xpp3/distinfo2
-rw-r--r--textproc/xpp3/pkg-descr15
3 files changed, 71 insertions, 0 deletions
diff --git a/textproc/xpp3/Makefile b/textproc/xpp3/Makefile
new file mode 100644
index 000000000000..c8668137eb78
--- /dev/null
+++ b/textproc/xpp3/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: xpp3
+# Date created: 2004-04-02
+# Whom: Herve Quiroz <root@arabica.esil.univ-mrs.fr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xpp3
+PORTVERSION= 1.1.3.4d.b4
+CATEGORIES= textproc java
+MASTER_SITES= http://www.extreme.indiana.edu/dist/java-repository/xpp3/distributions/
+DISTNAME= ${DISTNAME_PREFX}_src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= herve.quiroz@esil.univ-mrs.fr
+COMMENT= XML Pull Parser 3rd Edition (XPP3)
+
+BUILD_DEPENDS= ${ANT}:${PORTSDIR}/devel/apache-ant
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+
+DISTNAME_PREFX= ${PORTNAME}-${PORTVERSION:S/d.b/d_b/g}
+WRKSRC= ${WRKDIR}/${DISTNAME_PREFX}
+
+ANT?= ${LOCALBASE}/bin/ant
+ANT_TARGET= jar
+.if !defined(NOPORTDOCS)
+ANT_TARGET+= javadoc
+PORTDOCS= api_impl ABOUT.txt THANKS.txt TODO.html build.txt changes.html faq.html
+.endif
+JARFILE= ${DISTNAME_PREFX}.jar
+DESTJARFILE= ${PORTNAME}.jar
+PLIST_FILES+= ${JAVAJARDIR:S,^${PREFIX}/,,}/${DESTJARFILE}
+
+do-build:
+ @cd ${WRKSRC} && ${ANT} ${ANT_TARGET}
+
+do-install:
+ @${ECHO_CMD} -n ">> Installing JAR as ${JAVAJARDIR}/${DESTJARFILE}..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${CP} ${WRKSRC}/build/lib/${JARFILE} ${JAVAJARDIR}/${DESTJARFILE}
+ @${ECHO_CMD} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_CMD} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+.for DOCFILE in ${PORTDOCS}
+ @${CP} -r ${WRKSRC}/doc/${DOCFILE} ${DOCSDIR}/
+ @${ECHO_CMD} -n " ${DOCFILE}"
+.endfor
+ @${ECHO_CMD} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/xpp3/distinfo b/textproc/xpp3/distinfo
new file mode 100644
index 000000000000..999b3c522fb0
--- /dev/null
+++ b/textproc/xpp3/distinfo
@@ -0,0 +1,2 @@
+MD5 (xpp3-1.1.3.4d_b4_src.tgz) = aea178842db9ab3350c88738a9c0f545
+SIZE (xpp3-1.1.3.4d_b4_src.tgz) = 296155
diff --git a/textproc/xpp3/pkg-descr b/textproc/xpp3/pkg-descr
new file mode 100644
index 000000000000..689a8da978bd
--- /dev/null
+++ b/textproc/xpp3/pkg-descr
@@ -0,0 +1,15 @@
+MXP1 is a new XmlPull parsing engine that is based on ideas from XPP and in
+particular XPP2 but completely revised and rewritten to take best advantage of
+latest Java JIT JVMs such as Hotspot in JDK 1.4.
+
+MXP1 has following features:
+
+ - fast - let me say it again it is fast :-)
+ - small - lot of performance packed in JAR file that is less than 20KB!
+ - easy to use - the parser implements common XML pull parsing API (XMLPULL)
+ described at http://www.xmlpull.org
+
+Performance tests that compare MXP1 to other leading XML parsers are available
+at http://www.extreme.indiana.edu/~aslom/xpp_sax2bench/
+
+WWW: http://www.extreme.indiana.edu/soap/xpp/mxp1/