aboutsummaryrefslogtreecommitdiff
path: root/textproc/xqilla
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-11-10 14:22:22 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-11-10 14:22:22 +0000
commit7c6950f5c6cef8b5dfd16d98c072acdf084d290b (patch)
treede58362782f667d562c23056953a59faba24931f /textproc/xqilla
parent485d346367d00b42dd25dc6391152648a5c75609 (diff)
downloadports-7c6950f5c6cef8b5dfd16d98c072acdf084d290b.tar.gz
ports-7c6950f5c6cef8b5dfd16d98c072acdf084d290b.zip
Notes
Diffstat (limited to 'textproc/xqilla')
-rw-r--r--textproc/xqilla/Makefile2
-rw-r--r--textproc/xqilla/distinfo4
-rw-r--r--textproc/xqilla/pkg-plist74
3 files changed, 34 insertions, 46 deletions
diff --git a/textproc/xqilla/Makefile b/textproc/xqilla/Makefile
index f7cbd4367ca9..3b185794714a 100644
--- a/textproc/xqilla/Makefile
+++ b/textproc/xqilla/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xqilla
-PORTVERSION= 2.2.4
+PORTVERSION= 2.3.0
PORTEPOCH= 1
CATEGORIES= textproc
MASTER_SITES= SF
diff --git a/textproc/xqilla/distinfo b/textproc/xqilla/distinfo
index 3432b4f2dbb0..b2e1c4604823 100644
--- a/textproc/xqilla/distinfo
+++ b/textproc/xqilla/distinfo
@@ -1,2 +1,2 @@
-SHA256 (XQilla-2.2.4.tar.gz) = f39f8d11bca67ded2036d543bb6780ebeeee5b5723d75f067f256ae26516854b
-SIZE (XQilla-2.2.4.tar.gz) = 15667750
+SHA256 (XQilla-2.3.0.tar.gz) = 60e163cbbbe2900f999ee863bfa5a63d913b1d6e2ea17376302d565d2e9e1bc7
+SIZE (XQilla-2.3.0.tar.gz) = 7409736
diff --git a/textproc/xqilla/pkg-plist b/textproc/xqilla/pkg-plist
index 90a16b348c5b..a3b76eb3bc64 100644
--- a/textproc/xqilla/pkg-plist
+++ b/textproc/xqilla/pkg-plist
@@ -2,9 +2,9 @@ bin/xqilla
include/xqc.h
include/xqilla/ast/ASTNode.hpp
include/xqilla/ast/ASTNodeImpl.hpp
-include/xqilla/ast/ConstantFoldingFunction.hpp
include/xqilla/ast/ContextTuple.hpp
include/xqilla/ast/ConvertFunctionArg.hpp
+include/xqilla/ast/CountTuple.hpp
include/xqilla/ast/ForTuple.hpp
include/xqilla/ast/LetTuple.hpp
include/xqilla/ast/LocationInfo.hpp
@@ -14,7 +14,6 @@ include/xqilla/ast/StaticAnalysis.hpp
include/xqilla/ast/StaticType.hpp
include/xqilla/ast/TupleNode.hpp
include/xqilla/ast/WhereTuple.hpp
-include/xqilla/ast/XPath1Compat.hpp
include/xqilla/ast/XQAnalyzeString.hpp
include/xqilla/ast/XQApplyTemplates.hpp
include/xqilla/ast/XQAtomize.hpp
@@ -33,13 +32,13 @@ include/xqilla/ast/XQEffectiveBooleanValue.hpp
include/xqilla/ast/XQElementConstructor.hpp
include/xqilla/ast/XQFunction.hpp
include/xqilla/ast/XQFunctionCall.hpp
+include/xqilla/ast/XQFunctionCoercion.hpp
include/xqilla/ast/XQFunctionConversion.hpp
include/xqilla/ast/XQFunctionDeref.hpp
include/xqilla/ast/XQFunctionRef.hpp
include/xqilla/ast/XQGlobalVariable.hpp
include/xqilla/ast/XQIf.hpp
include/xqilla/ast/XQInlineFunction.hpp
-include/xqilla/ast/XQInstanceOf.hpp
include/xqilla/ast/XQLiteral.hpp
include/xqilla/ast/XQMap.hpp
include/xqilla/ast/XQNamespaceBinding.hpp
@@ -48,6 +47,7 @@ include/xqilla/ast/XQNav.hpp
include/xqilla/ast/XQOperator.hpp
include/xqilla/ast/XQOrderingChange.hpp
include/xqilla/ast/XQPIConstructor.hpp
+include/xqilla/ast/XQPartialApply.hpp
include/xqilla/ast/XQPredicate.hpp
include/xqilla/ast/XQQuantified.hpp
include/xqilla/ast/XQReturn.hpp
@@ -59,7 +59,6 @@ include/xqilla/ast/XQTypeswitch.hpp
include/xqilla/ast/XQValidate.hpp
include/xqilla/ast/XQVariable.hpp
include/xqilla/axis/NodeTest.hpp
-include/xqilla/axis/SelfAxis.hpp
include/xqilla/context/Collation.hpp
include/xqilla/context/ContextHelpers.hpp
include/xqilla/context/DynamicContext.hpp
@@ -148,34 +147,36 @@ include/xqilla/fulltext/Match.hpp
include/xqilla/fulltext/TokenInfo.hpp
include/xqilla/fulltext/TokenStore.hpp
include/xqilla/fulltext/Tokenizer.hpp
+include/xqilla/functions/BuiltInModules.hpp
+include/xqilla/functions/EXSLTMathFunction.hpp
include/xqilla/functions/ExternalFunction.hpp
include/xqilla/functions/FuncFactory.hpp
+include/xqilla/functions/FuncFactoryTemplate.hpp
include/xqilla/functions/FunctionAbs.hpp
+include/xqilla/functions/FunctionAcos.hpp
include/xqilla/functions/FunctionAdjustDateTimeToTimezone.hpp
include/xqilla/functions/FunctionAdjustDateToTimezone.hpp
include/xqilla/functions/FunctionAdjustTimeToTimezone.hpp
include/xqilla/functions/FunctionAnalyzeString.hpp
-include/xqilla/functions/FunctionAvg.hpp
+include/xqilla/functions/FunctionAsin.hpp
+include/xqilla/functions/FunctionAtan.hpp
include/xqilla/functions/FunctionBaseURI.hpp
-include/xqilla/functions/FunctionBoolean.hpp
+include/xqilla/functions/FunctionCaseFold.hpp
include/xqilla/functions/FunctionCeiling.hpp
-include/xqilla/functions/FunctionCodepointEqual.hpp
include/xqilla/functions/FunctionCodepointsToString.hpp
include/xqilla/functions/FunctionCollection.hpp
include/xqilla/functions/FunctionCompare.hpp
include/xqilla/functions/FunctionConcat.hpp
-include/xqilla/functions/FunctionConstructor.hpp
include/xqilla/functions/FunctionContains.hpp
+include/xqilla/functions/FunctionCos.hpp
include/xqilla/functions/FunctionCount.hpp
include/xqilla/functions/FunctionCurrentDate.hpp
include/xqilla/functions/FunctionCurrentDateTime.hpp
include/xqilla/functions/FunctionCurrentTime.hpp
-include/xqilla/functions/FunctionData.hpp
include/xqilla/functions/FunctionDateTime.hpp
include/xqilla/functions/FunctionDayFromDate.hpp
include/xqilla/functions/FunctionDayFromDateTime.hpp
include/xqilla/functions/FunctionDaysFromDuration.hpp
-include/xqilla/functions/FunctionDeepEqual.hpp
include/xqilla/functions/FunctionDefaultCollation.hpp
include/xqilla/functions/FunctionDistinctValues.hpp
include/xqilla/functions/FunctionDoc.hpp
@@ -183,35 +184,28 @@ include/xqilla/functions/FunctionDocAvailable.hpp
include/xqilla/functions/FunctionDocument.hpp
include/xqilla/functions/FunctionDocumentURI.hpp
include/xqilla/functions/FunctionEmpty.hpp
-include/xqilla/functions/FunctionEncodeForUri.hpp
include/xqilla/functions/FunctionEndsWith.hpp
include/xqilla/functions/FunctionError.hpp
-include/xqilla/functions/FunctionEscapeHtmlUri.hpp
-include/xqilla/functions/FunctionExactlyOne.hpp
-include/xqilla/functions/FunctionExists.hpp
-include/xqilla/functions/FunctionFalse.hpp
+include/xqilla/functions/FunctionExp.hpp
+include/xqilla/functions/FunctionExplain.hpp
include/xqilla/functions/FunctionFloor.hpp
include/xqilla/functions/FunctionFunctionArity.hpp
include/xqilla/functions/FunctionFunctionName.hpp
+include/xqilla/functions/FunctionHead.hpp
include/xqilla/functions/FunctionHoursFromDateTime.hpp
include/xqilla/functions/FunctionHoursFromDuration.hpp
include/xqilla/functions/FunctionHoursFromTime.hpp
include/xqilla/functions/FunctionId.hpp
include/xqilla/functions/FunctionIdref.hpp
include/xqilla/functions/FunctionImplicitTimezone.hpp
-include/xqilla/functions/FunctionInScopePrefixes.hpp
-include/xqilla/functions/FunctionIndexOf.hpp
-include/xqilla/functions/FunctionInsertBefore.hpp
-include/xqilla/functions/FunctionIriToUri.hpp
include/xqilla/functions/FunctionLang.hpp
include/xqilla/functions/FunctionLast.hpp
include/xqilla/functions/FunctionLocalNameFromQName.hpp
include/xqilla/functions/FunctionLocalname.hpp
+include/xqilla/functions/FunctionLog.hpp
include/xqilla/functions/FunctionLookup.hpp
include/xqilla/functions/FunctionLowerCase.hpp
include/xqilla/functions/FunctionMatches.hpp
-include/xqilla/functions/FunctionMax.hpp
-include/xqilla/functions/FunctionMin.hpp
include/xqilla/functions/FunctionMinutesFromDateTime.hpp
include/xqilla/functions/FunctionMinutesFromDuration.hpp
include/xqilla/functions/FunctionMinutesFromTime.hpp
@@ -219,7 +213,6 @@ include/xqilla/functions/FunctionMonthFromDate.hpp
include/xqilla/functions/FunctionMonthFromDateTime.hpp
include/xqilla/functions/FunctionMonthsFromDuration.hpp
include/xqilla/functions/FunctionName.hpp
-include/xqilla/functions/FunctionNamespaceURIForPrefix.hpp
include/xqilla/functions/FunctionNamespaceURIFromQName.hpp
include/xqilla/functions/FunctionNamespaceUri.hpp
include/xqilla/functions/FunctionNilled.hpp
@@ -228,55 +221,51 @@ include/xqilla/functions/FunctionNormalizeSpace.hpp
include/xqilla/functions/FunctionNormalizeUnicode.hpp
include/xqilla/functions/FunctionNot.hpp
include/xqilla/functions/FunctionNumber.hpp
-include/xqilla/functions/FunctionOneOrMore.hpp
include/xqilla/functions/FunctionParseHTML.hpp
include/xqilla/functions/FunctionParseJSON.hpp
include/xqilla/functions/FunctionParseXML.hpp
-include/xqilla/functions/FunctionPartialApply.hpp
include/xqilla/functions/FunctionPosition.hpp
+include/xqilla/functions/FunctionPower.hpp
include/xqilla/functions/FunctionPrefixFromQName.hpp
include/xqilla/functions/FunctionQName.hpp
include/xqilla/functions/FunctionRegexGroup.hpp
-include/xqilla/functions/FunctionRemove.hpp
include/xqilla/functions/FunctionReplace.hpp
-include/xqilla/functions/FunctionResolveQName.hpp
include/xqilla/functions/FunctionResolveURI.hpp
-include/xqilla/functions/FunctionReverse.hpp
include/xqilla/functions/FunctionRoot.hpp
include/xqilla/functions/FunctionRound.hpp
include/xqilla/functions/FunctionRoundHalfToEven.hpp
include/xqilla/functions/FunctionSecondsFromDateTime.hpp
include/xqilla/functions/FunctionSecondsFromDuration.hpp
include/xqilla/functions/FunctionSecondsFromTime.hpp
+include/xqilla/functions/FunctionSentences.hpp
include/xqilla/functions/FunctionSerializeJSON.hpp
+include/xqilla/functions/FunctionSignature.hpp
+include/xqilla/functions/FunctionSin.hpp
+include/xqilla/functions/FunctionSqrt.hpp
include/xqilla/functions/FunctionStartsWith.hpp
include/xqilla/functions/FunctionStaticBaseURI.hpp
include/xqilla/functions/FunctionString.hpp
-include/xqilla/functions/FunctionStringJoin.hpp
include/xqilla/functions/FunctionStringLength.hpp
include/xqilla/functions/FunctionStringToCodepoints.hpp
-include/xqilla/functions/FunctionSubsequence.hpp
include/xqilla/functions/FunctionSubstring.hpp
-include/xqilla/functions/FunctionSubstringAfter.hpp
-include/xqilla/functions/FunctionSubstringBefore.hpp
-include/xqilla/functions/FunctionSum.hpp
+include/xqilla/functions/FunctionTail.hpp
+include/xqilla/functions/FunctionTan.hpp
include/xqilla/functions/FunctionTime.hpp
include/xqilla/functions/FunctionTimezoneFromDate.hpp
include/xqilla/functions/FunctionTimezoneFromDateTime.hpp
include/xqilla/functions/FunctionTimezoneFromTime.hpp
include/xqilla/functions/FunctionTokenize.hpp
include/xqilla/functions/FunctionTrace.hpp
-include/xqilla/functions/FunctionTranslate.hpp
-include/xqilla/functions/FunctionTrue.hpp
include/xqilla/functions/FunctionUnordered.hpp
include/xqilla/functions/FunctionUnparsedText.hpp
include/xqilla/functions/FunctionUpperCase.hpp
+include/xqilla/functions/FunctionWords.hpp
include/xqilla/functions/FunctionYearFromDate.hpp
include/xqilla/functions/FunctionYearFromDateTime.hpp
include/xqilla/functions/FunctionYearsFromDuration.hpp
-include/xqilla/functions/FunctionZeroOrOne.hpp
-include/xqilla/functions/XQillaFunction.hpp
+include/xqilla/functions/RegExpFunction.hpp
include/xqilla/functions/XQUserFunction.hpp
+include/xqilla/functions/XQillaFunction.hpp
include/xqilla/items/ATAnySimpleType.hpp
include/xqilla/items/ATAnyURIOrDerived.hpp
include/xqilla/items/ATBase64BinaryOrDerived.hpp
@@ -343,28 +332,26 @@ include/xqilla/operators/NotEquals.hpp
include/xqilla/operators/Or.hpp
include/xqilla/operators/OrderComparison.hpp
include/xqilla/operators/Plus.hpp
-include/xqilla/operators/Range.hpp
include/xqilla/operators/UnaryMinus.hpp
include/xqilla/operators/Union.hpp
include/xqilla/optimizer/ASTCopier.hpp
include/xqilla/optimizer/ASTReleaser.hpp
+include/xqilla/optimizer/ASTToXML.hpp
include/xqilla/optimizer/ASTVisitor.hpp
-include/xqilla/optimizer/PartialEvaluator.hpp
include/xqilla/optimizer/Optimizer.hpp
+include/xqilla/optimizer/PartialEvaluator.hpp
include/xqilla/optimizer/QueryPathNode.hpp
include/xqilla/optimizer/QueryPathTreeGenerator.hpp
include/xqilla/optimizer/StaticTyper.hpp
include/xqilla/parser/QName.hpp
include/xqilla/runtime/ClosureResult.hpp
include/xqilla/runtime/EmptyResult.hpp
-include/xqilla/runtime/LazySequenceResult.hpp
include/xqilla/runtime/Result.hpp
include/xqilla/runtime/ResultBuffer.hpp
include/xqilla/runtime/ResultBufferImpl.hpp
include/xqilla/runtime/ResultImpl.hpp
include/xqilla/runtime/Sequence.hpp
include/xqilla/runtime/SequenceResult.hpp
-include/xqilla/runtime/SingleResult.hpp
include/xqilla/runtime/TupleResult.hpp
include/xqilla/schema/AnyAtomicTypeDatatypeValidator.hpp
include/xqilla/schema/DocumentCache.hpp
@@ -388,15 +375,16 @@ include/xqilla/update/UReplace.hpp
include/xqilla/update/UReplaceValueOf.hpp
include/xqilla/update/UTransform.hpp
include/xqilla/utils/ContextUtils.hpp
+include/xqilla/utils/DelayedModule.hpp
include/xqilla/utils/NumUtils.hpp
-include/xqilla/utils/PrintAST.hpp
-include/xqilla/utils/UCANormalizer.hpp
include/xqilla/utils/UTF8Str.hpp
+include/xqilla/utils/UnicodeTransformer.hpp
include/xqilla/utils/XMLChCompare.hpp
include/xqilla/utils/XPath2NSUtils.hpp
include/xqilla/utils/XPath2Utils.hpp
include/xqilla/utils/XQillaPlatformUtils.hpp
include/xqilla/utils/XStr.hpp
+include/xqilla/utils/utf8proc.h
include/xqilla/xerces/XercesConfiguration.hpp
include/xqilla/xqilla-dom3.hpp
include/xqilla/xqilla-simple.hpp
@@ -407,7 +395,7 @@ include/xqilla/xqts/TestSuiteRunner.hpp
lib/libxqilla.a
lib/libxqilla.la
lib/libxqilla.so
-lib/libxqilla.so.5
+lib/libxqilla.so.6
@dirrm include/xqilla/xqts
@dirrm include/xqilla/xerces
@dirrm include/xqilla/utils