aboutsummaryrefslogtreecommitdiff
path: root/textproc/xslide.el
diff options
context:
space:
mode:
authorYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-02-08 21:08:27 +0000
committerYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-02-08 21:08:27 +0000
commita204dd6693c6e3fb238c2f5bd289aadc0b7fc358 (patch)
tree410d6bd75efa6b34a851647f125825bbffa0fb34 /textproc/xslide.el
parentc87f842f5e48d646a2752a32415774725bdf2781 (diff)
downloadports-a204dd6693c6e3fb238c2f5bd289aadc0b7fc358.tar.gz
ports-a204dd6693c6e3fb238c2f5bd289aadc0b7fc358.zip
Notes
Diffstat (limited to 'textproc/xslide.el')
-rw-r--r--textproc/xslide.el/Makefile43
-rw-r--r--textproc/xslide.el/distinfo1
-rw-r--r--textproc/xslide.el/pkg-comment1
-rw-r--r--textproc/xslide.el/pkg-descr22
-rw-r--r--textproc/xslide.el/pkg-message20
-rw-r--r--textproc/xslide.el/pkg-plist9
6 files changed, 96 insertions, 0 deletions
diff --git a/textproc/xslide.el/Makefile b/textproc/xslide.el/Makefile
new file mode 100644
index 000000000000..c2e1ab88d97a
--- /dev/null
+++ b/textproc/xslide.el/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: xslide.el
+# Date created: 14 January 2002
+# Whom: Leo Kim <leo@florida.sarang.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xslide.el
+PORTVERSION= 0.2
+CATEGORIES= textproc elisp
+MASTER_SITES= http://www.menteith.com/xslide/data/
+DISTNAME= xslide
+
+MAINTAINER= leo@florida.sarang.net
+
+RUN_DEPENDS= emacs:${PORTSDIR}/editors/emacs21
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+USE_ZIP= yes
+
+ELISPDIR= ${PREFIX}/share/emacs/site-lisp
+
+do-install:
+ @${MKDIR} ${ELISPDIR}
+ @${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && \
+ ${INSTALL_DATA} \
+ xslide.el \
+ xslide-abbrev.el \
+ xslide-data.el \
+ xslide-font.el \
+ xslide-initial.xsl \
+ xslide-process.el \
+ ${ELISPDIR} && \
+ ${INSTALL_DATA} \
+ CHANGELOG.TXT README.TXT ${DOCSDIR} \
+ )
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/xslide.el/distinfo b/textproc/xslide.el/distinfo
new file mode 100644
index 000000000000..a287430e590f
--- /dev/null
+++ b/textproc/xslide.el/distinfo
@@ -0,0 +1 @@
+MD5 (xslide.zip) = 003de7a03474a3812105067231e6fcd3
diff --git a/textproc/xslide.el/pkg-comment b/textproc/xslide.el/pkg-comment
new file mode 100644
index 000000000000..85d48d5d753b
--- /dev/null
+++ b/textproc/xslide.el/pkg-comment
@@ -0,0 +1 @@
+Emacs major mode for editing XSL stylesheets
diff --git a/textproc/xslide.el/pkg-descr b/textproc/xslide.el/pkg-descr
new file mode 100644
index 000000000000..5c7d02c3214c
--- /dev/null
+++ b/textproc/xslide.el/pkg-descr
@@ -0,0 +1,22 @@
+Emacs major mode for editing XSL stylesheets.
+
+* FEATURES
+
+ - XSL customization group for setting some variables
+ - Initial stylesheet inserted into empty XSL buffers;
+ - "Template" menu for jumping to template rules, named templates, key
+ declarations, and attribute-set declarations in the buffer;
+ - `xsl-process' function that runs an XSL processor and collects the output;
+ - Predefined command line templates and error regexps for Java and
+ Windows executable versions of both XT and Saxon;
+ - Font lock highlighting so that the important information stands out;
+ - `xsl-complete' function for inserting element and attribute names;
+ - `xsl-insert-tag' function for inserting matching start- and end-tags;
+ - Automatic completion of end-tags;
+ - Automatic indenting of elements with user-definable indentation step; and
+ - Comprehensive abbreviations table to further ease typing.
+
+WWW: http://www.menteith.com/xslide/
+
+- Leo Kim
+leo@florida.sarang.net
diff --git a/textproc/xslide.el/pkg-message b/textproc/xslide.el/pkg-message
new file mode 100644
index 000000000000..eb57f2f00073
--- /dev/null
+++ b/textproc/xslide.el/pkg-message
@@ -0,0 +1,20 @@
+****************************************************************************
+To use xsl-mode, add to your ~/.emacs the following lines:
+
+;; XSL mode
+(autoload 'xsl-mode "xslide" "Major mode for XSL stylesheets." t)
+
+;; Turn on font lock when in XSL mode
+(add-hook 'xsl-mode-hook
+ 'turn-on-font-lock)
+
+(setq auto-mode-alist
+ (append
+ (list
+ '("\\.fo" . xsl-mode)
+ '("\\.xsl" . xsl-mode))
+ auto-mode-alist))
+
+;; Uncomment if using abbreviations
+;; (abbrev-mode t)
+****************************************************************************
diff --git a/textproc/xslide.el/pkg-plist b/textproc/xslide.el/pkg-plist
new file mode 100644
index 000000000000..a7ef314338d7
--- /dev/null
+++ b/textproc/xslide.el/pkg-plist
@@ -0,0 +1,9 @@
+share/doc/xslide.el/CHANGELOG.TXT
+share/doc/xslide.el/README.TXT
+share/emacs/site-lisp/xslide.el
+share/emacs/site-lisp/xslide-abbrev.el
+share/emacs/site-lisp/xslide-data.el
+share/emacs/site-lisp/xslide-font.el
+share/emacs/site-lisp/xslide-initial.xsl
+share/emacs/site-lisp/xslide-process.el
+@dirrm share/doc/xslide.el