aboutsummaryrefslogtreecommitdiff
path: root/textproc/xstream
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-05-13 12:40:21 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-05-13 12:40:21 +0000
commit78f3b0a9226709b506c47cafa37d82f75d895439 (patch)
tree9db24337252dd08bc8ec1e399f8d9c95208a4a9e /textproc/xstream
parent187ba4cac8eb14b9a9e5d856bbe715a6cf590733 (diff)
downloadports-78f3b0a9226709b506c47cafa37d82f75d895439.tar.gz
ports-78f3b0a9226709b506c47cafa37d82f75d895439.zip
Notes
Diffstat (limited to 'textproc/xstream')
-rw-r--r--textproc/xstream/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/textproc/xstream/Makefile b/textproc/xstream/Makefile
index 85f1c2b8a120..0e35b69bfb7f 100644
--- a/textproc/xstream/Makefile
+++ b/textproc/xstream/Makefile
@@ -10,9 +10,11 @@ DISTFILES= ${PORTNAME}-distribution-${PORTVERSION}-bin${EXTRACT_SUFX}
MAINTAINER= ale@FreeBSD.org
COMMENT= A simple library to serialize Java objects to XML
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+OPTIONS_DEFINE= DOCS
+
USES= zip
USE_JAVA= yes
NO_BUILD= yes
@@ -21,15 +23,17 @@ PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
PORTDOCS= *
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
do-install:
@${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
- @${INSTALL_DATA} ${WRKSRC}/lib/${DISTNAME}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${INSTALL_DATA} ${WRKSRC}/lib/${DISTNAME}.jar \
+ ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
@${ECHO_MSG} " [ DONE ]"
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}/
@${ECHO_MSG} " [ DONE ]"
.endif