aboutsummaryrefslogtreecommitdiff
path: root/textproc/xstream
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2008-10-14 16:17:29 +0000
committerAlex Dupre <ale@FreeBSD.org>2008-10-14 16:17:29 +0000
commit05fed8bce9e7ed60e8308ea4f60704b1cba21beb (patch)
tree985d0d72ab0c977f8146a891fc3c4caec303f47c /textproc/xstream
parent9cb8a6d230e0a6fb4870cab408467b63a9719561 (diff)
downloadports-05fed8bce9e7ed60e8308ea4f60704b1cba21beb.tar.gz
ports-05fed8bce9e7ed60e8308ea4f60704b1cba21beb.zip
Notes
Diffstat (limited to 'textproc/xstream')
-rw-r--r--textproc/xstream/Makefile13
-rw-r--r--textproc/xstream/distinfo6
-rw-r--r--textproc/xstream/files/patch-build.xml12
-rw-r--r--textproc/xstream/files/patch-src_java_com_thoughtworks_xstream_core_JVM.java22
4 files changed, 44 insertions, 9 deletions
diff --git a/textproc/xstream/Makefile b/textproc/xstream/Makefile
index dd6697fa41bf..95775e134cda 100644
--- a/textproc/xstream/Makefile
+++ b/textproc/xstream/Makefile
@@ -6,14 +6,15 @@
#
PORTNAME= xstream
-PORTVERSION= 1.2
-PORTREVISION= 2
+PORTVERSION= 1.3
CATEGORIES= textproc java
-MASTER_SITES= http://dist.codehaus.org/xstream/distributions/
+MASTER_SITES= http://repository.codehaus.org/com/thoughtworks/xstream/xstream-distribution/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-distribution-${PORTVERSION}-src
MAINTAINER= ale@FreeBSD.org
COMMENT= A simple library to serialize Java objects to XML
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}
USE_ZIP= yes
USE_JAVA= yes
USE_ANT= yes
@@ -28,14 +29,14 @@ ALL_TARGET+= javadoc
do-install:
@${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
- @${INSTALL_DATA} ${WRKSRC}/${DISTNAME}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${INSTALL_DATA} ${WRKSRC}/target/${PORTNAME}-SNAPSHOT.jar ${JAVAJARDIR}/${PORTNAME}.jar
@${ECHO_MSG} " [ DONE ]"
.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
@${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/ && ${FIND} javadoc \
+ @cd ${WRKSRC}/target/ && ${FIND} javadoc \
| ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
- @${INSTALL_DATA} ${OTHERDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${INSTALL_DATA} ${OTHERDOCS:S,^,${WRKSRC}/../,} ${DOCSDIR}/
@${ECHO_MSG} " [ DONE ]"
.endif
diff --git a/textproc/xstream/distinfo b/textproc/xstream/distinfo
index 439974f625fe..d3790583b720 100644
--- a/textproc/xstream/distinfo
+++ b/textproc/xstream/distinfo
@@ -1,3 +1,3 @@
-MD5 (xstream-1.2.zip) = 488fd2742f2d9f2b8bfe9acd8bccd097
-SHA256 (xstream-1.2.zip) = 7536d9b1f2bf1c1b235d1a1114dbdae08a8ed5953b1fe7a2c760bf807770e26d
-SIZE (xstream-1.2.zip) = 5488349
+MD5 (xstream-distribution-1.3-src.zip) = 8d2caf93c3078760c6baa8c26765ec4b
+SHA256 (xstream-distribution-1.3-src.zip) = fe09248421d8b153880b127b08083a7852f40dbafa6b0e2a9fa8920bf5abaa35
+SIZE (xstream-distribution-1.3-src.zip) = 7403424
diff --git a/textproc/xstream/files/patch-build.xml b/textproc/xstream/files/patch-build.xml
new file mode 100644
index 000000000000..5f6868451f6b
--- /dev/null
+++ b/textproc/xstream/files/patch-build.xml
@@ -0,0 +1,12 @@
+--- build.xml.orig 2008-10-14 17:50:58.000000000 +0200
++++ build.xml 2008-10-14 17:51:26.000000000 +0200
+@@ -146,9 +146,6 @@
+ <jar jarfile="${build.dir}/xstream-${version}.jar">
+ <fileset dir="${java.build.dir}"/>
+ </jar>
+- <jar jarfile="${build.dir}/xstream-benchmark-${version}.jar">
+- <fileset dir="${benchmark.build.dir}"/>
+- </jar>
+ <antcall target="jdk-check"/>
+ </target>
+
diff --git a/textproc/xstream/files/patch-src_java_com_thoughtworks_xstream_core_JVM.java b/textproc/xstream/files/patch-src_java_com_thoughtworks_xstream_core_JVM.java
new file mode 100644
index 000000000000..a3a161be66e9
--- /dev/null
+++ b/textproc/xstream/files/patch-src_java_com_thoughtworks_xstream_core_JVM.java
@@ -0,0 +1,22 @@
+--- src/java/com/thoughtworks/xstream/core/JVM.java.orig 2008-10-14 17:40:37.000000000 +0200
++++ src/java/com/thoughtworks/xstream/core/JVM.java 2008-10-14 17:47:39.000000000 +0200
+@@ -67,6 +67,10 @@ public class JVM {
+ return vendor.indexOf("Sun") != -1;
+ }
+
++ private static boolean isDiablo() {
++ return vendor.indexOf("The FreeBSD Foundation") != -1;
++ }
++
+ private static boolean isApple() {
+ return vendor.indexOf("Apple") != -1;
+ }
+@@ -178,7 +182,7 @@ public class JVM {
+ }
+
+ private boolean canUseSun14ReflectionProvider() {
+- return (isSun() || isApple() || isHPUX() || isIBM() || isBlackdown() || isBEAWithUnsafeSupport() || isHitachi() || isSAP()) && is14() && loadClass("sun.misc.Unsafe") != null;
++ return (isSun() || isDiablo() || isApple() || isHPUX() || isIBM() || isBlackdown() || isBEAWithUnsafeSupport() || isHitachi() || isSAP()) && is14() && loadClass("sun.misc.Unsafe") != null;
+ }
+
+ private boolean canUseHarmonyReflectionProvider() {