aboutsummaryrefslogtreecommitdiff
path: root/textproc/yodl/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-09 01:36:55 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-09 01:36:55 +0000
commit6191a0f6a8f6384636ebfb8fed314bd36e3804f7 (patch)
tree8820b40d432e57663e2a87eff34c8e568dd2ea84 /textproc/yodl/Makefile
parent7032f98510726019e07faad9003c218e9687ee7a (diff)
downloadports-6191a0f6a8f6384636ebfb8fed314bd36e3804f7.tar.gz
ports-6191a0f6a8f6384636ebfb8fed314bd36e3804f7.zip
Notes
Diffstat (limited to 'textproc/yodl/Makefile')
-rw-r--r--textproc/yodl/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/textproc/yodl/Makefile b/textproc/yodl/Makefile
index 4d4424aa47d3..7b72da6fc4a6 100644
--- a/textproc/yodl/Makefile
+++ b/textproc/yodl/Makefile
@@ -8,18 +8,23 @@
PORTNAME= yodl
PORTVERSION= 1.22
CATEGORIES= textproc
-MASTER_SITES= ftp://ftp.icce.rug.nl/pub/unix/
+MASTER_SITES= ftp://ftp.sco.com/skunkware/src/textproc/ \
+ ftp://ftp.sunsite.org.uk/Mirrors/ftp.sco.com/skunkware/src/textproc/ \
+ ftp://ftp.vse.cz/pub/.sd10c/SCO/ftp.sco.com/skunkware/src/textproc/ \
+ ftp://ftp.netsw.org/netsw/Typesetting/ASCII/Generate/ \
+ ftp://ftp.win.ne.jp/pub/misc/ \
+ ftp://ftp.eos.hokudai.ac.jp/pub/misc/ \
+ ftp://ftp.sunet.se/pub3/vendor/sco/skunkware/src/textproc/
MAINTAINER= dburr@FreeBSD.org
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash1 \
- latex:${PORTSDIR}/print/latex \
+BUILD_DEPENDS= latex:${PORTSDIR}/print/latex \
dvips:${PORTSDIR}/print/dvips
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash1 \
- latex:${PORTSDIR}/print/latex \
+RUN_DEPENDS= latex:${PORTSDIR}/print/latex \
dvips:${PORTSDIR}/print/dvips
-USE_GMAKE= YES
+ALL_TARGET= progs manpages misc/striproff
+INSTALL_TARGET= installman installmanual
MAN1= yodl.1 \
striproff.1 \
@@ -32,15 +37,7 @@ do-build:
(cd ${WRKSRC} && ${SETENV} CFLAGS="${CFLAGS}" ${GMAKE} PREFIX=${PREFIX} progs)
(cd ${WRKSRC}/misc && gcc ${CFLAGS} -s -o striproff striproff.c)
-# this weird contortion is because the YODL makefile is broken
-# trust me, it works.
-do-install:
- @${ECHO_MSG} "*** NOTE: any errors from make can be safely ignored."
- (cd ${WRKSRC} && ${GMAKE} PREFIX=${PREFIX} install)
- -(cd ${WRKSRC} && ${GMAKE} PREFIX=${PREFIX} manpages)
- (cd ${WRKSRC}/manpages && ${GMAKE} PREFIX=${PREFIX} manpages)
- (cd ${WRKSRC}/manpages && ${GMAKE} PREFIX=${PREFIX} MANPREFIX=${PREFIX}/man installman)
- (cd ${WRKSRC} && ${GMAKE} PREFIX=${PREFIX} installmanual)
- (cd ${WRKSRC}/misc && ${INSTALL_PROGRAM} striproff ${PREFIX}/bin/striproff)
+post-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/misc/striproff ${PREFIX}/bin
.include <bsd.port.mk>