aboutsummaryrefslogtreecommitdiff
path: root/textproc/zorba/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-06-27 08:07:59 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-06-27 08:07:59 +0000
commit54a34c95b8bc47bb0f8dd59782237e4d59e6a057 (patch)
tree544bc7a0f40af133de36d34e6d49956f719db3a7 /textproc/zorba/Makefile
parent72f833567c983caac362af689413c5a140768a43 (diff)
downloadports-54a34c95b8bc47bb0f8dd59782237e4d59e6a057.tar.gz
ports-54a34c95b8bc47bb0f8dd59782237e4d59e6a057.zip
Notes
Diffstat (limited to 'textproc/zorba/Makefile')
-rw-r--r--textproc/zorba/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index c864fbff8c9f..454cd50be753 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -30,10 +30,12 @@ CONFLICTS= xqilla-[0-9]*
USE_GNOME= libxml2 libxslt
USE_LDCONFIG= yes
-USES= cmake:outsource iconv
-CXXFLAGS+= -I${LOCALBASE}/include
+USE_CXXSTD= c++11
+USES= cmake:outsource iconv compiler:c++11-lib
+CXXFLAGS+= -I${LOCALBASE}/include -O1 # compiler hangs with -O2 on CURRENT
LDFLAGS+= -L${LOCALBASE}/lib
-CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-I${LOCALBASE}/include -L${LOCALBASE}/lib"
+CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
+ -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
@@ -41,7 +43,6 @@ PLIST_SUB+= FULLVERSION=${PORTVERSION} \
MIDVERSION=${PORTVERSION:R} \
MINVERSION=${PORTVERSION:R:R}
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPHP}
@@ -112,7 +113,7 @@ post-patch:
# ${FIND} ${WRKSRC} -name "*.orig" -delete
post-install:
- ${LN} -sf libzorba_simplestore.so.${PORTVERSION} ${PREFIX}/lib/libzorba_simplestore.so.${PORTVERSION:R:R}
+ ${LN} -sf libzorba_simplestore.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libzorba_simplestore.so.${PORTVERSION:R:R}
test: build
cd ${BUILD_WRKSRC} && ${MAKE} test