aboutsummaryrefslogtreecommitdiff
path: root/textproc/zorba
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-06-27 08:07:59 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-06-27 08:07:59 +0000
commit54a34c95b8bc47bb0f8dd59782237e4d59e6a057 (patch)
tree544bc7a0f40af133de36d34e6d49956f719db3a7 /textproc/zorba
parent72f833567c983caac362af689413c5a140768a43 (diff)
Notes
Diffstat (limited to 'textproc/zorba')
-rw-r--r--textproc/zorba/Makefile11
-rw-r--r--textproc/zorba/files/patch-bin-debugger_command_line_handler.cpp11
-rw-r--r--textproc/zorba/files/patch-include-zorba-config.h.cmake11
-rw-r--r--textproc/zorba/files/patch-src-store-api_item_handle.h11
-rw-r--r--textproc/zorba/files/patch-src-util_tracer.h17
-rw-r--r--textproc/zorba/pkg-plist2
6 files changed, 58 insertions, 5 deletions
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index c864fbff8c9f..454cd50be753 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -30,10 +30,12 @@ CONFLICTS= xqilla-[0-9]*
USE_GNOME= libxml2 libxslt
USE_LDCONFIG= yes
-USES= cmake:outsource iconv
-CXXFLAGS+= -I${LOCALBASE}/include
+USE_CXXSTD= c++11
+USES= cmake:outsource iconv compiler:c++11-lib
+CXXFLAGS+= -I${LOCALBASE}/include -O1 # compiler hangs with -O2 on CURRENT
LDFLAGS+= -L${LOCALBASE}/lib
-CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-I${LOCALBASE}/include -L${LOCALBASE}/lib"
+CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
+ -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
@@ -41,7 +43,6 @@ PLIST_SUB+= FULLVERSION=${PORTVERSION} \
MIDVERSION=${PORTVERSION:R} \
MINVERSION=${PORTVERSION:R:R}
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPHP}
@@ -112,7 +113,7 @@ post-patch:
# ${FIND} ${WRKSRC} -name "*.orig" -delete
post-install:
- ${LN} -sf libzorba_simplestore.so.${PORTVERSION} ${PREFIX}/lib/libzorba_simplestore.so.${PORTVERSION:R:R}
+ ${LN} -sf libzorba_simplestore.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libzorba_simplestore.so.${PORTVERSION:R:R}
test: build
cd ${BUILD_WRKSRC} && ${MAKE} test
diff --git a/textproc/zorba/files/patch-bin-debugger_command_line_handler.cpp b/textproc/zorba/files/patch-bin-debugger_command_line_handler.cpp
new file mode 100644
index 000000000000..d16bd1ad0dad
--- /dev/null
+++ b/textproc/zorba/files/patch-bin-debugger_command_line_handler.cpp
@@ -0,0 +1,11 @@
+--- bin/debugger/command_line_handler.cpp.orig 2014-06-26 18:42:05.000000000 +0200
++++ bin/debugger/command_line_handler.cpp 2014-06-26 18:40:21.000000000 +0200
+@@ -138,7 +138,7 @@
+
+ template<>
+ void
+-CommandLineHandler::handle<BreakpointSet>(std::tr1::tuple<bstring, bstring, bint> &aTuple)
++CommandLineHandler::handle<BreakpointSet>(ZORBA_TR1_NS::tuple<bstring, bstring, bint> &aTuple)
+ {
+ DebuggerClient::BreakpointType lType = DebuggerClient::Line;
+ bool lEnabled = true;
diff --git a/textproc/zorba/files/patch-include-zorba-config.h.cmake b/textproc/zorba/files/patch-include-zorba-config.h.cmake
new file mode 100644
index 000000000000..b7fbba08339d
--- /dev/null
+++ b/textproc/zorba/files/patch-include-zorba-config.h.cmake
@@ -0,0 +1,11 @@
+--- include/zorba/config.h.cmake.orig 2014-06-13 15:08:16.000000000 +0200
++++ include/zorba/config.h.cmake 2014-06-13 15:08:29.000000000 +0200
+@@ -126,7 +126,7 @@
+
+ ////////// C++ tr1 include directory & namespace //////////////////////////////
+
+-#if defined( __GNUC__ ) && (__GNUC__ * 100 + __GNUC_MINOR__ < 430)
++#if !defined(__clang__) && defined( __GNUC__ ) && (__GNUC__ * 100 + __GNUC_MINOR__ < 430)
+ # define ZORBA_GCC_OLDER_THAN_430 1
+ #endif
+
diff --git a/textproc/zorba/files/patch-src-store-api_item_handle.h b/textproc/zorba/files/patch-src-store-api_item_handle.h
new file mode 100644
index 000000000000..8746ce262b4a
--- /dev/null
+++ b/textproc/zorba/files/patch-src-store-api_item_handle.h
@@ -0,0 +1,11 @@
+--- src/store/api/item_handle.h.orig 2014-06-13 15:24:23.000000000 +0200
++++ src/store/api/item_handle.h 2014-06-13 15:34:05.000000000 +0200
+@@ -16,6 +16,8 @@
+ #ifndef ZORBA_STORE_ITEM_HANDLE_H
+ #define ZORBA_STORE_ITEM_HANDLE_H
+
++#include <string>
++#include <sstream>
+
+
+ namespace zorba
diff --git a/textproc/zorba/files/patch-src-util_tracer.h b/textproc/zorba/files/patch-src-util_tracer.h
new file mode 100644
index 000000000000..b5cba3ace151
--- /dev/null
+++ b/textproc/zorba/files/patch-src-util_tracer.h
@@ -0,0 +1,17 @@
+--- src/util/tracer.h.orig 2014-06-13 15:42:33.000000000 +0200
++++ src/util/tracer.h 2014-06-13 15:42:58.000000000 +0200
+@@ -21,12 +21,12 @@
+
+
+ #if !defined WIN32 && !defined WINCE
+-#define TRACE __PRETTY_FUNCTION__<<" ("__FILE__<<':'<<std::dec<<__LINE__<<")"
++#define TRACE __PRETTY_FUNCTION__<<" ("<<__FILE__<<':'<<std::dec<<__LINE__<<")"
+ #define LOCATION (__oss.str(""), \
+ __oss<<__FILE__<<":"<<std::dec<<__LINE__<<"::"<<__PRETTY_FUNCTION__, \
+ __oss.str())
+ #elif defined WIN32
+-#define TRACE __FUNCSIG__<<" ("__FILE__<<':'<<std::dec<<__LINE__<<")"
++#define TRACE __FUNCSIG__<<" ("<<__FILE__<<':'<<std::dec<<__LINE__<<")"
+ #define LOCATION (__oss.str(""), \
+ __oss<<__FILE__<<":"<<std::dec<<__LINE__<<"::"<<__FUNCTION__, \
+ __oss.str())
diff --git a/textproc/zorba/pkg-plist b/textproc/zorba/pkg-plist
index ffef10478c9b..46ab06e94808 100644
--- a/textproc/zorba/pkg-plist
+++ b/textproc/zorba/pkg-plist
@@ -464,3 +464,5 @@ share/cmake/Modules/zorba-%%FULLVERSION%%/ExternalModuleConfig.cmake.in
@dirrm %%DATADIR%%/uris/core
@dirrm %%DATADIR%%/uris
@dirrm %%DATADIR%%
+@dirrmtry share/cmake/Modules
+@dirrmtry share/cmake