aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2015-11-19 21:50:18 +0000
committerTom Judge <tj@FreeBSD.org>2015-11-19 21:50:18 +0000
commit2444e2e56a094086e0742e9f227c667787da9062 (patch)
treed6bf2235375043a6d30737b5a9f31d5730ea20a0 /textproc
parenta51004caee0d1416a1ace250950f10100f8ece0b (diff)
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/elasticsearch/Makefile3
-rw-r--r--textproc/elasticsearch2/Makefile127
-rw-r--r--textproc/elasticsearch2/distinfo2
-rw-r--r--textproc/elasticsearch2/files/elasticsearch.in112
-rw-r--r--textproc/elasticsearch2/files/patch-bin-elasticsearch.in.sh22
-rw-r--r--textproc/elasticsearch2/files/patch-config-elasticsearch.yml15
-rw-r--r--textproc/elasticsearch2/files/pkg-message.in6
-rw-r--r--textproc/elasticsearch2/pkg-descr4
-rw-r--r--textproc/elasticsearch2/pkg-plist56
10 files changed, 348 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ff2a0a1a86d9..6147496f9db4 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -158,6 +158,7 @@
SUBDIR += elasticsearch-plugin-marvel
SUBDIR += elasticsearch-plugin-sql
SUBDIR += elasticsearch-river-rabbitmq
+ SUBDIR += elasticsearch2
SUBDIR += elixir-earmark
SUBDIR += elixir-ex_doc
SUBDIR += elixir-funnel
diff --git a/textproc/elasticsearch/Makefile b/textproc/elasticsearch/Makefile
index 5c4efd1ca298..a113102d6046 100644
--- a/textproc/elasticsearch/Makefile
+++ b/textproc/elasticsearch/Makefile
@@ -3,6 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 1.7.3
+PORTREVISION= 1
CATEGORIES= textproc java devel
MASTER_SITES= http://download.elasticsearch.org/${PORTNAME}/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -14,6 +15,8 @@ LICENSE= APACHE20
RUN_DEPENDS= java-sigar>=0:${PORTSDIR}/java/sigar
+CONFLICTS= elasticsearch2-[0-9]*
+
USES= cpe
NO_ARCH= yes
USE_JAVA= yes
diff --git a/textproc/elasticsearch2/Makefile b/textproc/elasticsearch2/Makefile
new file mode 100644
index 000000000000..9e9daae93a56
--- /dev/null
+++ b/textproc/elasticsearch2/Makefile
@@ -0,0 +1,127 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= elasticsearch
+PORTVERSION= 2.0.0
+CATEGORIES= textproc java devel
+MASTER_SITES= http://download.elasticsearch.org/${PORTNAME}/${PORTNAME}/ \
+ http://mirrors.rit.edu/zi/
+PKGNAMESUFFIX= 2
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Full-text search engine for Java
+
+LICENSE= APACHE20
+
+CONFLICTS= elasticsearch-[0-9]*
+
+USES= cpe
+NO_ARCH= yes
+USE_JAVA= yes
+NO_BUILD= yes
+JAVA_VERSION= 1.7+
+USE_RC_SUBR= ${PORTNAME}
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+LUCENEVER= 5.2.1
+CONFIG_FILES= elasticsearch.yml logging.yml
+JARS= elasticsearch-${PORTVERSION}.jar \
+ HdrHistogram-2.1.6.jar \
+ antlr-runtime-3.5.jar \
+ apache-log4j-extras-1.2.17.jar \
+ asm-4.1.jar \
+ asm-commons-4.1.jar \
+ commons-cli-1.3.1.jar \
+ compiler-0.8.13.jar \
+ compress-lzf-1.0.2.jar \
+ groovy-all-2.4.4-indy.jar \
+ guava-18.0.jar \
+ hppc-0.7.1.jar \
+ jackson-core-2.5.3.jar \
+ jackson-dataformat-cbor-2.5.3.jar \
+ jackson-dataformat-smile-2.5.3.jar \
+ jackson-dataformat-yaml-2.5.3.jar \
+ jna-4.1.0.jar \
+ joda-convert-1.2.jar \
+ joda-time-2.8.2.jar \
+ jsr166e-1.1.0.jar \
+ jts-1.13.jar \
+ log4j-1.2.17.jar \
+ lucene-analyzers-common-${LUCENEVER}.jar \
+ lucene-backward-codecs-${LUCENEVER}.jar \
+ lucene-core-${LUCENEVER}.jar \
+ lucene-expressions-${LUCENEVER}.jar \
+ lucene-grouping-${LUCENEVER}.jar \
+ lucene-highlighter-${LUCENEVER}.jar \
+ lucene-join-${LUCENEVER}.jar \
+ lucene-memory-${LUCENEVER}.jar \
+ lucene-misc-${LUCENEVER}.jar \
+ lucene-queries-${LUCENEVER}.jar \
+ lucene-queryparser-${LUCENEVER}.jar \
+ lucene-sandbox-${LUCENEVER}.jar \
+ lucene-spatial-${LUCENEVER}.jar \
+ lucene-suggest-${LUCENEVER}.jar \
+ netty-3.10.5.Final.jar \
+ snakeyaml-1.12.jar \
+ spatial4j-0.4.1.jar \
+ t-digest-3.0.jar
+BINS= elasticsearch.in.sh \
+ elasticsearch \
+ plugin
+
+DOCS= LICENSE.txt \
+ NOTICE.txt \
+ README.textile
+
+SIGAR_ARCH= ${ARCH:S|i386|x86|}
+SEARCHUSER?= elasticsearch
+SEARCHGROUP?= ${SEARCHUSER}
+USERS= ${SEARCHUSER}
+GROUPS= ${SEARCHGROUP}
+ELASTIC_DBDIR= /var/db/elasticsearch
+ELASTIC_LOGDIR= /var/log/elasticsearch
+
+SUB_LIST= SEARCHUSER=${SEARCHUSER} \
+ SEARCHGROUP=${SEARCHGROUP} \
+ PORTVERSION=${PORTVERSION}
+SUB_FILES= pkg-message
+PLIST_SUB= SEARCHUSER=${SEARCHUSER} \
+ SEARCHGROUP=${SEARCHGROUP} \
+ LUCENEVER=${LUCENEVER} \
+ PORTVERSION=${PORTVERSION} \
+ ELASTIC_DBDIR=${ELASTIC_DBDIR} \
+ ELASTIC_LOGDIR=${ELASTIC_LOGDIR}
+
+post-patch:
+ ${SED} -i .bak -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/elasticsearch.yml
+ ${SED} -i .bak -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/bin/elasticsearch.in.sh
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/elasticsearch
+.for f in ${CONFIG_FILES}
+ ${INSTALL} -m 440 ${WRKSRC}/config/${f} ${STAGEDIR}${ETCDIR}/${f}.sample
+.endfor
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
+.for f in ${BINS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
+.endfor
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib
+.for f in ${JARS}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib
+.endfor
+
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+ cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s ${PREFIX}/lib/elasticsearch/bin/plugin elasticsearch-plugin
+
+.include <bsd.port.mk>
diff --git a/textproc/elasticsearch2/distinfo b/textproc/elasticsearch2/distinfo
new file mode 100644
index 000000000000..75867aab0c05
--- /dev/null
+++ b/textproc/elasticsearch2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (elasticsearch-2.0.0.tar.gz) = b25f13f615337c2072964fd9fc5c7250f8a2a983b22198daf93548285d5d16df
+SIZE (elasticsearch-2.0.0.tar.gz) = 28576708
diff --git a/textproc/elasticsearch2/files/elasticsearch.in b/textproc/elasticsearch2/files/elasticsearch.in
new file mode 100644
index 000000000000..20975366a3ab
--- /dev/null
+++ b/textproc/elasticsearch2/files/elasticsearch.in
@@ -0,0 +1,112 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: elasticsearch
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf to enable elasticsearch:
+#
+# elasticsearch_enable="YES"
+#
+# elasticsearch_user (username): Set to elasticsearch by default.
+# Set it to required username.
+# elasticsearch_group (group): Set to elasticsearch by default.
+# Set it to required group.
+# elasticsearch_config (path): Set to /usr/local/etc/elasticsearch/elasticsearch.yml by default.
+# Set it to the config file location.
+# elasticsearch_min_mem (num): Minumum JVM heap size, 256m by default.
+# elasticsearch_max_mem (num): Maximum JVM heap size, 1g by default.
+# elasticsearch_props (args): Additional java properties or arguments.
+# elasticsearch_tmp (path): Set to /var/tmp/elasticsearch by default.
+# Set it to the path to be used for temp files.
+#
+. /etc/rc.subr
+
+name=elasticsearch
+rcvar=elasticsearch_enable
+
+load_rc_config ${name}
+
+: ${elasticsearch_enable:="NO"}
+: ${elasticsearch_user:=%%SEARCHUSER%%}
+: ${elasticsearch_group:=%%SEARCHGROUP%%}
+: ${elasticsearch_config:="%%PREFIX%%/etc/elasticsearch"}
+: ${elasticsearch_tmp:="/var/tmp/elasticsearch"}
+
+required_files="${elasticsearch_config}/elasticsearch.yml"
+pidfile="/var/run/${name}.pid"
+
+extra_commands="console status"
+console_cmd="elasticsearch_console"
+start_precmd="elasticsearch_precmd"
+status_cmd="elasticsearch_status"
+stop_cmd="elasticsearch_stop"
+command="%%PREFIX%%/lib/elasticsearch/bin/elasticsearch"
+command_args="-d --pidfile=${pidfile}"
+
+elasticsearch_precmd()
+{
+ touch ${pidfile}
+ chown ${elasticsearch_user}:${elasticsearch_group} ${pidfile}
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 ${elasticsearch_tmp}
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 /var/db/elasticsearch
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 /var/log/elasticsearch
+}
+
+elasticsearch_console()
+{
+ command_args=""
+ run_rc_command "start"
+}
+
+
+elasticsearch_stop()
+{
+ rc_pid=$(elasticsearch_check_pidfile $pidfile)
+
+ if [ -z "$rc_pid" ]; then
+ [ -n "$rc_fast" ] && return 0
+ echo "${name} not running? (check $pidfile)."
+ return 1
+ fi
+
+ echo "Stopping ${name}."
+ kill ${rc_pid} 2> /dev/null
+}
+
+elasticsearch_status()
+{
+ rc_pid=$(elasticsearch_check_pidfile $pidfile)
+
+ if [ -z "$rc_pid" ]; then
+ [ -n "$rc_fast" ] && return 0
+ echo "${name} not running? (check $pidfile)."
+ return 1
+ fi
+ echo "${name} is running as pid ${rc_pid}."
+}
+
+elasticsearch_check_pidfile()
+{
+ _pidfile=$1
+ if [ -z "$_pidfile" ]; then
+ err 3 'USAGE: elasticsearch_check_pidfile pidfile'
+ fi
+ if [ ! -f $_pidfile ]; then
+ debug "pid file ($_pidfile): not readable."
+ return
+ fi
+ read _pid _junk < $_pidfile
+ if [ -z "$_pid" ]; then
+ debug "pid file ($_pidfile): no pid in file."
+ return
+ fi
+ if [ -n "`%%LOCALBASE%%/bin/jps -l | grep -e "^$_pid"`" ]; then
+ echo -n $_pid
+ fi
+}
+
+run_rc_command "$1"
diff --git a/textproc/elasticsearch2/files/patch-bin-elasticsearch.in.sh b/textproc/elasticsearch2/files/patch-bin-elasticsearch.in.sh
new file mode 100644
index 000000000000..ccc1f18eb10c
--- /dev/null
+++ b/textproc/elasticsearch2/files/patch-bin-elasticsearch.in.sh
@@ -0,0 +1,22 @@
+--- bin/elasticsearch.in.sh.orig 2015-11-19 16:02:28.386051810 -0500
++++ bin/elasticsearch.in.sh 2015-11-19 16:02:56.618049877 -0500
+@@ -1,5 +1,19 @@
+ #!/bin/sh
+
++if [ `uname -o` == "FreeBSD" ]; then
++ . /etc/rc.subr
++ load_rc_config elasticsearch
++ ES_MIN_MEM=${elasticsearch_min_mem}
++ ES_MAX_MEM=${elasticsearch_max_mem}
++ ES_HEAP_NEW_SIZE=${elasticsearch_heap_newsize}
++ ES_DIRECT_SIZE=${elasticsearch_direct_size}
++ ES_USE_IPV4=${elasticsearch_use_ipv4}
++ ES_GC_OPTS=${elasticsearch_gc_opts}
++ ES_GC_LOG_FILE=${elasticsearch_gc_logfile}
++ JAVA_OPTS="$JAVA_OPTS -Des.path.conf=${elasticsearch_config:="%%PREFIX%%/etc/elasticsearch"}"
++ JAVA_OPTS="$JAVA_OPTS -Des.path.scripts=${elasticsearch_scripts:="%%PREFIX%%/libexec/elasticsearch"}"
++fi
++
+ # check in case a user was using this mechanism
+ if [ "x$ES_CLASSPATH" != "x" ]; then
+ cat >&2 << EOF
diff --git a/textproc/elasticsearch2/files/patch-config-elasticsearch.yml b/textproc/elasticsearch2/files/patch-config-elasticsearch.yml
new file mode 100644
index 000000000000..3cb9c2f81be2
--- /dev/null
+++ b/textproc/elasticsearch2/files/patch-config-elasticsearch.yml
@@ -0,0 +1,15 @@
+--- config/elasticsearch.yml.orig 2015-10-21 04:41:12.000000000 -0400
++++ config/elasticsearch.yml 2015-11-19 12:34:39.766910803 -0500
+@@ -31,10 +31,12 @@
+ # Path to directory where to store the data (separate multiple locations by comma):
+ #
+ # path.data: /path/to/data
++path.data: /var/db/elasticsearch
+ #
+ # Path to log files:
+ #
+ # path.logs: /path/to/logs
++path.logs: /var/log/elasticsearch
+ #
+ # ----------------------------------- Memory -----------------------------------
+ #
diff --git a/textproc/elasticsearch2/files/pkg-message.in b/textproc/elasticsearch2/files/pkg-message.in
new file mode 100644
index 000000000000..e7f3aecf52b8
--- /dev/null
+++ b/textproc/elasticsearch2/files/pkg-message.in
@@ -0,0 +1,6 @@
+======================================================================
+
+Please see %%ETCDIR%% for sample versions of
+elasticsearch.yml and logging.yml.
+
+======================================================================
diff --git a/textproc/elasticsearch2/pkg-descr b/textproc/elasticsearch2/pkg-descr
new file mode 100644
index 000000000000..a4d6442315f0
--- /dev/null
+++ b/textproc/elasticsearch2/pkg-descr
@@ -0,0 +1,4 @@
+Elasticsearch aims to be a Distributed, RESTful, Search Engine built on top of
+Apache Lucene.
+
+WWW: http://www.elasticsearch.org/
diff --git a/textproc/elasticsearch2/pkg-plist b/textproc/elasticsearch2/pkg-plist
new file mode 100644
index 000000000000..7649a8674976
--- /dev/null
+++ b/textproc/elasticsearch2/pkg-plist
@@ -0,0 +1,56 @@
+@sample(%%SEARCHUSER%%,%%SEARCHGROUP%%,440) %%ETCDIR%%/elasticsearch.yml.sample
+@sample(%%SEARCHUSER%%,%%SEARCHGROUP%%,440) %%ETCDIR%%/logging.yml.sample
+@unexec if [ -d %%ELASTIC_LOGDIR%% ]; then echo "You should remove %%ELASTIC_LOGDIR%% if you don't need it any more."; fi
+@unexec if [ -d %%ELASTIC_DBDIR%% ]; then echo "You should remove %%ELASTIC_DBDIR%% if you don't need it any more."; fi
+bin/elasticsearch-plugin
+lib/elasticsearch/lib/HdrHistogram-2.1.6.jar
+lib/elasticsearch/lib/antlr-runtime-3.5.jar
+lib/elasticsearch/lib/apache-log4j-extras-1.2.17.jar
+lib/elasticsearch/lib/asm-4.1.jar
+lib/elasticsearch/lib/asm-commons-4.1.jar
+lib/elasticsearch/lib/commons-cli-1.3.1.jar
+lib/elasticsearch/lib/compiler-0.8.13.jar
+lib/elasticsearch/lib/compress-lzf-1.0.2.jar
+lib/elasticsearch/lib/elasticsearch-%%PORTVERSION%%.jar
+lib/elasticsearch/lib/groovy-all-2.4.4-indy.jar
+lib/elasticsearch/lib/guava-18.0.jar
+lib/elasticsearch/lib/hppc-0.7.1.jar
+lib/elasticsearch/lib/jackson-core-2.5.3.jar
+lib/elasticsearch/lib/jackson-dataformat-cbor-2.5.3.jar
+lib/elasticsearch/lib/jackson-dataformat-smile-2.5.3.jar
+lib/elasticsearch/lib/jackson-dataformat-yaml-2.5.3.jar
+lib/elasticsearch/lib/jna-4.1.0.jar
+lib/elasticsearch/lib/joda-convert-1.2.jar
+lib/elasticsearch/lib/joda-time-2.8.2.jar
+lib/elasticsearch/lib/jsr166e-1.1.0.jar
+lib/elasticsearch/lib/jts-1.13.jar
+lib/elasticsearch/lib/log4j-1.2.17.jar
+lib/elasticsearch/lib/lucene-analyzers-common-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-backward-codecs-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-core-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-expressions-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-grouping-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-highlighter-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-join-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-memory-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-misc-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-queries-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-queryparser-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-sandbox-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-spatial-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-suggest-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/netty-3.10.5.Final.jar
+lib/elasticsearch/lib/snakeyaml-1.12.jar
+lib/elasticsearch/lib/spatial4j-0.4.1.jar
+lib/elasticsearch/lib/t-digest-3.0.jar
+lib/elasticsearch/bin/elasticsearch.in.sh
+lib/elasticsearch/bin/elasticsearch
+lib/elasticsearch/bin/plugin
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/NOTICE.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.textile
+@dir lib/elasticsearch/lib
+@dir lib/elasticsearch/bin
+@dir lib/elasticsearch/plugins
+@dir lib/elasticsearch
+@dir libexec/elasticsearch