aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-10-10 09:13:07 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-10-10 09:13:07 +0000
commitcd655f389fbedd94c5c438e3f1e294d0953e342b (patch)
treeac646f82f23ac112618757faefc4ca2e317a543a /textproc
parent71eade7397374640c0cb87bc26b21c581b01c958 (diff)
downloadports-cd655f389fbedd94c5c438e3f1e294d0953e342b.tar.gz
ports-cd655f389fbedd94c5c438e3f1e294d0953e342b.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xqilla/Makefile27
1 files changed, 22 insertions, 5 deletions
diff --git a/textproc/xqilla/Makefile b/textproc/xqilla/Makefile
index f65aa3c44a85..47681463aa83 100644
--- a/textproc/xqilla/Makefile
+++ b/textproc/xqilla/Makefile
@@ -3,21 +3,38 @@
PORTNAME= xqilla
PORTVERSION= 2.3.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= textproc
MASTER_SITES= SF
DISTNAME= XQilla-${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
-COMMENT= An XQuery and XPath2 library
+COMMENT= XQuery and XPath2 library
-LIB_DEPENDS= xerces-c.3:${PORTSDIR}/textproc/xerces-c3
+OPTIONS_DEFINE= DOCS
-USE_GMAKE= yes
-USES= perl5
+LICENSE= AL2
+
+LIB_DEPENDS= libxerces-c.so.3:${PORTSDIR}/textproc/xerces-c3
+
+USES= gmake
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+
+post-build:
+ cd ${WRKSRC} && ${GMAKE} docs
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} \*-api ${STAGEDIR}${DOCSDIR}
+.endif
-NO_STAGE= yes
.include <bsd.port.mk>