aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-22 07:48:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-22 07:48:12 +0000
commite9aece4d3b2d3a6c1cf45bcb0d571728ef08f677 (patch)
treeed9bf14616b36df1ec0ab38323105ac63e26e354 /textproc
parentc97823efa72f2400abd46029e20f7b3fb2ef73bd (diff)
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xerces-c2/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/textproc/xerces-c2/Makefile b/textproc/xerces-c2/Makefile
index b823a45667e0..8e3ddb5d832c 100644
--- a/textproc/xerces-c2/Makefile
+++ b/textproc/xerces-c2/Makefile
@@ -20,11 +20,10 @@ ICONVFBSD_DESC= Use IconvFBSD transcoder
ICU_DESC= Use ICU transcoder
NATIVE_DESC= Use native transcoder
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MICU}
-LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu
+LIB_DEPENDS+= libicuuc.so:${PORTSDIR}/devel/icu
ICUROOT?= ${LOCALBASE}
CONFIGURE_ENV+= ICUROOT=${ICUROOT}
MAKE_ENV+= ICUROOT=${ICUROOT}
@@ -147,16 +146,16 @@ post-configure:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${CP} -r ${WRKSRC}/doc/ ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${CP} -r ${WRKSRC}/doc/ ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for i in ${XERCES_BINS} data
- @${CP} -r ${WRKSRC}/samples/$i ${EXAMPLESDIR}
+ @${CP} -r ${WRKSRC}/samples/$i ${STAGEDIR}${EXAMPLESDIR}
.endfor
.for i in ${XERCES_BINS}
- @${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${STAGEDIR}${PREFIX}/bin
.endfor
.endif