aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
commitfae8e0f615b1dfcff35249a7a11ebfba7391bc56 (patch)
treecbba292aa57c0d2e7bb423ca0366362b198eec85 /textproc
parent090dbb7b77d15ec9d072089f51c17e73d6e22f59 (diff)
downloadports-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.tar.gz
ports-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/rubygem-ferret/Makefile8
-rw-r--r--textproc/rubygem-formosa/Makefile7
-rw-r--r--textproc/rubygem-htmltools/Makefile7
-rw-r--r--textproc/rubygem-ini/Makefile7
-rw-r--r--textproc/rubygem-rak/Makefile7
-rw-r--r--textproc/rubygem-spreadsheet-excel/Makefile7
-rw-r--r--textproc/rubygem-spreadsheet/Makefile7
-rw-r--r--textproc/rubygem-syntax/Makefile8
-rw-r--r--textproc/rubygem-tidy/Makefile7
9 files changed, 37 insertions, 28 deletions
diff --git a/textproc/rubygem-ferret/Makefile b/textproc/rubygem-ferret/Makefile
index 00e0a8c10701..83d9e80537e9 100644
--- a/textproc/rubygem-ferret/Makefile
+++ b/textproc/rubygem-ferret/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= RF
MAINTAINER= clsung@FreeBSD.org
COMMENT= Ferret is a ruby port of Lucene
-BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake
-
USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
post-install:
@${FIND} ${PREFIX}/${GEM_LIB_DIR} ! -type d | \
@@ -27,6 +27,4 @@ post-install:
@${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d | ${SORT} -r | \
${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-formosa/Makefile b/textproc/rubygem-formosa/Makefile
index a9d65d1f3ab3..f36dd060519b 100644
--- a/textproc/rubygem-formosa/Makefile
+++ b/textproc/rubygem-formosa/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= rubygem-activesupport>=1.4.2:${PORTSDIR}/devel/rubygem-activesuppor
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-htmltools/Makefile b/textproc/rubygem-htmltools/Makefile
index 70d5659ca320..274eb2f6631e 100644
--- a/textproc/rubygem-htmltools/Makefile
+++ b/textproc/rubygem-htmltools/Makefile
@@ -14,6 +14,7 @@ DISTNAME= htmltools-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Tools for parsing and manipulating HTML text in Ruby
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-ini/Makefile b/textproc/rubygem-ini/Makefile
index dca740f0c018..701de2cb7661 100644
--- a/textproc/rubygem-ini/Makefile
+++ b/textproc/rubygem-ini/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}file
MAINTAINER= yds@CoolRat.org
COMMENT= Ruby INI File Parser and Writer
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-rak/Makefile b/textproc/rubygem-rak/Makefile
index f6d972ea8342..dbb4610484ba 100644
--- a/textproc/rubygem-rak/Makefile
+++ b/textproc/rubygem-rak/Makefile
@@ -16,6 +16,7 @@ COMMENT= A grep replacement in pure Ruby
BUILD_DEPENDS= rubygem-hoe>=1.3.0:${PORTSDIR}/devel/rubygem-hoe
RUN_DEPENDS= rubygem-hoe>=1.3.0:${PORTSDIR}/devel/rubygem-hoe
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-spreadsheet-excel/Makefile b/textproc/rubygem-spreadsheet-excel/Makefile
index da9e3264faa4..0f4aef20598d 100644
--- a/textproc/rubygem-spreadsheet-excel/Makefile
+++ b/textproc/rubygem-spreadsheet-excel/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= spreadsheet
MAINTAINER= ports@logvinov.com
COMMENT= A Ruby module to generate Microsoft Excel compatible files
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-spreadsheet/Makefile b/textproc/rubygem-spreadsheet/Makefile
index da9e3264faa4..0f4aef20598d 100644
--- a/textproc/rubygem-spreadsheet/Makefile
+++ b/textproc/rubygem-spreadsheet/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= spreadsheet
MAINTAINER= ports@logvinov.com
COMMENT= A Ruby module to generate Microsoft Excel compatible files
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-syntax/Makefile b/textproc/rubygem-syntax/Makefile
index cc263b117951..6a0376b5055b 100644
--- a/textproc/rubygem-syntax/Makefile
+++ b/textproc/rubygem-syntax/Makefile
@@ -14,14 +14,18 @@ PKGNAMEPREFIX= rubygem-
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A module for using Systax highlighting in Ruby
+USE_RUBY= yes
+
.include <bsd.port.pre.mk>
#.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
# syntax.gem has invalid content, we need to buuild the gem ourself
+.if ${RUBY_VER} == 1.8
BUILD_DEPENDS+= ${RUBYGEMBIN}:${PORTSDIR}/devel/ruby-gems
RUN_DEPENDS+= ${BUILD_DEPENDS}
+.endif
-REV= 1.8
+REV= ${RUBY_VER}
GEMS_BASE_DIR= lib/ruby/gems/${REV}
GEMS_DIR= ${GEMS_BASE_DIR}/gems
DOC_DIR= ${GEMS_BASE_DIR}/doc
@@ -48,7 +52,7 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}" \
GEM_CACHE="${GEM_CACHE}" \
EXTRACT_SUFX="${EXTRACT_SUFX}"
-RUBYGEMBIN= ${LOCALBASE}/bin/gem18
+RUBYGEMBIN= ${LOCALBASE}/bin/gem${RUBY_VER:S/.//}
do-build:
cd ${WRKSRC} && ${RUBYGEMBIN} build syntax.gemspec
diff --git a/textproc/rubygem-tidy/Makefile b/textproc/rubygem-tidy/Makefile
index 94edf87b2885..3b50400a45bd 100644
--- a/textproc/rubygem-tidy/Makefile
+++ b/textproc/rubygem-tidy/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= don@na.rim.or.jp
COMMENT= Ruby interface to HTML Tidy Library Project
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>