aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2007-05-31 11:29:52 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2007-05-31 11:29:52 +0000
commitc8630b3adfd85115e4f3211f6987fbc7c57e94bd (patch)
tree33adad66f5222f15544b1abea5b67168e0e5fb8b /textproc
parentba32102818e13876d70f494e70253167f9f538cd (diff)
downloadports-c8630b3adfd85115e4f3211f6987fbc7c57e94bd.tar.gz
ports-c8630b3adfd85115e4f3211f6987fbc7c57e94bd.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-MARC-Lint/Makefile27
-rw-r--r--textproc/p5-MARC-Lint/distinfo3
-rw-r--r--textproc/p5-MARC-Lint/pkg-descr1
-rw-r--r--textproc/p5-MARC-Lint/pkg-plist6
5 files changed, 38 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3f5b77f97760..6ea9cd10367d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -402,6 +402,7 @@
SUBDIR += p5-Lingua-StopWords
SUBDIR += p5-Lucene
SUBDIR += p5-MARC
+ SUBDIR += p5-MARC-Lint
SUBDIR += p5-MARC-Record
SUBDIR += p5-MKDoc-XML
SUBDIR += p5-Makefile-Parser
diff --git a/textproc/p5-MARC-Lint/Makefile b/textproc/p5-MARC-Lint/Makefile
new file mode 100644
index 000000000000..bf84c09ddf76
--- /dev/null
+++ b/textproc/p5-MARC-Lint/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-MARC-Lint
+# Date created: 31 May 2007
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MARC-Lint
+PORTVERSION= 1.42
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= MARC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= A mechanism for validating MARC records
+
+BUILD_DEPENDS= ${SITE_PERL}/MARC/Record.pm:${PORTSDIR}/textproc/p5-MARC-Record \
+ ${SISTE_PERL}/Business/ISBN.pm:${PORTSDIR}/misc/p5-Business-ISBN
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN1= marclint.1
+MAN3= MARC::Lint.3 MARC::Lint::CodeData.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-MARC-Lint/distinfo b/textproc/p5-MARC-Lint/distinfo
new file mode 100644
index 000000000000..d2b808b83ea3
--- /dev/null
+++ b/textproc/p5-MARC-Lint/distinfo
@@ -0,0 +1,3 @@
+MD5 (MARC-Lint-1.42.tar.gz) = a9bdbd28493554a76945e8fc4a8610fe
+SHA256 (MARC-Lint-1.42.tar.gz) = 740cc4c32e50a223dd43253b75130a2931621c8796900b329ef29fa436df56a4
+SIZE (MARC-Lint-1.42.tar.gz) = 69441
diff --git a/textproc/p5-MARC-Lint/pkg-descr b/textproc/p5-MARC-Lint/pkg-descr
new file mode 100644
index 000000000000..b33ed9cf2e50
--- /dev/null
+++ b/textproc/p5-MARC-Lint/pkg-descr
@@ -0,0 +1 @@
+MARC::Lint provides a mechanism for validating MARC records.
diff --git a/textproc/p5-MARC-Lint/pkg-plist b/textproc/p5-MARC-Lint/pkg-plist
new file mode 100644
index 000000000000..0d916d9119a0
--- /dev/null
+++ b/textproc/p5-MARC-Lint/pkg-plist
@@ -0,0 +1,6 @@
+bin/marclint
+%%SITE_PERL%%/MARC/Lint.pm
+%%SITE_PERL%%/MARC/Lint/CodeData.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MARC/Lint/.packlist
+@dirrm %%SITE_PERL%%/MARC/Lint
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MARC/Lint