aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-02-10 19:15:43 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-02-10 19:15:43 +0000
commitd6aed984524d8175ec8dd4c2883467df5acf626a (patch)
treec0fc0e5fceb184dd43f323c442b579b4635d0b70 /textproc
parent487cc991b8bc9908571b177bc8e03c262d761798 (diff)
downloadports-d6aed984524d8175ec8dd4c2883467df5acf626a.tar.gz
ports-d6aed984524d8175ec8dd4c2883467df5acf626a.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libxml2/Makefile10
-rw-r--r--textproc/libxml2/files/patch-ab20
-rw-r--r--textproc/libxml2/files/patch-ae14
3 files changed, 36 insertions, 8 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 25c37e2b7c4a..42fca8cbe1c4 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -7,13 +7,14 @@
PORTNAME= libxml2
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/libxml
MAINTAINER= sobomax@FreeBSD.org
-LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
+LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
USE_GMAKE= yes
USE_LIBTOOL= yes
@@ -21,14 +22,9 @@ INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-iconv
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -liconv"
+ LIBS="-L${LOCALBASE}/lib -lgiconv"
MAN1= xml2-config.1 xmllint.1
MAN4= libxml.4
-#pre-patch:
-# @find ${WRKSRC}/include -type f -name "*.h" | \
-# xargs ${PERL} -pi -e 's|libxml/|libxml2/|'
-# @${LN} -sf ${WRKSRC}/include/libxml ${WRKSRC}/include/libxml2
-
.include <bsd.port.mk>
diff --git a/textproc/libxml2/files/patch-ab b/textproc/libxml2/files/patch-ab
index e21bcc174b83..752788d6c57b 100644
--- a/textproc/libxml2/files/patch-ab
+++ b/textproc/libxml2/files/patch-ab
@@ -2,7 +2,7 @@
$FreeBSD$
--- configure.orig Thu Feb 8 13:39:59 2001
-+++ configure Fri Feb 9 02:04:41 2001
++++ configure Fri Feb 9 23:40:58 2001
@@ -3474,7 +3474,7 @@
@@ -12,3 +12,21 @@ $FreeBSD$
XML_LIBS="-lxml2 $Z_LIBS $M_LIBS $LIBS"
XML_CFLAGS=""
+@@ -3871,7 +3871,7 @@
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char $ac_func();
++char lib$ac_func();
+
+ int main() {
+
+@@ -3881,7 +3881,7 @@
+ #if defined (__stub_$ac_func) || defined (__stub___$ac_func)
+ choke me
+ #else
+-$ac_func();
++lib$ac_func();
+ #endif
+
+ ; return 0; }
diff --git a/textproc/libxml2/files/patch-ae b/textproc/libxml2/files/patch-ae
new file mode 100644
index 000000000000..00fd712110b4
--- /dev/null
+++ b/textproc/libxml2/files/patch-ae
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- include/libxml/encoding.h 2001/02/09 21:35:22 1.1
++++ include/libxml/encoding.h 2001/02/09 21:35:37
+@@ -23,7 +23,7 @@
+
+ #include <libxml/xmlversion.h>
+ #ifdef LIBXML_ICONV_ENABLED
+-#include <iconv.h>
++#include <giconv.h>
+ #endif
+ #include <libxml/tree.h>
+