aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-19 23:26:45 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-19 23:26:45 +0000
commit89182e000d784022c163cd3ee7de3ea1d739c202 (patch)
treeddfa8fc122b2177cf4916e9a78013e90721426a1 /textproc
parent2042e206581788b8102debc1b364f20efc42ef17 (diff)
downloadports-89182e000d784022c163cd3ee7de3ea1d739c202.tar.gz
ports-89182e000d784022c163cd3ee7de3ea1d739c202.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-CQL-Parser/Makefile47
-rw-r--r--textproc/p5-CQL-Parser/distinfo3
-rw-r--r--textproc/p5-CQL-Parser/pkg-descr23
-rw-r--r--textproc/p5-CQL-Parser/pkg-plist19
5 files changed, 93 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 1ea6fc168399..db75c587bc1c 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -291,6 +291,7 @@
SUBDIR += p5-Apache-ParseLog
SUBDIR += p5-Apache-XBEL
SUBDIR += p5-Bloom-Filter
+ SUBDIR += p5-CQL-Parser
SUBDIR += p5-CSS-SAC
SUBDIR += p5-CSS-Tiny
SUBDIR += p5-Chess-PGN-Parse
diff --git a/textproc/p5-CQL-Parser/Makefile b/textproc/p5-CQL-Parser/Makefile
new file mode 100644
index 000000000000..482213c1fe3a
--- /dev/null
+++ b/textproc/p5-CQL-Parser/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: CQL-Parser
+# Date created: 19 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CQL-Parser
+PORTVERSION= 0.98
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/E/ES/ESUMMERS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Compiles CQL strings into parse trees of Node subtypes
+
+BUILD_DEPENDS= ${SITE_PERL}/String/Tokenizer.pm:${PORTSDIR}/textproc/p5-String-Tokenizer \
+ ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= CQL::AndNode.3 \
+ CQL::BooleanNode.3 \
+ CQL::Lexer.3 \
+ CQL::ModifierSet.3 \
+ CQL::Node.3 \
+ CQL::NotNode.3 \
+ CQL::OrNode.3 \
+ CQL::Parser.3 \
+ CQL::Prefix.3 \
+ CQL::PrefixNode.3 \
+ CQL::ProxNode.3 \
+ CQL::Relation.3 \
+ CQL::TermNode.3 \
+ CQL::Token.3 \
+ CQL::Visitor.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-CQL-Parser/distinfo b/textproc/p5-CQL-Parser/distinfo
new file mode 100644
index 000000000000..7494a40666df
--- /dev/null
+++ b/textproc/p5-CQL-Parser/distinfo
@@ -0,0 +1,3 @@
+MD5 (CQL-Parser-0.98.tar.gz) = 22eceae1796185472b13889a1f4b3f6f
+SHA256 (CQL-Parser-0.98.tar.gz) = d8e9d5eb224c80b2f75ec62c2c68600d741170d3546f5ae07dfd18b66dc666d8
+SIZE (CQL-Parser-0.98.tar.gz) = 19276
diff --git a/textproc/p5-CQL-Parser/pkg-descr b/textproc/p5-CQL-Parser/pkg-descr
new file mode 100644
index 000000000000..4a3cf1f309a0
--- /dev/null
+++ b/textproc/p5-CQL-Parser/pkg-descr
@@ -0,0 +1,23 @@
+CQL::Parser provides a mechanism to parse Common Query Language (CQL)
+statements. The best description of CQL comes from the CQL homepage at the
+Library of Congress http://www.loc.gov/z3950/agency/zing/cql/
+
+CQL is a formal language for representing queries to information retrieval
+systems such as web indexes, bibliographic catalogs and museum collection
+information. The CQL design objective is that queries be human readable
+and human writable, and that the language be intuitive while maintaining
+the expressiveness of more complex languages.
+
+A CQL statement can be as simple as a single keyword, or as complicated as
+a set of compoenents indicating search indexes, relations, relational
+modifiers, proximity clauses and boolean logic. CQL::Parser will parse CQL
+statements and return the root node for a tree of nodes which describes
+the CQL statement. This data structure can then be used by a client
+application to analyze the statement, and possibly turn it into a query
+for a local repository.
+
+WWW: http://search.cpan.org/dist/CQL-Parser
+Authors:
+ * Ed Summers - ehs at pobox dot com
+ * Brian Cassidy - brian.cassidy at gmail dot com
+ * Wilbert Hengst - W.Hengst at uva dot nl
diff --git a/textproc/p5-CQL-Parser/pkg-plist b/textproc/p5-CQL-Parser/pkg-plist
new file mode 100644
index 000000000000..9c3244fd1c64
--- /dev/null
+++ b/textproc/p5-CQL-Parser/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/CQL/AndNode.pm
+%%SITE_PERL%%/CQL/BooleanNode.pm
+%%SITE_PERL%%/CQL/Lexer.pm
+%%SITE_PERL%%/CQL/ModifierSet.pm
+%%SITE_PERL%%/CQL/Node.pm
+%%SITE_PERL%%/CQL/NotNode.pm
+%%SITE_PERL%%/CQL/OrNode.pm
+%%SITE_PERL%%/CQL/Parser.pm
+%%SITE_PERL%%/CQL/Prefix.pm
+%%SITE_PERL%%/CQL/PrefixNode.pm
+%%SITE_PERL%%/CQL/ProxNode.pm
+%%SITE_PERL%%/CQL/Relation.pm
+%%SITE_PERL%%/CQL/TermNode.pm
+%%SITE_PERL%%/CQL/Token.pm
+%%SITE_PERL%%/CQL/Utils.pm
+%%SITE_PERL%%/CQL/Visitor.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CQL-Parser/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CQL-Parser
+@dirrm %%SITE_PERL%%/CQL