aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
commitcb8b1428c6bb9ed135f61a9cecbe8397defbf329 (patch)
tree0a68a09c88303888985b47f7045bed36788aefc2 /textproc
parent563bcaab10c891e4bee07c4ec1fbf46515c5a0b4 (diff)
downloadports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.tar.gz
ports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/rasqal/Makefile48
-rw-r--r--textproc/rasqal/distinfo4
-rw-r--r--textproc/rasqal/pkg-plist1
-rw-r--r--textproc/redland-bindings/Makefile79
-rw-r--r--textproc/redland-bindings/distinfo4
-rw-r--r--textproc/soprano/Makefile30
-rw-r--r--textproc/soprano/distinfo4
-rw-r--r--textproc/soprano/pkg-descr13
-rw-r--r--textproc/soprano/pkg-message10
-rw-r--r--textproc/soprano/pkg-plist1
10 files changed, 92 insertions, 102 deletions
diff --git a/textproc/rasqal/Makefile b/textproc/rasqal/Makefile
index c70625e0a5c6..8ee93737c95a 100644
--- a/textproc/rasqal/Makefile
+++ b/textproc/rasqal/Makefile
@@ -1,51 +1,45 @@
-# ex:ts=8
-# New ports collection makefile for: redland
-# Date created: Nov 22, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= rasqal
-PORTVERSION= 0.9.29
-PORTREVISION= 1
+PORTVERSION= 0.9.30
CATEGORIES= textproc
MASTER_SITES= http://download.librdf.org/source/ \
SF/librdf/${PORTNAME}/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
-COMMENT= A high-level interface for RDF
+COMMENT= High-level interface for RDF
-LIB_DEPENDS= raptor2.0:${PORTSDIR}/textproc/raptor2 \
- pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= raptor2:${PORTSDIR}/textproc/raptor2 \
+ pcre:${PORTSDIR}/devel/pcre
-USE_GNOME= gnomehack lthack pkgconfig
+USE_GNOME= gnomehack lthack
USE_OPENSSL= yes
-USE_GMAKE= yes
+USE_PERL5_BUILD=yes
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
-
+USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PERL5_BUILD= yes
MAN1= rasqal-config.1 roqet.1
MAN3= librasqal.3
-OPTIONS+= MPFR "Use MPFR library for decimals (implies GMP)" off
-OPTIONS+= GMP "Use Gnu MP library for decimals" off
+OPTIONS_RADIO= DEC
+OPTIONS_RADIO_DEC= GMP MPFR
+
+GMP_DESC= Use GMP library for decimals
+MPFR_DESC= Use MPFR library for decimals
.include <bsd.port.options.mk>
-# Set to mpfr if MPFR is on, gmp if only GMP is on and none if neither.
-# This guards against $user setting both GMP and MPFR, since we can't be
-# very verbose in explaining our options.
-.if defined(WITH_MPFR)
-CONFIGURE_ARGS+= --with-decimal=mpfr --with-mpfr=${LOCALBASE}
-LIB_DEPENDS+= mpfr.4:${PORTSDIR}/math/mpfr
-.elif defined(WITH_GMP)
-CONFIGURE_ARGS+= --with-decimal=gmp
-LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
+.if ${PORT_OPTIONS:MMPFR}
+CONFIGURE_ARGS+=--with-decimal=mpfr --with-mpfr=${LOCALBASE}
+LIB_DEPENDS+= mpfr:${PORTSDIR}/math/mpfr
+.elif ${PORT_OPTIONS:MGMP}
+CONFIGURE_ARGS+=--with-decimal=gmp
+LIB_DEPENDS+= gmp:${PORTSDIR}/math/gmp
.else
-CONFIGURE_ARGS+= --with-decimal=none
+CONFIGURE_ARGS+=--with-decimal=none
.endif
.include <bsd.port.mk>
diff --git a/textproc/rasqal/distinfo b/textproc/rasqal/distinfo
index b1e25bd9e194..4ac19a7bcf2e 100644
--- a/textproc/rasqal/distinfo
+++ b/textproc/rasqal/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rasqal-0.9.29.tar.gz) = 8b218dc51b77b99f33103a9251218a4439748f73ee30fa8ee549ab6d150e7c53
-SIZE (rasqal-0.9.29.tar.gz) = 1550144
+SHA256 (rasqal-0.9.30.tar.gz) = abf0e93d80cc79bdf383fd3e904255bf98bc729356d6cf2f673bce74b08b1cfd
+SIZE (rasqal-0.9.30.tar.gz) = 1469921
diff --git a/textproc/rasqal/pkg-plist b/textproc/rasqal/pkg-plist
index 209e2bef878f..776f1dafd444 100644
--- a/textproc/rasqal/pkg-plist
+++ b/textproc/rasqal/pkg-plist
@@ -18,6 +18,7 @@ share/gtk-doc/html/rasqal/rasqal-changes-0-9-24-to-0-9-25.html
share/gtk-doc/html/rasqal/rasqal-changes-0-9-25-to-0-9-26.html
share/gtk-doc/html/rasqal/rasqal-changes-0-9-26-to-0-9-27.html
share/gtk-doc/html/rasqal/rasqal-changes-0-9-28-to-0-9-29.html
+share/gtk-doc/html/rasqal/rasqal-changes-0-9-29-to-0-9-30.html
share/gtk-doc/html/rasqal/rasqal-changes.html
share/gtk-doc/html/rasqal/rasqal-section-data.html
share/gtk-doc/html/rasqal/rasqal-section-expression.html
diff --git a/textproc/redland-bindings/Makefile b/textproc/redland-bindings/Makefile
index 554e388f05d1..5680f9de89f5 100644
--- a/textproc/redland-bindings/Makefile
+++ b/textproc/redland-bindings/Makefile
@@ -1,83 +1,78 @@
-# New ports collection makefile for: redland-bindings
-# Date created: 2004-08-10
-# Whom: Russell Cloran <russell@rucus.ru.ac.za>
-#
+# Created by: Russell Cloran <russell@rucus.ru.ac.za>
# $FreeBSD$
-#
PORTNAME= redland-bindings
-PORTVERSION= 1.0.14.1
-CATEGORIES= textproc
+PORTVERSION= 1.0.16.1
+CATEGORIES?= textproc
MASTER_SITES= http://download.librdf.org/source/
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Language bindings for the Redland package
+MAINTAINER?= kde@FreeBSD.org
+COMMENT?= Language bindings for the Redland package
-LIB_DEPENDS= rdf.0:${PORTSDIR}/textproc/redland
-
-OPTIONS= PERL "Add Perl bindings" off \
- PHP "Add PHP bindings" off \
- PYTHON "Add Python bindings" on \
- RUBY "Add Ruby bindings" off
+LIB_DEPENDS= rdf:${PORTSDIR}/textproc/redland
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+OPTIONS_DEFINE= PERL PHP PYTHON RUBY
+OPTIONS_DEFAULT=PYTHON
.include <bsd.port.options.mk>
-.if defined(WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
USE_PERL5= yes
-CONFIGURE_ARGS+= --with-perl
+CONFIGURE_ARGS+=--with-perl
PLIST_SUB+= WITH_PERL=""
MANPREFIX= ${LOCALBASE}/lib/perl5/${PERL_VERSION}
-MAN3= RDF::Redland.3 \
- RDF::Redland::BlankNode.3 \
- RDF::Redland::Iterator.3 \
- RDF::Redland::LiteralNode.3 \
- RDF::Redland::Model.3 \
- RDF::Redland::Node.3 \
- RDF::Redland::Parser.3 \
- RDF::Redland::Query.3 \
- RDF::Redland::QueryResults.3 \
- RDF::Redland::RSS.3 \
- RDF::Redland::Serializer.3 \
- RDF::Redland::Statement.3 \
- RDF::Redland::Storage.3 \
- RDF::Redland::Stream.3 \
- RDF::Redland::URI.3 \
- RDF::Redland::URINode.3 \
- RDF::Redland::XMLLiteralNode.3
+MAN3= RDF::Redland.3 \
+ RDF::Redland::BlankNode.3 \
+ RDF::Redland::Iterator.3 \
+ RDF::Redland::LiteralNode.3 \
+ RDF::Redland::Model.3 \
+ RDF::Redland::Node.3 \
+ RDF::Redland::Parser.3 \
+ RDF::Redland::Query.3 \
+ RDF::Redland::QueryResults.3 \
+ RDF::Redland::RSS.3 \
+ RDF::Redland::Serializer.3 \
+ RDF::Redland::Statement.3 \
+ RDF::Redland::Storage.3 \
+ RDF::Redland::Stream.3 \
+ RDF::Redland::URI.3 \
+ RDF::Redland::URINode.3 \
+ RDF::Redland::XMLLiteralNode.3
.else
PLIST_SUB+= WITH_PERL="@comment "
.endif
-.if defined(WITH_PHP)
+.if ${PORT_OPTIONS:MPHP}
USE_PHP= yes
USE_PHP_BUILD= yes
-CONFIGURE_ARGS+= --with-php
+CONFIGURE_ARGS+=--with-php
PLIST_SUB+= WITH_PHP=""
.else
PLIST_SUB+= WITH_PHP="@comment "
.endif
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= 2.5+
-CONFIGURE_ARGS+= --with-python
+CONFIGURE_ARGS+=--with-python
PLIST_SUB+= WITH_PYTHON=""
.else
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
-.if defined(WITH_RUBY)
+.if ${PORT_OPTIONS:MRUBY}
USE_RUBY= yes
-CONFIGURE_ARGS+= --with-ruby
+CONFIGURE_ARGS+=--with-ruby
PLIST_SUB+= WITH_RUBY=""
.else
PLIST_SUB+= WITH_RUBY="@comment "
.endif
post-install:
-. if defined(WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
-${RM} -f ${PREFIX}/lib/perl5/${PERL_VERSION}/mach/perllocal.pod
-. endif
+.endif
.include <bsd.port.mk>
diff --git a/textproc/redland-bindings/distinfo b/textproc/redland-bindings/distinfo
index 52a4858ce7c2..78860ce7e290 100644
--- a/textproc/redland-bindings/distinfo
+++ b/textproc/redland-bindings/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redland-bindings-1.0.14.1.tar.gz) = a8cc365fccf292c56d53341ecae57fe8727e5002e048ca25f6251b5e595aec40
-SIZE (redland-bindings-1.0.14.1.tar.gz) = 792557
+SHA256 (redland-bindings-1.0.16.1.tar.gz) = 065037ef61e9b78f642e75b9c2a42700eb1a87d903f2f9963d86591c7d916826
+SIZE (redland-bindings-1.0.16.1.tar.gz) = 859166
diff --git a/textproc/soprano/Makefile b/textproc/soprano/Makefile
index fd4d18415992..ceb9b9158e8f 100644
--- a/textproc/soprano/Makefile
+++ b/textproc/soprano/Makefile
@@ -1,39 +1,35 @@
-# New ports collection Makefile for: soprano
-# Date created: 2008-01-18
-# Whom: arved
-#
+# Created by: arved
# $FreeBSD$
PORTNAME= soprano
-PORTVERSION= 2.7.6
+PORTVERSION= 2.9.0
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/Soprano/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt4 RDF framework
+COMMENT= Qt/C++ RDF framework
-LIB_DEPENDS= raptor2.0:${PORTSDIR}/textproc/raptor2 \
- rdf.0:${PORTSDIR}/textproc/redland \
- iodbc.3:${PORTSDIR}/databases/libiodbc
+LIB_DEPENDS= raptor2:${PORTSDIR}/textproc/raptor2 \
+ rdf:${PORTSDIR}/textproc/redland \
+ iodbc:${PORTSDIR}/databases/libiodbc
-USE_BZIP2= yes
USE_QT4= corelib dbus qtestlib network \
qmake_build moc_build uic_build rcc_build
-USE_GNOME= pkgconfig
-USE_LDCONFIG= yes
+USE_PKGCONFIG= both
+USE_BZIP2= yes
USE_CMAKE= yes
CMAKE_ARGS+= -DSOPRANO_DISABLE_CLUCENE_INDEX=yes \
-DSOPRANO_DISABLE_SESAME2_BACKEND=yes
-
-.include <bsd.port.pre.mk>
+MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
post-patch:
- ${REINPLACE_CMD} -e "s,$${LIB_SUFFIX}/pkgconfig,data/pkgconfig," \
+ @${REINPLACE_CMD} -e 's,$${LIB_SUFFIX}/pkgconfig,data/pkgconfig,' \
${WRKSRC}/CMakeLists.txt
- ${REINPLACE_CMD} -e "s,soprano/cmake,cmake/Modules," \
+ @${REINPLACE_CMD} -e 's,soprano/cmake,cmake/Modules,' \
${WRKSRC}/cmake/modules/CMakeLists.txt
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/soprano/distinfo b/textproc/soprano/distinfo
index 76fe9060c48a..6d44c5dde72d 100644
--- a/textproc/soprano/distinfo
+++ b/textproc/soprano/distinfo
@@ -1,2 +1,2 @@
-SHA256 (soprano-2.7.6.tar.bz2) = 28dd05edc21eebaa6f5f2bda773455ecc010ce68026a789549747a8e58cfd732
-SIZE (soprano-2.7.6.tar.bz2) = 1954245
+SHA256 (soprano-2.9.0.tar.bz2) = b39323386ede0ed4e8e278540fb9e2725b9f486bbc3975dcaa0eb68d7368e4eb
+SIZE (soprano-2.9.0.tar.bz2) = 1956448
diff --git a/textproc/soprano/pkg-descr b/textproc/soprano/pkg-descr
index 17129f2af0c6..ac0500a98b2f 100644
--- a/textproc/soprano/pkg-descr
+++ b/textproc/soprano/pkg-descr
@@ -1,7 +1,8 @@
-Soprano (formerly known as QRDF) is a library which provides a highly usable
-object-oriented C++/QT4 framework for RDF data. It uses different RDF storage
-solutions as backends through a simple plugin system. Soprano is targetted at
-desktop applications that need a RDF data storage solution. It has been
-optimized for easy usage and simplicity.
+Soprano (formerly known as QRDF) is a library which provides a highly
+usable object-oriented C++/Qt framework for RDF data. It uses
+different RDF storage solutions as backends through a simple plugin
+system. Soprano is targeted at desktop applications that need a RDF
+data storage solution. It has been optimized for easy usage and
+simplicity.
-WWW: http://soprano.sourceforge.net/
+WWW: http://soprano.sourceforge.net
diff --git a/textproc/soprano/pkg-message b/textproc/soprano/pkg-message
index f7e584379ec2..ec7d01b6bf99 100644
--- a/textproc/soprano/pkg-message
+++ b/textproc/soprano/pkg-message
@@ -1,4 +1,6 @@
-============================================================
-You'll have to install databases/virtuoso to use soprano's
-virtuoso backend.
-============================================================
+======================================================================
+
+You'll have to install databases/virtuoso to use Soprano's Virtuoso
+backend.
+
+======================================================================
diff --git a/textproc/soprano/pkg-plist b/textproc/soprano/pkg-plist
index 2894f2dafda4..4c3d1bfac0f9 100644
--- a/textproc/soprano/pkg-plist
+++ b/textproc/soprano/pkg-plist
@@ -77,6 +77,7 @@ include/soprano/asyncquery.h
include/soprano/asyncresult.h
include/soprano/backend.h
include/soprano/bindingset.h
+include/soprano/datastream.h
include/soprano/dbusclient.h
include/soprano/dbusexportiterator.h
include/soprano/dbusexportmodel.h