aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-12-08 10:03:42 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-12-08 10:03:42 +0000
commit4375b96f29109a30b96a73146ad0d5206a01513b (patch)
treee0cc41b0b763d2785f9a9fd0504a232dbd88e473 /textproc
parentb217fc5e4efbc773e3db9dc6bd2f513db6d2be1d (diff)
downloadports-4375b96f29109a30b96a73146ad0d5206a01513b.tar.gz
ports-4375b96f29109a30b96a73146ad0d5206a01513b.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/foiltex/Makefile4
-rw-r--r--textproc/foiltex/pkg-deinstall13
2 files changed, 15 insertions, 2 deletions
diff --git a/textproc/foiltex/Makefile b/textproc/foiltex/Makefile
index fcd103d30e89..2ea294f76df4 100644
--- a/textproc/foiltex/Makefile
+++ b/textproc/foiltex/Makefile
@@ -57,7 +57,7 @@ do-install:
@${INSTALL_DATA} ${FOIL_FILES} ${FOIL_DIR}
post-install:
- ${SETENV} LOCALBASE=${LOCALBASE} ${SH} ${PKGDIR}/pkg-install \
- ${PKGNAME} POST-INSTALL
+ ${SETENV} LOCALBASE=${LOCALBASE} PKG_PREFIX=${PREFIX} \
+ ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>
diff --git a/textproc/foiltex/pkg-deinstall b/textproc/foiltex/pkg-deinstall
new file mode 100644
index 000000000000..f49ad2595ff4
--- /dev/null
+++ b/textproc/foiltex/pkg-deinstall
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+if [ "$2" = "POST-DEINSTALL" ]; then
+ echo "Updating content cache to let LaTeX know about the new style files:"
+ if [ -x ${PKG_PREFIX}/bin/mktexlsr ]; then
+ ${PKG_PREFIX}/bin/mktexlsr
+ elif [ -x /usr/local/bin/mktexlsr ]; then
+ /usr/local/bin/mktexlsr
+ else
+ echo "Could not find mktexlsr. Please run it manually to update"
+ echo "LaTeX's content cache."
+ fi
+fi