aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-07-23 12:16:55 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-07-23 12:16:55 +0000
commit3f90fed2bb4fca3a7c50485f5ce43e97ab1cbfe9 (patch)
tree6286f4c7ce058fd8d44a6603d22448a47a6b3377 /textproc
parentd28a06eb409c78cce46639694fa550e9af30a5dc (diff)
downloadports-3f90fed2bb4fca3a7c50485f5ce43e97ab1cbfe9.tar.gz
ports-3f90fed2bb4fca3a7c50485f5ce43e97ab1cbfe9.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/uim-qt/Makefile6
-rw-r--r--textproc/uim/Makefile2
2 files changed, 5 insertions, 3 deletions
diff --git a/textproc/uim-qt/Makefile b/textproc/uim-qt/Makefile
index 6e3ead0ac76b..3ff0fc4ae9e0 100644
--- a/textproc/uim-qt/Makefile
+++ b/textproc/uim-qt/Makefile
@@ -16,8 +16,10 @@ MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
CONFIGURE_ARGS= --with-qt
CONFIGURE_ENV= QTDIR=${X11BASE}/lib QTINCDIR=${X11BASE}/include \
- CXXFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS} -I${X11BASE}/include" LIBS="${LIBS} ${PTHREAD_LIBS} -L${X11BASE}/lib"
-
+ CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
+ CXXFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
+ LIBS="${LIBS} ${PTHREAD_LIBS} -L${X11BASE}/lib -L${LOCALBASE}/lib" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${X11BASE}/lib -L${LOCALBASE}/lib"
UIM_SLAVE= yes
# This is normally handled by defining USE_QT_VER ...
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index eccbb76e74d8..bec1cdccb2f8 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS+= --with-gtk2
CONFIGURE_ARGS+= --enable-emacs
.endif
-CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
+CONFIGURE_ENV?= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
.if !defined(UIM_SLAVE)