aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 09:00:42 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 09:00:42 +0000
commit7fb9058d3779f78665d4d70d502c79ff2981fa9c (patch)
tree78c99d5e3c9b7c4f5753b7e607116636971828ef /textproc
parent7c18e5b1365c2367fd183b3d7c997eb627f79bf2 (diff)
downloadports-7fb9058d3779f78665d4d70d502c79ff2981fa9c.tar.gz
ports-7fb9058d3779f78665d4d70d502c79ff2981fa9c.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/groff/Makefile3
-rw-r--r--textproc/openjade/Makefile10
-rw-r--r--textproc/opensp/Makefile4
-rw-r--r--textproc/p5-HTML-HTML5-Parser/Makefile3
-rw-r--r--textproc/p5-Hailo/Makefile3
-rw-r--r--textproc/p5-Text-TestBase/Makefile3
-rw-r--r--textproc/p5-XML-Feed-Deduper/Makefile4
-rw-r--r--textproc/rasqal/Makefile7
-rw-r--r--textproc/redland-bindings/Makefile2
-rw-r--r--textproc/redland/Makefile7
-rw-r--r--textproc/refdb/Makefile4
-rw-r--r--textproc/sgmlformat/Makefile9
12 files changed, 23 insertions, 36 deletions
diff --git a/textproc/groff/Makefile b/textproc/groff/Makefile
index a99b53f84126..55b9fa9d7073 100644
--- a/textproc/groff/Makefile
+++ b/textproc/groff/Makefile
@@ -17,8 +17,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/gs:${PORTSDIR}/print/ghostscript8 \
${LOCALBASE}/bin/psselect:${PORTSDIR}/print/psutils
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5= yes
-USE_GMAKE= yes
+USES= gmake perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-awk=/usr/bin/awk
diff --git a/textproc/openjade/Makefile b/textproc/openjade/Makefile
index f9ddf0aec66b..6bcef1977cd6 100644
--- a/textproc/openjade/Makefile
+++ b/textproc/openjade/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: OpenJade
-# Date created: May 19, 2000
-# Whom: kuriyama
-#
+# Created by: kuriyama
# $FreeBSD$
-#
PORTNAME= openjade
PORTVERSION= 1.3.3p1
@@ -19,10 +15,8 @@ LIB_DEPENDS= osp.5:${PORTSDIR}/textproc/opensp
RUN_DEPENDS= ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
USE_GCC= any
-USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PERL5= yes
-USES= gettext
+USES= gettext gmake perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
--datadir=${DATADIR}
diff --git a/textproc/opensp/Makefile b/textproc/opensp/Makefile
index 6ac5bac274d3..5b468c82b24d 100644
--- a/textproc/opensp/Makefile
+++ b/textproc/opensp/Makefile
@@ -10,11 +10,9 @@ MASTER_SITES= SF/openjade/${PORTNAME:L}/${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= This package is a collection of SGML/XML tools called OpenSP
-USE_GMAKE= yes
USE_LDCONFIG= yes
-USES= iconv
+USES= gmake iconv perl5
GNU_CONFIGURE= yes
-USE_PERL5= yes
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
--datadir=${PREFIX}/share/sgml/openjade \
--disable-doc-build
diff --git a/textproc/p5-HTML-HTML5-Parser/Makefile b/textproc/p5-HTML-HTML5-Parser/Makefile
index 446dce1d964b..363f9b25bfbf 100644
--- a/textproc/p5-HTML-HTML5-Parser/Makefile
+++ b/textproc/p5-HTML-HTML5-Parser/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-HTML-HTML5-Entities>=0.002:${PORTSDIR}/textproc/p5-HTML-HTML5-
p5-XML-LibXML>=1.94:${PORTSDIR}/textproc/p5-XML-LibXML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::HTML5::Parser.3 \
HTML::HTML5::Parser::Error.3 \
diff --git a/textproc/p5-Hailo/Makefile b/textproc/p5-Hailo/Makefile
index 507023171072..001a80d07155 100644
--- a/textproc/p5-Hailo/Makefile
+++ b/textproc/p5-Hailo/Makefile
@@ -43,7 +43,8 @@ TEST_DEPENDS= p5-DBD-SQLite>=1.29:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-Test-Script-Run>=0.04:${PORTSDIR}/devel/p5-Test-Script-Run \
p5-Test-Synopsis>=0.06:${PORTSDIR}/devel/p5-Test-Synopsis
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= hailo.1
diff --git a/textproc/p5-Text-TestBase/Makefile b/textproc/p5-Text-TestBase/Makefile
index 45f25fc6883c..1474ce606d4c 100644
--- a/textproc/p5-Text-TestBase/Makefile
+++ b/textproc/p5-Text-TestBase/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Class-Accessor-Lite>=0.05:${PORTSDIR}/devel/p5-Class-Accessor-
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Data::Section::TestBase.3 \
Test::Base::Less.3 \
diff --git a/textproc/p5-XML-Feed-Deduper/Makefile b/textproc/p5-XML-Feed-Deduper/Makefile
index 3807ced85c1e..2121a7454226 100644
--- a/textproc/p5-XML-Feed-Deduper/Makefile
+++ b/textproc/p5-XML-Feed-Deduper/Makefile
@@ -1,6 +1,5 @@
# Created by: TERAMOTO Masahiro <markun@onohara.to>
# $FreeBSD$
-#
PORTNAME= XML-Feed-Deduper
PORTVERSION= 0.06
@@ -19,7 +18,8 @@ BUILD_DEPENDS= p5-Mouse>=1.08:${PORTSDIR}/devel/p5-Any-Moose \
RUN_DEPENDS= p5-Mouse>=1.08:${PORTSDIR}/devel/p5-Any-Moose \
p5-XML-Feed>=0.41:${PORTSDIR}/textproc/p5-XML-Feed
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= XML::Feed::Deduper.3
diff --git a/textproc/rasqal/Makefile b/textproc/rasqal/Makefile
index 27d5867b2814..5642386de44e 100644
--- a/textproc/rasqal/Makefile
+++ b/textproc/rasqal/Makefile
@@ -13,12 +13,11 @@ COMMENT= High-level interface for RDF
LIB_DEPENDS= raptor2:${PORTSDIR}/textproc/raptor2 \
pcre:${PORTSDIR}/devel/pcre
-USE_GNOME= gnomehack lthack
+USE_GNOME= lthack
USE_OPENSSL= yes
-USE_PERL5_BUILD=yes
-USES= pkgconfig
+USE_PERL5= build
+USES= gmake pathfix pkgconfig perl5
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
MAN1= rasqal-config.1 roqet.1
diff --git a/textproc/redland-bindings/Makefile b/textproc/redland-bindings/Makefile
index c080649d07fd..fb5f623e5d74 100644
--- a/textproc/redland-bindings/Makefile
+++ b/textproc/redland-bindings/Makefile
@@ -19,7 +19,7 @@ OPTIONS_DEFAULT=PYTHON
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES= perl5
CONFIGURE_ARGS+=--with-perl
PLIST_SUB+= WITH_PERL=""
MANPREFIX= ${LOCALBASE}/lib/perl5/${PERL_VER}
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index a67ed3b89304..2773065b80b9 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -13,14 +13,13 @@ LIB_DEPENDS= raptor2:${PORTSDIR}/textproc/raptor2 \
rasqal:${PORTSDIR}/textproc/rasqal
USE_AUTOTOOLS= libltdl
-USE_GNOME= gnomehack libxml2 lthack
+USE_GNOME= libxml2 lthack
USE_OPENSSL= yes
-USE_PERL5_BUILD= yes
-USES= pkgconfig:both
+USE_PERL5= build
+USES= gmake pathfix perl5 pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-raptor=system \
--with-threestore=no
-USE_GMAKE= yes
USE_LDCONFIG= yes
MAN1= rdfproc.1 redland-config.1 \
diff --git a/textproc/refdb/Makefile b/textproc/refdb/Makefile
index c9d57d311276..22393974ca77 100644
--- a/textproc/refdb/Makefile
+++ b/textproc/refdb/Makefile
@@ -15,9 +15,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
btparse.0:${PORTSDIR}/textproc/btparse \
dbi.1:${PORTSDIR}/databases/libdbi
-USE_GMAKE= yes
-USES= iconv
-USE_PERL5= yes
+USES= gmake iconv perl5
HAS_CONFIGURE= yes
ALL_TARGET=
diff --git a/textproc/sgmlformat/Makefile b/textproc/sgmlformat/Makefile
index f422d2911270..492184c04747 100644
--- a/textproc/sgmlformat/Makefile
+++ b/textproc/sgmlformat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sgmlformat
-# Date created: July 16, 1997
-# Whom: jfieber
-#
+# Created by: jfieber
# $FreeBSD$
-#
PORTNAME= sgmlformat
PORTVERSION= 1.7
@@ -15,7 +11,8 @@ MASTER_SITE_SUBDIR= kuriyama
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Generates groff and HTML from linuxdoc and docbook SGML documents
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
MAN1= instant.1 sgmlfmt.1
MAN5= transpec.5