aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-10 13:36:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-10 13:36:29 +0000
commit180ef443a6e6d8796220bac521339d2285efa84f (patch)
tree0fd8d1dae525f1411893f84f72b54df104d9776e /textproc
parent2c1356276fe9df4d1c18fbb421a071b6f88eef34 (diff)
downloadports-180ef443a6e6d8796220bac521339d2285efa84f.tar.gz
ports-180ef443a6e6d8796220bac521339d2285efa84f.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ruby-htmltools/Makefile36
-rw-r--r--textproc/ruby-htmltools/distinfo2
-rw-r--r--textproc/ruby-htmltools/files/patch-install.rb45
-rw-r--r--textproc/ruby-htmltools/pkg-descr6
-rw-r--r--textproc/ruby-htmltools/pkg-plist9
6 files changed, 99 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 187ff6537b69..e481d2074236 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -577,6 +577,7 @@
SUBDIR += ruby-htmlcompact
SUBDIR += ruby-htmlrepair
SUBDIR += ruby-htmlsplit
+ SUBDIR += ruby-htmltools
SUBDIR += ruby-htree
SUBDIR += ruby-libxml
SUBDIR += ruby-libxslt
diff --git a/textproc/ruby-htmltools/Makefile b/textproc/ruby-htmltools/Makefile
new file mode 100644
index 000000000000..cf23104d1733
--- /dev/null
+++ b/textproc/ruby-htmltools/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ruby-htmltools
+# Date created: 2005-03-31
+# Whom: Alexander Novitsky <alecn2002@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmltools
+PORTVERSION= 1.09
+CATEGORIES= textproc ruby
+MASTER_SITES= http://rubyforge.org/frs/download.php/1340/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= alecn2002@yandex.ru
+COMMENT= Tools for parsing and manipulating HTML text in Ruby
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+CONFIGURE_ARGS= --prefix=${PREFIX}
+RUBY_INSTALL_ARGS= --prefix=${PREFIX}
+NOHARM_ARGS= --no-harm
+
+install-noharm:
+ @${ECHO_MSG} "===> Running ${RUBY_SETUP} to NOHARM-install (Just output, do nothing)"
+ cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${RUBY} ${RUBY_FLAGS} ${RUBY_SETUP} install ${NOHARM_ARGS} ${RUBY_INSTALL_ARGS}
+
+do-install:
+ @${ECHO_MSG} "===> Running ${RUBY_SETUP} to install"
+ @cd ${INSTALL_WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${RUBY} ${RUBY_FLAGS} ${RUBY_SETUP} install ${RUBY_INSTALL_ARGS}
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-htmltools/distinfo b/textproc/ruby-htmltools/distinfo
new file mode 100644
index 000000000000..a6bdc1b6e781
--- /dev/null
+++ b/textproc/ruby-htmltools/distinfo
@@ -0,0 +1,2 @@
+MD5 (ruby/ruby-htmltools.tar.gz) = 62b55355964699f44e40d77e14e3eb70
+SIZE (ruby/ruby-htmltools.tar.gz) = 26930
diff --git a/textproc/ruby-htmltools/files/patch-install.rb b/textproc/ruby-htmltools/files/patch-install.rb
new file mode 100644
index 000000000000..7b8c3df0a33a
--- /dev/null
+++ b/textproc/ruby-htmltools/files/patch-install.rb
@@ -0,0 +1,45 @@
+--- install.rb.orig Sun Apr 10 15:32:16 2005
++++ install.rb Sun Apr 10 15:32:26 2005
+@@ -10,6 +10,8 @@
+ # the GNU Lesser General Public License version 2.
+ #
+
++
++
+ ### begin compat.rb
+
+ unless Enumerable.instance_methods(true).include? 'inject' then
+@@ -32,6 +34,13 @@
+ end
+
+ ### end compat.rb
++
++class String
++ def begin_with?( substr )
++ index( substr ) == 0
++ end
++end
++
+ ### begin config.rb
+
+ if i = ARGV.index(/\A--rbconfig=/) then
+@@ -308,7 +317,7 @@
+ module FileOperations
+
+ def mkdir_p( dname, prefix = nil )
+- dname = prefix + dname if prefix
++ dname = File.join( prefix, dname ) if ( prefix and not dname.begin_with?( prefix ) )
+ $stderr.puts "mkdir -p #{dname}" if verbose?
+ return if no_harm?
+
+@@ -371,7 +380,9 @@
+ $stderr.puts "install #{from} #{dest}" if verbose?
+ return if no_harm?
+
+- realdest = prefix + dest if prefix
++ realdest = ( prefix and not dest.begin_with?( prefix ) ) ?
++ prefix + dest :
++ dest
+ if dir? realdest then
+ realdest += '/' + File.basename(from)
+ end
diff --git a/textproc/ruby-htmltools/pkg-descr b/textproc/ruby-htmltools/pkg-descr
new file mode 100644
index 000000000000..b74ccf770585
--- /dev/null
+++ b/textproc/ruby-htmltools/pkg-descr
@@ -0,0 +1,6 @@
+Ruby-htmltools tools for parsing and manipulating HTML text in Ruby.
+It can be used for programmatically access outside HTML-pages.
+I hope to extend it to become a web-publishing framework in the future.
+
+Author: Johannes Brodwall <johannes@brodwall.com>
+WWW: http://rubyforge.org/projects/ruby-htmltools/
diff --git a/textproc/ruby-htmltools/pkg-plist b/textproc/ruby-htmltools/pkg-plist
new file mode 100644
index 000000000000..f82a12580396
--- /dev/null
+++ b/textproc/ruby-htmltools/pkg-plist
@@ -0,0 +1,9 @@
+%%RUBY_SITELIBDIR%%/html/element.rb
+%%RUBY_SITELIBDIR%%/html/rexml-nodepath.rb
+%%RUBY_SITELIBDIR%%/html/sgml-parser.rb
+%%RUBY_SITELIBDIR%%/html/stparser.rb
+%%RUBY_SITELIBDIR%%/html/tags.rb
+%%RUBY_SITELIBDIR%%/html/tree.rb
+%%RUBY_SITELIBDIR%%/html/xmltree.rb
+%%RUBY_SITELIBDIR%%/html/xpath.rb
+@dirrm %%RUBY_SITELIBDIR%%/html