aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2004-04-29 01:43:25 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2004-04-29 01:43:25 +0000
commit4d150424a07ee58813e375bb48e471f3f208ba8c (patch)
tree2d847579dc4851ed27b55258caa55765d56e8591 /textproc
parent557e51f968c30484b7c93e49d66a776d9b8baf3a (diff)
downloadports-4d150424a07ee58813e375bb48e471f3f208ba8c.tar.gz
ports-4d150424a07ee58813e375bb48e471f3f208ba8c.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/glimpse/Makefile3
-rw-r--r--textproc/glimpse/distinfo4
-rw-r--r--textproc/glimpse/files/patch-aj11
3 files changed, 14 insertions, 4 deletions
diff --git a/textproc/glimpse/Makefile b/textproc/glimpse/Makefile
index 43ba5c053410..d544da461163 100644
--- a/textproc/glimpse/Makefile
+++ b/textproc/glimpse/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= glimpse
-PORTVERSION= 4.12.6
+PORTVERSION= 4.13.1
CATEGORIES= textproc databases
MASTER_SITES= ftp://ftp.polito.it/pub/tools/unix/harvest/
@@ -20,7 +20,6 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -DISO_CHAR_SET=1 -D__STRICT_ANSI__"
MAN1= glimpse.1 glimpseindex.1 glimpseserver.1 agrep.1
pre-configure:
- ${RM} ${WRKSRC}/config.cache
${CHMOD} ugo+x ${WRKSRC}/configure
post-install:
diff --git a/textproc/glimpse/distinfo b/textproc/glimpse/distinfo
index 6f7118cb80af..73fb7eeb1811 100644
--- a/textproc/glimpse/distinfo
+++ b/textproc/glimpse/distinfo
@@ -1,2 +1,2 @@
-MD5 (glimpse-4.12.6.tar.gz) = 1741abb8c6cb7ab376a5b2aa1d4f9a6b
-SIZE (glimpse-4.12.6.tar.gz) = 426506
+MD5 (glimpse-4.13.1.tar.gz) = a4e5d5f8017a9bde5edf233cb80caae5
+SIZE (glimpse-4.13.1.tar.gz) = 394426
diff --git a/textproc/glimpse/files/patch-aj b/textproc/glimpse/files/patch-aj
new file mode 100644
index 000000000000..a53f66a6c0b5
--- /dev/null
+++ b/textproc/glimpse/files/patch-aj
@@ -0,0 +1,11 @@
+--- agrep/sgrep.c.orig Mon Apr 26 23:15:06 2004
++++ agrep/sgrep.c Mon Apr 26 23:15:33 2004
+@@ -1539,7 +1539,7 @@
+ hash = TR[*text];
+ hash = (hash << 3) + TR[*(text-1)];
+ shift = SHIFT_2[hash];
+- while(shift) {
++ while(shift && text <= textend) {
+ text = text + shift;
+ hash = (TR[*text] << 3) + TR[*(text-1)];
+ shift = SHIFT_2[hash];