aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-10-15 09:56:31 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-10-15 09:56:31 +0000
commitbdc0dbf6bdd6a8f494476213aeb3547a13fc4263 (patch)
tree4d272bd1a1c85b38e6779b4f6584533d62cc635a /textproc
parent432f65d8680aa84efb0706ec36fbcc094a40d260 (diff)
downloadports-bdc0dbf6bdd6a8f494476213aeb3547a13fc4263.tar.gz
ports-bdc0dbf6bdd6a8f494476213aeb3547a13fc4263.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/cost/Makefile54
-rw-r--r--textproc/cost/distinfo4
-rw-r--r--textproc/cost/pkg-plist40
3 files changed, 44 insertions, 54 deletions
diff --git a/textproc/cost/Makefile b/textproc/cost/Makefile
index 9551817de7c7..ac5794f69c47 100644
--- a/textproc/cost/Makefile
+++ b/textproc/cost/Makefile
@@ -2,46 +2,38 @@
# $FreeBSD$
PORTNAME= cost
-PORTVERSION= 2.2p1
-PORTREVISION= 2
+DISTVERSION= 2.3-2004-10-08
CATEGORIES= textproc tcl
-MASTER_SITES= http://www.flightlab.com/~joe/cost/
+MASTER_SITES= http://www.flightlab.com/~joe/downloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= SGML/XML application programming tool
-USE_TCL= 84
-USE_TCL_BUILD= 84
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
+OPTIONS_DEFINE= DOCS
+
+USES+= tk
GNU_CONFIGURE= YES
-CONFIGURE_ARGS+=--with-tcl=${LOCALBASE}/lib/tcl8.4 \
- --with-docdir=${PREFIX}/share/doc/cost --with-charmaps
-CONFIGURE_ENV+= TCL_INCLUDE_SPEC="${LOCALBASE}/include/tcl8.4"
+CONFIGURE_ARGS+=-prefix=${PREFIX} \
+ --exec-prefix=${PREFIX} \
+ --with-tcl=${TCL_LIBDIR} \
+ --with-tcl-include=${TCL_INCLUDEDIR} \
+ --with-docdir=${DOCSDIR}
CFLAGS+= -fPIC
-NO_STAGE= yes
+PORTDOCS= *
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.3/src
+
+.include <bsd.port.options.mk>
+
post-patch:
- @${REINPLACE_CMD} -e 's|TCL_SRC_DIR%g|TCL_INCLUDE_SPEC%g|' \
- ${WRKSRC}/configure
-
-post-configure:
- @${REINPLACE_CMD} -e 's|-I$$(TCL_SRC_DIR)/generic|$$(TCL_SRC_DIR)|' \
- ${WRKSRC}/Makefile
-
-do-install:
- ${MKDIR} ${PREFIX}/lib/cost2.2
- ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/lib/*.tcl ${PREFIX}/lib/cost2.2
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/lib/*.spec ${PREFIX}/lib/cost2.2
- ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/lib/*.itcl ${PREFIX}/lib/cost2.2
- ${INSTALL_DATA} ${WRKSRC}/libcost2.2.so ${PREFIX}/lib/cost2.2
- ${INSTALL_PROGRAM} ${WRKSRC}/costsh ${PREFIX}/bin/costsh
-
-.if !defined(NOPORTDOCS)
- @${ECHO} "===> Installing Cost documentation"
- @${MKDIR} ${DOCSDIR} && ${CHMOD} a+rx ${DOCSDIR}
- @cd ${WRKDIR}/${DISTNAME}/doc && \
- ${INSTALL_MAN} manual.html manual.ps rtflib.html simple.html \
- ${DOCSDIR}/
+ ${REINPLACE_CMD} -e 's|$$(TCL_PKGPATH)|${PREFIX}/lib|' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's|wish8.0|${WISH}|' ${WRKSRC}/../demos/sgmlbrowse.tcl
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/../demos/sgmlbrowse.tcl ${STAGEDIR}${PREFIX}/bin/sgmlbrowse
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/../doc && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/textproc/cost/distinfo b/textproc/cost/distinfo
index aa4de73e9f1c..5c55ed40b2cd 100644
--- a/textproc/cost/distinfo
+++ b/textproc/cost/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cost-2.2p1.tar.gz) = d8783817cc392946697ead8c78ac5abda42207d86c93a63930262671aa9a9279
-SIZE (cost-2.2p1.tar.gz) = 213550
+SHA256 (cost-2.3-2004-10-08.tar.gz) = d33f63d7d1a2e55a21d2154fe657ba9503b33d969606f8bd5bf3f0d63ff4532e
+SIZE (cost-2.3-2004-10-08.tar.gz) = 267756
diff --git a/textproc/cost/pkg-plist b/textproc/cost/pkg-plist
index 9c0afeef67ad..182e3d5f24e6 100644
--- a/textproc/cost/pkg-plist
+++ b/textproc/cost/pkg-plist
@@ -1,21 +1,19 @@
-bin/costsh
-lib/cost2.2/libcost2.2.so
-lib/cost2.2/Core.tcl
-lib/cost2.2/Counters.tcl
-lib/cost2.2/Numerals.tcl
-lib/cost2.2/Simple.tcl
-lib/cost2.2/auxfile.tcl
-lib/cost2.2/costinit.tcl
-lib/cost2.2/htmllib.tcl
-lib/cost2.2/pkgIndex.tcl
-lib/cost2.2/rtflib.tcl
-lib/cost2.2/textutil.tcl
-lib/cost2.2/winhelp-stylesheet.tcl
-lib/cost2.2/RTF.spec
-lib/cost2.2/EventHandler.itcl
-%%PORTDOCS%%%%DOCSDIR%%/manual.html
-%%PORTDOCS%%%%DOCSDIR%%/manual.ps
-%%PORTDOCS%%%%DOCSDIR%%/rtflib.html
-%%PORTDOCS%%%%DOCSDIR%%/simple.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm lib/cost2.2
+bin/sgmlbrowse
+lib/cost2.3/Core.tcl
+lib/cost2.3/Counters.tcl
+lib/cost2.3/EventHandler.itcl
+lib/cost2.3/HTML.spec
+lib/cost2.3/Numerals.tcl
+lib/cost2.3/Options.tcl
+lib/cost2.3/RTF.spec
+lib/cost2.3/Simple.tcl
+lib/cost2.3/auxfile.tcl
+lib/cost2.3/cost23.so
+lib/cost2.3/costinit.tcl
+lib/cost2.3/htmllib.tcl
+lib/cost2.3/latex.tcl
+lib/cost2.3/pkgIndex.tcl
+lib/cost2.3/rtflib.tcl
+lib/cost2.3/textutil.tcl
+lib/cost2.3/winhelp-stylesheet.tcl
+@dirrm lib/cost2.3