aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2015-10-11 21:34:11 +0000
committerFlorian Smeets <flo@FreeBSD.org>2015-10-11 21:34:11 +0000
commite1bb2b03af7c352fb3c74621e800fc7ebcd7adf9 (patch)
tree2de1d99c4e61334d066d207afacb4ea63c51ed55 /textproc
parentceb6ffa6fcf52c55d298ac34ef7d721fc083d9d3 (diff)
downloadports-e1bb2b03af7c352fb3c74621e800fc7ebcd7adf9.tar.gz
ports-e1bb2b03af7c352fb3c74621e800fc7ebcd7adf9.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/pecl-wbxml/Makefile7
-rw-r--r--textproc/pecl-wbxml/files/patch-config.m415
-rw-r--r--textproc/pecl-wbxml/files/patch-wbxml.c11
-rw-r--r--textproc/pecl-wbxml/pkg-descr2
-rw-r--r--textproc/wbxml2/Makefile3
-rw-r--r--textproc/wbxml2/distinfo4
-rw-r--r--textproc/wbxml2/files/patch-CMakeLists.txt8
-rw-r--r--textproc/wbxml2/pkg-plist28
8 files changed, 41 insertions, 37 deletions
diff --git a/textproc/pecl-wbxml/Makefile b/textproc/pecl-wbxml/Makefile
index 86b6fabf347a..c6d317037178 100644
--- a/textproc/pecl-wbxml/Makefile
+++ b/textproc/pecl-wbxml/Makefile
@@ -3,10 +3,10 @@
PORTNAME= wbxml
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= textproc pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
-EXTRACT_SUFX= .tgz
DIST_SUBDIR= PECL
MAINTAINER= flo@FreeBSD.org
@@ -14,9 +14,14 @@ COMMENT= PECL extension that provides WBXML conversion capabilities
LIB_DEPENDS= libwbxml2.so:${PORTSDIR}/textproc/wbxml2
+USES=tar:tgz
+
CONFIGURE_ARGS= --with-wbxml=${LOCALBASE} \
--with-libexpat-dir=${LOCALBASE}
USE_PHP= yes
USE_PHPEXT= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/config.m4
+
.include <bsd.port.mk>
diff --git a/textproc/pecl-wbxml/files/patch-config.m4 b/textproc/pecl-wbxml/files/patch-config.m4
index fe970179e169..a3490e365f67 100644
--- a/textproc/pecl-wbxml/files/patch-config.m4
+++ b/textproc/pecl-wbxml/files/patch-config.m4
@@ -1,6 +1,15 @@
---- config.m4.orig 2009-03-11 17:57:16.000000000 +0100
-+++ config.m4 2009-03-11 17:57:27.000000000 +0100
-@@ -74,21 +74,6 @@
+--- config.m4.orig 2009-02-22 11:30:57 UTC
++++ config.m4
+@@ -43,7 +43,7 @@ if test "$PHP_WBXML" != "no"; then
+ ],-L$WBXML_LIBDIR)
+
+ PHP_ADD_LIBRARY_WITH_PATH(wbxml2, $WBXML_LIBDIR, WBXML_SHARED_LIBADD)
+- PHP_ADD_INCLUDE($WBXML_DIR/include)
++ PHP_ADD_INCLUDE(/usr/local/include/libwbxml-1.0)
+
+ for i in $PHP_LIBEXPAT_DIR /usr/local /usr; do
+ for j in $PHP_LIBDIR lib64 lib; do
+@@ -74,21 +74,6 @@ if test "$PHP_WBXML" != "no"; then
CFLAGS="$CFLAGS -Wall"
fi
diff --git a/textproc/pecl-wbxml/files/patch-wbxml.c b/textproc/pecl-wbxml/files/patch-wbxml.c
index 11917b12954d..a9e6b91942eb 100644
--- a/textproc/pecl-wbxml/files/patch-wbxml.c
+++ b/textproc/pecl-wbxml/files/patch-wbxml.c
@@ -1,6 +1,6 @@
---- wbxml.c.orig 2009-03-11 18:12:19.000000000 +0100
-+++ wbxml.c 2009-03-11 18:12:27.000000000 +0100
-@@ -27,6 +27,10 @@
+--- wbxml.c.orig 2009-01-29 19:13:57 UTC
++++ wbxml.c
+@@ -27,8 +27,12 @@
#include "ext/standard/info.h"
#include "php_wbxml.h"
@@ -9,5 +9,8 @@
+#endif
+
#undef HAVE_LIBXML
- #include "wbxml.h"
+-#include "wbxml.h"
++#include "wbxml/wbxml.h"
+ /* {{{ wbxml_functions[]
+ */
diff --git a/textproc/pecl-wbxml/pkg-descr b/textproc/pecl-wbxml/pkg-descr
index 6574d9a1bcfe..e3b62dfd80b3 100644
--- a/textproc/pecl-wbxml/pkg-descr
+++ b/textproc/pecl-wbxml/pkg-descr
@@ -1,4 +1,4 @@
This extension provides WBXML (Wireless Binary XML) conversion capabilities
using the libwbxml library, which can be found at https://libwbxml.opensync.org/
-WWW: http://pecl.php.net/package/WBXML/
+WWW: http://pecl.php.net/package/WBXML/
diff --git a/textproc/wbxml2/Makefile b/textproc/wbxml2/Makefile
index 0f280bad6eb3..db5da73f16d0 100644
--- a/textproc/wbxml2/Makefile
+++ b/textproc/wbxml2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= wbxml2
-PORTVERSION= 0.10.9
-PORTREVISION= 1
+PORTVERSION= 0.11.2
CATEGORIES= textproc devel
MASTER_SITES= SF/libwbxml/libwbxml/${PORTVERSION}
DISTNAME= libwbxml-${PORTVERSION}
diff --git a/textproc/wbxml2/distinfo b/textproc/wbxml2/distinfo
index d80f884effeb..1769cc9fb5ca 100644
--- a/textproc/wbxml2/distinfo
+++ b/textproc/wbxml2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libwbxml-0.10.9.tar.bz2) = 8ca60c9360536680d538cafbb5947ae2bae6fea5ff704f1bbdf166183b698d59
-SIZE (libwbxml-0.10.9.tar.bz2) = 350697
+SHA256 (libwbxml-0.11.2.tar.bz2) = 5f642027ece0225d80ef21979a57cf59b1027d46cb8dbd5ff4b87662eec2557d
+SIZE (libwbxml-0.11.2.tar.bz2) = 354176
diff --git a/textproc/wbxml2/files/patch-CMakeLists.txt b/textproc/wbxml2/files/patch-CMakeLists.txt
index 9a73f40b8c2f..0fc2d7efd3bf 100644
--- a/textproc/wbxml2/files/patch-CMakeLists.txt
+++ b/textproc/wbxml2/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2009-05-12 20:43:10.000000000 +0900
-+++ CMakeLists.txt 2009-08-12 05:53:35.000000000 +0900
-@@ -36,7 +36,7 @@
+--- CMakeLists.txt.orig 2012-07-20 12:29:52 UTC
++++ CMakeLists.txt
+@@ -44,7 +44,7 @@ SET( CMAKE_MODULE_PATH "${CMAKE_SOURCE_D
SET( LIB_SUFFIX "" CACHE STRING "The library directory suffix. 32bit empty string, 64 for 64bit." )
SET( LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}" CACHE INTERNAL "libary location" )
@@ -9,7 +9,7 @@
SET( BIN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/bin" CACHE INTERNAL "binary location" )
SET( SHARE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/share" CACHE INTERNAL "data location" )
SET( INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include" CACHE INTERNAL "headers location" )
-@@ -176,7 +176,7 @@
+@@ -191,7 +191,7 @@ MARK_AS_ADVANCED( CLEAR BUILD_DOCUMENTAT
# ADD_CUSTOM_TARGET( DoxygenDoc )
# ADD_DEPENDENCIES( DoxygenDoc DoxygenDocLibrary DoxygenDocTools )
#ENDIF ( BUILD_DOCUMENTATION )
diff --git a/textproc/wbxml2/pkg-plist b/textproc/wbxml2/pkg-plist
index e07ba98e0443..a4e9bd90f8f1 100644
--- a/textproc/wbxml2/pkg-plist
+++ b/textproc/wbxml2/pkg-plist
@@ -1,27 +1,15 @@
bin/wbxml2xml
bin/xml2wbxml
-include/wbxml.h
-include/wbxml_base64.h
-include/wbxml_buffers.h
-include/wbxml_charset.h
-include/wbxml_config.h
-include/wbxml_conv.h
-include/wbxml_elt.h
-include/wbxml_encoder.h
-include/wbxml_errors.h
-include/wbxml_handlers.h
-include/wbxml_lists.h
-include/wbxml_log.h
-include/wbxml_mem.h
-include/wbxml_parser.h
-include/wbxml_tables.h
-include/wbxml_tree.h
-include/wbxml_tree_clb_wbxml.h
-include/wbxml_tree_clb_xml.h
+include/libwbxml-1.0/wbxml/wbxml.h
+include/libwbxml-1.0/wbxml/wbxml_config.h
+include/libwbxml-1.0/wbxml/wbxml_conv.h
+include/libwbxml-1.0/wbxml/wbxml_defines.h
+include/libwbxml-1.0/wbxml/wbxml_errors.h
lib/libwbxml2.so
-lib/libwbxml2.so.0
-lib/libwbxml2.so.0.0.18
+lib/libwbxml2.so.1
+lib/libwbxml2.so.1.0.4
libdata/pkgconfig/libwbxml2.pc
+share/cmake/Modules/FindLibWbxml2.cmake
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog