aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-29 10:40:49 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-29 10:40:49 +0000
commitbfe59ce7bceb073f18a583358731fb2f4d6f8305 (patch)
treef79c4566d73141040d670a4816383a5ea4009898 /textproc
parent48048fd2706e8a2d0a96edf4b47ddc95fbcaa964 (diff)
downloadports-bfe59ce7bceb073f18a583358731fb2f4d6f8305.tar.gz
ports-bfe59ce7bceb073f18a583358731fb2f4d6f8305.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-LibXML/Makefile28
-rw-r--r--textproc/p5-XML-LibXML/README9
-rw-r--r--textproc/p5-XML-LibXML/distinfo1
-rw-r--r--textproc/p5-XML-LibXML/pkg-comment1
-rw-r--r--textproc/p5-XML-LibXML/pkg-descr3
-rw-r--r--textproc/p5-XML-LibXML/pkg-plist13
7 files changed, 56 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 30aca8d07778..da4e2357141f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -115,6 +115,7 @@
SUBDIR += p5-XML-DOM
SUBDIR += p5-XML-DT
SUBDIR += p5-XML-Dumper
+ SUBDIR += p5-XML-LibXML
SUBDIR += p5-XML-Node
SUBDIR += p5-XML-Parser
SUBDIR += p5-XML-RSS
diff --git a/textproc/p5-XML-LibXML/Makefile b/textproc/p5-XML-LibXML/Makefile
new file mode 100644
index 000000000000..f2fda6b6b4ed
--- /dev/null
+++ b/textproc/p5-XML-LibXML/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: XML::LibXML
+# Date created: 28 May 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-LibXML
+PORTVERSION= 0.91
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INC='-I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2'
+
+MAN3= XML::LibXML::Element.3 XML::LibXML::CDATASection.3 \
+ XML::LibXML::Comment.3 XML::LibXML::Text.3 XML::LibXML.3 \
+ XML::LibXML::Node.3 XML::LibXML::Document.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-LibXML/README b/textproc/p5-XML-LibXML/README
new file mode 100644
index 000000000000..b13b350c2593
--- /dev/null
+++ b/textproc/p5-XML-LibXML/README
@@ -0,0 +1,9 @@
+This module is a minimal interface to the Gnome libxml2 library which you
+can find at http://www.xmlsoft.org/
+
+Currently this is just a helper module for XML::LibXSLT (and as such is
+included with the XML::LibXSLT distribution), but libxml2 has a full DOM
+API, and so I hope to be able to offer full access to that API one day.
+
+This is free software, you may use it and distribute it under the same
+terms as Perl itself. Copyright 2001 AxKit.com Ltd, All rights reserved.
diff --git a/textproc/p5-XML-LibXML/distinfo b/textproc/p5-XML-LibXML/distinfo
new file mode 100644
index 000000000000..17cc18c6780e
--- /dev/null
+++ b/textproc/p5-XML-LibXML/distinfo
@@ -0,0 +1 @@
+MD5 (XML-LibXML-0.91.tar.gz) = f9f3dc2d8dcac50f5d849597d5fe9c03
diff --git a/textproc/p5-XML-LibXML/pkg-comment b/textproc/p5-XML-LibXML/pkg-comment
new file mode 100644
index 000000000000..4de1326c5950
--- /dev/null
+++ b/textproc/p5-XML-LibXML/pkg-comment
@@ -0,0 +1 @@
+Interface to Gnome libxml2 library
diff --git a/textproc/p5-XML-LibXML/pkg-descr b/textproc/p5-XML-LibXML/pkg-descr
new file mode 100644
index 000000000000..47d42a48232d
--- /dev/null
+++ b/textproc/p5-XML-LibXML/pkg-descr
@@ -0,0 +1,3 @@
+This module is a minimal interface to the Gnome libxml2 library.
+
+WWW: http://www.xmlsoft.org/
diff --git a/textproc/p5-XML-LibXML/pkg-plist b/textproc/p5-XML-LibXML/pkg-plist
new file mode 100644
index 000000000000..982d83fb1774
--- /dev/null
+++ b/textproc/p5-XML-LibXML/pkg-plist
@@ -0,0 +1,13 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibXML/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML/LibXML.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML/LibXML/CDATASection.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML/LibXML/Comment.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML/LibXML/Document.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML/LibXML/Element.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML/LibXML/Node.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML/LibXML/Text.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibXML/LibXML.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibXML/LibXML.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibXML
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true