aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-11-25 09:28:58 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-11-25 09:28:58 +0000
commit3cbe86c237afc5cfb197c8e7e21ed8feffc65272 (patch)
tree405c557f58a021ef8d048e7bb3ab7dd91171dd40 /textproc
parent52fbe2672b09d39e84cdd1598073c1b9cbf7f767 (diff)
downloadports-3cbe86c237afc5cfb197c8e7e21ed8feffc65272.tar.gz
ports-3cbe86c237afc5cfb197c8e7e21ed8feffc65272.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-elasticsearch6/Makefile1
-rw-r--r--textproc/py-elasticsearch6/files/patch-elasticsearch-connection-http_urllib3.py12
2 files changed, 13 insertions, 0 deletions
diff --git a/textproc/py-elasticsearch6/Makefile b/textproc/py-elasticsearch6/Makefile
index 64c6b27f2b2a..1ef44da90626 100644
--- a/textproc/py-elasticsearch6/Makefile
+++ b/textproc/py-elasticsearch6/Makefile
@@ -3,6 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 6.4.0
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/textproc/py-elasticsearch6/files/patch-elasticsearch-connection-http_urllib3.py b/textproc/py-elasticsearch6/files/patch-elasticsearch-connection-http_urllib3.py
new file mode 100644
index 000000000000..a688f1019de2
--- /dev/null
+++ b/textproc/py-elasticsearch6/files/patch-elasticsearch-connection-http_urllib3.py
@@ -0,0 +1,12 @@
+Backport from: https://github.com/elastic/elasticsearch-py/commit/4c531c5cdbd5ba8b59be16c2fa15d5cf81d0a92f
+
+--- elasticsearch/connection/http_urllib3.py.orig 2019-05-28 17:59:13 UTC
++++ elasticsearch/connection/http_urllib3.py
+@@ -170,6 +170,7 @@ class Urllib3HttpConnection(Connection):
+ }
+ )
+ else:
++ kw["cert_reqs"] = "CERT_NONE"
+ warnings.warn(
+ "Connecting to %s using SSL with verify_certs=False is insecure."
+ % host