aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-05-30 16:14:26 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-05-30 16:14:26 +0000
commit53ede7defe5f060e15f9d71cb4f878e17545c363 (patch)
treeea0098140721dc1681b86da12d337cc816dbaa7a /textproc
parentdd4b8336dbda54755422ce6143453db081a9db2d (diff)
downloadports-53ede7defe5f060e15f9d71cb4f878e17545c363.tar.gz
ports-53ede7defe5f060e15f9d71cb4f878e17545c363.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-RDF-Notation3/Makefile25
-rw-r--r--textproc/p5-RDF-Notation3/distinfo2
-rw-r--r--textproc/p5-RDF-Notation3/pkg-descr2
-rw-r--r--textproc/p5-RDF-Notation3/pkg-plist5
4 files changed, 22 insertions, 12 deletions
diff --git a/textproc/p5-RDF-Notation3/Makefile b/textproc/p5-RDF-Notation3/Makefile
index 5ec849967a6e..9bf6151e062c 100644
--- a/textproc/p5-RDF-Notation3/Makefile
+++ b/textproc/p5-RDF-Notation3/Makefile
@@ -6,28 +6,33 @@
#
PORTNAME= RDF-Notation3
-PORTVERSION= 0.40
+PORTVERSION= 0.70
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= RDF
PKGNAMEPREFIX= p5-
-MAINTAINER= skv@protey.ru
+MAINTAINER= skv@FreeBSD.org
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/RDF/Core.pm:${PORTSDIR}/textproc/p5-RDF-Core \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/RDFStore.pm:${PORTSDIR}/textproc/p5-RDFStore
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= RDF::Notation3.3 RDF::Notation3::PrefTriples.3 \
+ RDF::Notation3::RDFCore.3 RDF::Notation3::RDFStore.3 \
RDF::Notation3::ReaderFile.3 RDF::Notation3::ReaderString.3 \
- RDF::Notation3::Template::TReader.3 \
- RDF::Notation3::Template::TTriples.3 RDF::Notation3::Triples.3
-
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+ RDF::Notation3::SAX.3 RDF::Notation3::Template::TReader.3 \
+ RDF::Notation3::Template::TTriples.3 \
+ RDF::Notation3::Template::TXML.3 RDF::Notation3::Triples.3 \
+ RDF::Notation3::XML.3
pre-patch:
- @find ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
- '$$package=$$1 if /^package\s+([^\s;]*);/; s!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+(\$$)(VERSION)\s+=!$$1$${package}::$$2=!;'
+ @${FIND} ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
+ '$$package=$$1 if /^package\s+([^\s;]*);/; s!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+(\$$)(VERSION)\s+=!$$1$${package}::$$2=!;'
.include <bsd.port.mk>
diff --git a/textproc/p5-RDF-Notation3/distinfo b/textproc/p5-RDF-Notation3/distinfo
index ac9b5d07716c..381482913423 100644
--- a/textproc/p5-RDF-Notation3/distinfo
+++ b/textproc/p5-RDF-Notation3/distinfo
@@ -1 +1 @@
-MD5 (RDF-Notation3-0.40.tar.gz) = 144818b57889094abf02c635288543e1
+MD5 (RDF-Notation3-0.70.tar.gz) = ba909ec87d1329baec8a3787b11979ed
diff --git a/textproc/p5-RDF-Notation3/pkg-descr b/textproc/p5-RDF-Notation3/pkg-descr
index ffaaaf4c312b..e0864cbd2bc8 100644
--- a/textproc/p5-RDF-Notation3/pkg-descr
+++ b/textproc/p5-RDF-Notation3/pkg-descr
@@ -5,4 +5,4 @@ desired format available).
WWW: http://search.cpan.org/search?dist=RDF-Notation3
-- Sergey Skvortsov
-skv@protey.ru
+skv@FreeBSD.org
diff --git a/textproc/p5-RDF-Notation3/pkg-plist b/textproc/p5-RDF-Notation3/pkg-plist
index 9691bcc3ebc4..793275b057a0 100644
--- a/textproc/p5-RDF-Notation3/pkg-plist
+++ b/textproc/p5-RDF-Notation3/pkg-plist
@@ -2,11 +2,16 @@ lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/RDF/Notation3/.packlist
lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3.pm
lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3.pod
lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/PrefTriples.pm
+lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/RDFCore.pm
+lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/RDFStore.pm
lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/ReaderFile.pm
lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/ReaderString.pm
+lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/SAX.pm
lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/Template/TReader.pm
lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/Template/TTriples.pm
+lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/Template/TXML.pm
lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/Triples.pm
+lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/XML.pm
@dirrm lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3/Template
@dirrm lib/perl5/site_perl/%%PERL_VER%%/RDF/Notation3
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/RDF 2>/dev/null || true