aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-15 09:01:15 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-15 09:01:15 +0000
commit60b8fd8d4abb3c10afa32f4366c99d26e93d8461 (patch)
tree8537c1b2d487db468ef5b6b2d170356c19f6eaea /textproc
parentd02eae1e936867888ecbf4e8d02f5fbd24b1c089 (diff)
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xsv/Makefile19
-rw-r--r--textproc/xsv/files/patch-setup.py6
2 files changed, 12 insertions, 13 deletions
diff --git a/textproc/xsv/Makefile b/textproc/xsv/Makefile
index e256ba2b711b..1dcea42ead18 100644
--- a/textproc/xsv/Makefile
+++ b/textproc/xsv/Makefile
@@ -11,26 +11,25 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= XML Schema Validator
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ltxml>0:textproc/py-ltxml
USES= python
USE_PYTHON= distutils autoplist
-USE_LDCONFIG= yes
+NO_ARCH= yes
PORTDOCS= pc-shrinkwrap xsv-status.xml xsv-status.html
PORTEXAMPLES= triv.xml triv.xsd tiny.xml tiny.xsd
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
-CFLAGS+= -fPIC
-.endif
+OPTIONS_DEFINE= DOCS EXAMPLES
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/xsv/files/patch-setup.py b/textproc/xsv/files/patch-setup.py
index c5e14c6d98ed..305ee3281674 100644
--- a/textproc/xsv/files/patch-setup.py
+++ b/textproc/xsv/files/patch-setup.py
@@ -1,6 +1,6 @@
---- ./setup.py.orig 2008-01-18 13:17:40.000000000 +0100
-+++ ./setup.py 2014-03-23 02:06:18.690868591 +0100
-@@ -16,20 +16,10 @@
+--- setup.py.orig 2008-01-18 12:17:40 UTC
++++ setup.py
+@@ -16,20 +16,10 @@ class smart_install_data(install_data):
self.install_dir = getattr(install_cmd, 'install_lib')
return install_data.run(self)