aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-11 05:26:06 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-11 05:26:06 +0000
commit7ff8f72b1443f1c09cd42aaa0e7e29894f85b8da (patch)
treefd0d2771b82d10fc3795eebd3ddaee816827fe6e /textproc
parent32f9d8efd00f380bcb1307213f04c95dc58fd476 (diff)
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-RSS-Liberal/Makefile32
-rw-r--r--textproc/p5-XML-RSS-Liberal/distinfo3
-rw-r--r--textproc/p5-XML-RSS-Liberal/pkg-descr7
-rw-r--r--textproc/p5-XML-RSS-Liberal/pkg-plist4
5 files changed, 47 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 1227fb3558bd..58f2fad6b7ce 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -576,6 +576,7 @@
SUBDIR += p5-XML-RSS
SUBDIR += p5-XML-RSS-JavaScript
SUBDIR += p5-XML-RSS-LibXML
+ SUBDIR += p5-XML-RSS-Liberal
SUBDIR += p5-XML-RSS-Parser
SUBDIR += p5-XML-RSS-SimpleGen
SUBDIR += p5-XML-RegExp
diff --git a/textproc/p5-XML-RSS-Liberal/Makefile b/textproc/p5-XML-RSS-Liberal/Makefile
new file mode 100644
index 000000000000..e87102f179c9
--- /dev/null
+++ b/textproc/p5-XML-RSS-Liberal/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-XML-RSS-Liberal
+# Date created: 2006-07-09
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-RSS-Liberal
+PORTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= XML::RSS With A Liberal Parser
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Liberal.pm:${PORTSDIR}/textproc/p5-XML-Liberal \
+ ${SITE_PERL}/XML/RSS/LibXML.pm:${PORTSDIR}/textproc/p5-XML-RSS-LibXML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= XML::RSS::Liberal.3 XML::RSS::Liberal::Parser.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703 # inherited from textprocs/p5-XML-RSS-LibXML
+IGNORE= requires perl 5.7.3 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-RSS-Liberal/distinfo b/textproc/p5-XML-RSS-Liberal/distinfo
new file mode 100644
index 000000000000..c38f323d55f0
--- /dev/null
+++ b/textproc/p5-XML-RSS-Liberal/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-RSS-Liberal-0.01.tar.gz) = e2a1a41e38f464d1bcb19908c099fe4b
+SHA256 (XML-RSS-Liberal-0.01.tar.gz) = d16167d484d63996ec6fa09fce17c197eb670cf1e3ede1e6d8a690736b65ce6a
+SIZE (XML-RSS-Liberal-0.01.tar.gz) = 2023
diff --git a/textproc/p5-XML-RSS-Liberal/pkg-descr b/textproc/p5-XML-RSS-Liberal/pkg-descr
new file mode 100644
index 000000000000..829212e6c056
--- /dev/null
+++ b/textproc/p5-XML-RSS-Liberal/pkg-descr
@@ -0,0 +1,7 @@
+XML::RSS::Liberal is a subclass of XML::RSS::LibXML, for those of you
+who want to parse broken RSS files (as they often are). It uses
+XML::Liberal as its core parser, and therefore whatever broken XML you
+provided, as long as XML::Liberal can tolerate it.
+
+Author: Daisuke Maki <dmaki@cpan.org>, Tatsuhiko Miyagawa <miyagawa@bulknews.net>
+WWW: http://search.cpan.org/dist/XML-RSS-Liberal/
diff --git a/textproc/p5-XML-RSS-Liberal/pkg-plist b/textproc/p5-XML-RSS-Liberal/pkg-plist
new file mode 100644
index 000000000000..91d5ab8adecf
--- /dev/null
+++ b/textproc/p5-XML-RSS-Liberal/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/XML/RSS/Liberal.pm
+%%SITE_PERL%%/XML/RSS/Liberal/Parser.pm
+@dirrmtry %%SITE_PERL%%/XML/RSS/Liberal