aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2007-06-13 15:32:32 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2007-06-13 15:32:32 +0000
commit29d08137c35f58f5c51f93d9d73c7f30af4b2f96 (patch)
treee4a0a9ef05b03a354bbc6cb33fb874745343c4e3 /textproc
parenta50688e7eb5d68c458abff1d5570b1c31a20aa1f (diff)
downloadports-29d08137c35f58f5c51f93d9d73c7f30af4b2f96.tar.gz
ports-29d08137c35f58f5c51f93d9d73c7f30af4b2f96.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/google-ctemplate/Makefile5
-rw-r--r--textproc/google-ctemplate/distinfo6
-rw-r--r--textproc/google-ctemplate/files/patch-src-template.cc11
-rw-r--r--textproc/google-ctemplate/files/patch-src-template_dictionary.cc11
-rw-r--r--textproc/google-ctemplate/files/patch-src_base_mutex.h11
-rw-r--r--textproc/google-ctemplate/files/patch-src_google_template_dictionary.h.in11
-rw-r--r--textproc/google-ctemplate/files/patch-src_google_template_namelist.h.in11
-rw-r--r--textproc/google-ctemplate/pkg-plist12
8 files changed, 43 insertions, 35 deletions
diff --git a/textproc/google-ctemplate/Makefile b/textproc/google-ctemplate/Makefile
index 03103b1c42cc..e688b9791b3d 100644
--- a/textproc/google-ctemplate/Makefile
+++ b/textproc/google-ctemplate/Makefile
@@ -7,10 +7,9 @@
#
PORTNAME= google-ctemplate
-PORTVERSION= 0.4
+PORTVERSION= 0.6
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= goog-ctemplate
+MASTER_SITES= http://google-ctemplate.googlecode.com/files/
DISTNAME= ctemplate-${PORTVERSION}
MAINTAINER= clsung@FreeBSD.org
diff --git a/textproc/google-ctemplate/distinfo b/textproc/google-ctemplate/distinfo
index a18ce155cdf0..e9ca90742f0c 100644
--- a/textproc/google-ctemplate/distinfo
+++ b/textproc/google-ctemplate/distinfo
@@ -1,3 +1,3 @@
-MD5 (ctemplate-0.4.tar.gz) = 088607d1bc48ae4547f7699d5f488b63
-SHA256 (ctemplate-0.4.tar.gz) = 7fb45d09c00eebd0de4d2cc3c5d029e2dc983ff08a4e803e1be78911de129f3a
-SIZE (ctemplate-0.4.tar.gz) = 478697
+MD5 (ctemplate-0.6.tar.gz) = 9d3a13b42328c6227b57a864d12be1e9
+SHA256 (ctemplate-0.6.tar.gz) = 81afd538c2d96475345458cbdf646c054598da9352185fe06492c11b0458b223
+SIZE (ctemplate-0.6.tar.gz) = 504556
diff --git a/textproc/google-ctemplate/files/patch-src-template.cc b/textproc/google-ctemplate/files/patch-src-template.cc
deleted file mode 100644
index d5651bc97159..000000000000
--- a/textproc/google-ctemplate/files/patch-src-template.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/template.cc.orig Mon Apr 24 22:43:36 2006
-+++ src/template.cc Wed Apr 26 15:13:22 2006
-@@ -35,7 +35,7 @@
-
- // Needed for pthread_rwlock_*. If it causes problems, you could take
- // it out, but then you'd have to unset HAVE_RWLOCK (at least on linux).
--#define _XOPEN_SOURCE 500 // needed to get the rwlock calls
-+//#define _XOPEN_SOURCE 500 // needed to get the rwlock calls
-
- #include <assert.h>
- #include <stdlib.h>
diff --git a/textproc/google-ctemplate/files/patch-src-template_dictionary.cc b/textproc/google-ctemplate/files/patch-src-template_dictionary.cc
deleted file mode 100644
index 4c98402e243b..000000000000
--- a/textproc/google-ctemplate/files/patch-src-template_dictionary.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/template_dictionary.cc.orig Wed Apr 26 15:14:17 2006
-+++ src/template_dictionary.cc Wed Apr 26 15:14:26 2006
-@@ -36,7 +36,7 @@
-
- // Needed for pthread_rwlock_*. If it causes problems, you could take
- // it out, but then you'd have to unset HAVE_RWLOCK (at least on linux).
--#define _XOPEN_SOURCE 500 // needed to get the rwlock calls
-+//#define _XOPEN_SOURCE 500 // needed to get the rwlock calls
-
- #include <assert.h>
- #include <stdlib.h>
diff --git a/textproc/google-ctemplate/files/patch-src_base_mutex.h b/textproc/google-ctemplate/files/patch-src_base_mutex.h
new file mode 100644
index 000000000000..0f42c854f082
--- /dev/null
+++ b/textproc/google-ctemplate/files/patch-src_base_mutex.h
@@ -0,0 +1,11 @@
+--- src/base/mutex.h.orig Wed Jun 13 22:51:52 2007
++++ src/base/mutex.h Wed Jun 13 22:49:02 2007
+@@ -52,7 +52,7 @@
+ #elif defined(HAVE_PTHREAD) && defined(HAVE_RWLOCK)
+ // Needed for pthread_rwlock_*. If it causes problems, you could take
+ // it out, but then you'd have to unset HAVE_RWLOCK (at least on linux).
+-# define _XOPEN_SOURCE 500 // needed to get the rwlock calls
++//# define _XOPEN_SOURCE 500 // needed to get the rwlock calls
+ # include <pthread.h>
+ typedef pthread_rwlock_t MutexType;
+ #elif defined(HAVE_PTHREAD)
diff --git a/textproc/google-ctemplate/files/patch-src_google_template_dictionary.h.in b/textproc/google-ctemplate/files/patch-src_google_template_dictionary.h.in
new file mode 100644
index 000000000000..68b31c92abf9
--- /dev/null
+++ b/textproc/google-ctemplate/files/patch-src_google_template_dictionary.h.in
@@ -0,0 +1,11 @@
+--- src/google/template_dictionary.h.in.orig Wed Jun 13 23:18:14 2007
++++ src/google/template_dictionary.h.in Wed Jun 13 23:18:30 2007
+@@ -251,7 +251,7 @@
+ inline static size_t HashTemplateString(const TemplateString& s) {
+ // This is a terrible hash-function
+ unsigned long r = 0;
+- for (int i = 0; i < s.length_; i++)
++ for (unsigned int i = 0; i < s.length_; i++)
+ r = 5 * r + s.ptr_[i];
+ return static_cast<size_t>(r);
+ }
diff --git a/textproc/google-ctemplate/files/patch-src_google_template_namelist.h.in b/textproc/google-ctemplate/files/patch-src_google_template_namelist.h.in
new file mode 100644
index 000000000000..a53864b276b7
--- /dev/null
+++ b/textproc/google-ctemplate/files/patch-src_google_template_namelist.h.in
@@ -0,0 +1,11 @@
+--- src/google/template_namelist.h.in.orig Wed Jun 13 23:14:49 2007
++++ src/google/template_namelist.h.in Wed Jun 13 23:19:50 2007
+@@ -42,7 +42,7 @@
+ #include <time.h> // for time_t
+ #include <string>
+ #include <vector>
+-#include HASH_SET_H // defined in config.h
++#include <ext/hash_set>
+ #include <google/template_enums.h> // for Strip
+
+ // RegisterTemplateFilename
diff --git a/textproc/google-ctemplate/pkg-plist b/textproc/google-ctemplate/pkg-plist
index 19dac81a5cae..2e741355f40d 100644
--- a/textproc/google-ctemplate/pkg-plist
+++ b/textproc/google-ctemplate/pkg-plist
@@ -1,18 +1,16 @@
bin/make_tpl_varnames_h
bin/template-converter
-include/google/ctemplate/hash_map.h
-include/google/ctemplate/hash_set.h
include/google/template.h
-include/google/template_enums.h
include/google/template_dictionary.h
-include/google/template_namelist.h
+include/google/template_enums.h
+include/google/template_emitter.h
include/google/template_from_string.h
-include/google/hash_map.h
-@dirrm include/google/ctemplate
-@dirrm include/google
+include/google/template_modifiers.h
+include/google/template_namelist.h
lib/libctemplate.a
lib/libctemplate.so
lib/libctemplate.so.0
lib/libctemplate_nothreads.a
lib/libctemplate_nothreads.so
lib/libctemplate_nothreads.so.0
+@dirrmtry include/google