aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2004-05-18 13:55:50 +0000
committerErwin Lansing <erwin@FreeBSD.org>2004-05-18 13:55:50 +0000
commit36c916aee8ca23cfa371f6c6cbda72de0c8de3d7 (patch)
treeaa0aeb9a8bfde4c866ff19e478aacdbb4fe873f1 /textproc
parente8ecba0d4a93b2030d82ce6ab30ddef88c96efb8 (diff)
downloadports-36c916aee8ca23cfa371f6c6cbda72de0c8de3d7.tar.gz
ports-36c916aee8ca23cfa371f6c6cbda72de0c8de3d7.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-TabularDisplay/Makefile27
-rw-r--r--textproc/p5-Text-TabularDisplay/distinfo2
-rw-r--r--textproc/p5-Text-TabularDisplay/files/patch-TabularDisplay.pm11
-rw-r--r--textproc/p5-Text-TabularDisplay/pkg-descr5
-rw-r--r--textproc/p5-Text-TabularDisplay/pkg-plist5
6 files changed, 51 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index aceac9273f4d..29f3b914d60d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -327,6 +327,7 @@
SUBDIR += p5-Text-Striphigh
SUBDIR += p5-Text-Table
SUBDIR += p5-Text-Tabs+Wrap
+ SUBDIR += p5-Text-TabularDisplay
SUBDIR += p5-Text-Template
SUBDIR += p5-Text-Tmpl
SUBDIR += p5-Text-WikiFormat
diff --git a/textproc/p5-Text-TabularDisplay/Makefile b/textproc/p5-Text-TabularDisplay/Makefile
new file mode 100644
index 000000000000..7fc48fc6c0fa
--- /dev/null
+++ b/textproc/p5-Text-TabularDisplay/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Text-TabularDisplay
+# Date created: 16 May 2004
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+
+PORTNAME= Text-TabularDisplay
+PORTVERSION= 1.18
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Display text in formatted table output
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::TabularDisplay.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+# make PREFIX-clean under perl 5.005_03
+post-configure:
+ ${PERL} -pi -e 's,/usr/local/,\$$(PREFIX)/,g' ${WRKSRC}/Makefile
+.endif
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-TabularDisplay/distinfo b/textproc/p5-Text-TabularDisplay/distinfo
new file mode 100644
index 000000000000..4b7adf602744
--- /dev/null
+++ b/textproc/p5-Text-TabularDisplay/distinfo
@@ -0,0 +1,2 @@
+MD5 (Text-TabularDisplay-1.18.tar.gz) = 06b48726ca3281b2b3ab41eec9c06460
+SIZE (Text-TabularDisplay-1.18.tar.gz) = 13557
diff --git a/textproc/p5-Text-TabularDisplay/files/patch-TabularDisplay.pm b/textproc/p5-Text-TabularDisplay/files/patch-TabularDisplay.pm
new file mode 100644
index 000000000000..67e5f12703db
--- /dev/null
+++ b/textproc/p5-Text-TabularDisplay/files/patch-TabularDisplay.pm
@@ -0,0 +1,11 @@
+--- TabularDisplay.pm.orig Sun May 16 23:07:02 2004
++++ TabularDisplay.pm Mon May 17 23:56:08 2004
+@@ -240,7 +240,7 @@
+
+ push @data, $add->[$i];
+ $length->[$i] = $l
+- unless $length->[$i] > $l;
++ unless defined $length->[$i] and $length->[$i] > $l;
+ }
+ push @$where, \@data;
+ }
diff --git a/textproc/p5-Text-TabularDisplay/pkg-descr b/textproc/p5-Text-TabularDisplay/pkg-descr
new file mode 100644
index 000000000000..68feacad4d23
--- /dev/null
+++ b/textproc/p5-Text-TabularDisplay/pkg-descr
@@ -0,0 +1,5 @@
+Text::TabularDisplay simplifies displaying textual data in a table.
+The output is identical to the columnar display of query results
+in the mysql text monitor.
+
+WWW: http://search.cpan.org/dist/Text-TabularDisplay
diff --git a/textproc/p5-Text-TabularDisplay/pkg-plist b/textproc/p5-Text-TabularDisplay/pkg-plist
new file mode 100644
index 000000000000..8bd64ef40d30
--- /dev/null
+++ b/textproc/p5-Text-TabularDisplay/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Text/TabularDisplay.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/TabularDisplay/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/TabularDisplay
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Text 2>/dev/null || true