aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-11 13:57:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-11 13:57:34 +0000
commitdbcface0f67c0a0411deb0eb9f049c16d24f0ef2 (patch)
tree81bf389ae10cb87e714765fafcbebf9c7e0294d8 /textproc
parent2db89a42eb1e91e57cfbf0a3f25f7a0fb3ddd204 (diff)
downloadports-dbcface0f67c0a0411deb0eb9f049c16d24f0ef2.tar.gz
ports-dbcface0f67c0a0411deb0eb9f049c16d24f0ef2.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/expat2/Makefile12
-rw-r--r--textproc/expat2/distinfo6
-rw-r--r--textproc/expat2/files/patch-Makefile.in15
3 files changed, 14 insertions, 19 deletions
diff --git a/textproc/expat2/Makefile b/textproc/expat2/Makefile
index b0bade8ad04d..ada560c58a8c 100644
--- a/textproc/expat2/Makefile
+++ b/textproc/expat2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= expat
-PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTVERSION= 2.0.1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= expat
@@ -18,19 +17,18 @@ COMMENT= XML 1.0 parser written in C
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
ALL_TARGET= default
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= xmlwf.1
SHLIB_MAJOR= 6
-MAKE_ENV= LIBCURRENT="${SHLIB_MAJOR}" \
- SHELL="/bin/sh"
+MAKE_ENV= LIBCURRENT="${SHLIB_MAJOR}"
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
list-depend-ports:
cd ${PORTSDIR}; \
- find . -mindepth 3 -maxdepth 3 -name Makefile -execdir sh -c \
- 'find . -type f | grep -v CVS | xargs grep -q expat.5' \; \
+ ${FIND} . -mindepth 3 -maxdepth 3 -name Makefile -execdir ${SH} -c \
+ '${FIND} . -type f | ${GREP} -v CVS | ${XARGS} ${GREP} -q expat.5' \; \
-print
.include <bsd.port.mk>
diff --git a/textproc/expat2/distinfo b/textproc/expat2/distinfo
index 8c4ed0fa926f..899df73ec38e 100644
--- a/textproc/expat2/distinfo
+++ b/textproc/expat2/distinfo
@@ -1,3 +1,3 @@
-MD5 (expat-2.0.0.tar.gz) = d945df7f1c0868c5c73cf66ba9596f3f
-SHA256 (expat-2.0.0.tar.gz) = c4280eb80fa8e14b3f204b1d0ec67af66fa04c4f9dae9c78a1a8ee4c6f485ddd
-SIZE (expat-2.0.0.tar.gz) = 450860
+MD5 (expat-2.0.1.tar.gz) = ee8b492592568805593f81f8cdf2a04c
+SHA256 (expat-2.0.1.tar.gz) = 847660b4df86e707c9150e33cd8c25bc5cd828f708c7418e765e3e983a2e5e93
+SIZE (expat-2.0.1.tar.gz) = 446456
diff --git a/textproc/expat2/files/patch-Makefile.in b/textproc/expat2/files/patch-Makefile.in
index 182565add03d..19203cd94dc2 100644
--- a/textproc/expat2/files/patch-Makefile.in
+++ b/textproc/expat2/files/patch-Makefile.in
@@ -1,14 +1,11 @@
---- Makefile.in.orig Thu Jan 12 00:28:02 2006
-+++ Makefile.in Thu Jan 12 00:28:10 2006
-@@ -44,9 +44,9 @@
+--- Makefile.in.orig Sun Jun 10 21:10:33 2007
++++ Makefile.in Sun Jun 10 21:11:18 2007
+@@ -44,8 +44,6 @@
APIHEADER = $(srcdir)/lib/expat.h $(srcdir)/lib/expat_external.h
LIBRARY = libexpat.la
--ifndef INSTALL_ROOT
-+#ifndef INSTALL_ROOT
- INSTALL_ROOT=$(DESTDIR)
--endif
-+#endif
-
+-DESTDIR = $(INSTALL_ROOT)
+-
default: buildlib xmlwf/xmlwf
+ buildlib: $(LIBRARY)