aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-11-08 18:53:49 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-11-08 18:53:49 +0000
commit0a5c59363f54b85bdceeacff5256fb6eb3d3c680 (patch)
tree128299fbff4d389f4b9d89ff48b3b4947e96a523 /textproc
parentac01eaff99c39944327eaf62e83547d2b7da88d6 (diff)
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-qrcode/Makefile2
-rw-r--r--textproc/py3-qrcode/Makefile7
3 files changed, 9 insertions, 1 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3135d6b5ac23..9cf578a0a099 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1401,6 +1401,7 @@
SUBDIR += py3-pyPEG2
SUBDIR += py3-pygments
SUBDIR += py3-pystemmer
+ SUBDIR += py3-qrcode
SUBDIR += py3-snowballstemmer
SUBDIR += py3-sphinx
SUBDIR += py3-sphinx_rtd_theme
diff --git a/textproc/py-qrcode/Makefile b/textproc/py-qrcode/Makefile
index 7b7b6fb55400..88be2a75dbac 100644
--- a/textproc/py-qrcode/Makefile
+++ b/textproc/py-qrcode/Makefile
@@ -15,7 +15,7 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.8:devel/py-six \
${PYTHON_PKGNAMEPREFIX}pillow>=2.6:graphics/py-pillow
-USES= python
+USES?= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/textproc/py3-qrcode/Makefile b/textproc/py3-qrcode/Makefile
new file mode 100644
index 000000000000..204d2aa49106
--- /dev/null
+++ b/textproc/py3-qrcode/Makefile
@@ -0,0 +1,7 @@
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-qrcode
+
+USES= python:3
+
+.include "${MASTERDIR}/Makefile"