aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-07-03 18:52:25 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-07-03 18:52:25 +0000
commit422a4b39d88b7a7327050318633c93751b5713ae (patch)
tree86318aca0708a6ca8a6807acc5a7e62da1eadcca /textproc
parent3ca4253c8508ae007e2f30a1b419ee827c49c2b0 (diff)
downloadports-422a4b39d88b7a7327050318633c93751b5713ae.tar.gz
ports-422a4b39d88b7a7327050318633c93751b5713ae.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/minify/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/textproc/minify/Makefile b/textproc/minify/Makefile
index 917e29e56787..2d4842599025 100644
--- a/textproc/minify/Makefile
+++ b/textproc/minify/Makefile
@@ -12,20 +12,19 @@ COMMENT= Go minifiers for web formats
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USES= go
+USES= go:modules
-GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
-GO_TARGET= ${GO_PKGNAME}/cmd/${GH_PROJECT}
+GO_TARGET= ./cmd/${GH_PROJECT}
PLIST_FILES= bin/minify
GH_ACCOUNT= tdewolff
-GH_TUPLE= dustin:go-humanize:v1.0.0:dustin_go_humanize/../src/github.com/dustin/go-humanize \
- fsnotify:fsnotify:v1.4.7:fsnotify_fsnotify/../src/github.com/fsnotify/fsnotify \
- golang:sys:61b9204:golang_sys/../src/golang.org/x/sys \
- matryer:try:v1:matryer_try/../src/github.com/matryer/try \
- spf13:pflag:v1.0.3:spf13_pflag/../src/github.com/spf13/pflag \
- tdewolff:parse:v2.3.7:tdewolff_parse/../src/github.com/tdewolff/parse
+GH_TUPLE= dustin:go-humanize:v1.0.0:dustin_go_humanize/vendor/github.com/dustin/go-humanize \
+ fsnotify:fsnotify:v1.4.7:fsnotify_fsnotify/vendor/github.com/fsnotify/fsnotify \
+ golang:sys:61b9204:golang_sys/vendor/golang.org/x/sys \
+ matryer:try:v1:matryer_try/vendor/github.com/matryer/try \
+ spf13:pflag:v1.0.3:spf13_pflag/vendor/github.com/spf13/pflag \
+ tdewolff:parse:v2.3.7:tdewolff_parse/vendor/github.com/tdewolff/parse/v2
USE_GITHUB= yes
do-install: