aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-10-18 12:29:50 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-10-18 12:29:50 +0000
commite6de2ce4c43cd2d96c2c40379d52c9409ce1ede7 (patch)
tree16a77f9bc8c9233189d0ab37b9517d69bab5b5f9 /textproc
parent9c165638ca499520ab14ea22e6cfd7dea0d5968f (diff)
KMFL aims to bring Tavultesoft Keyman functionality to *nix operating
systems. KMFL is being jointly developed by SIL International (http://www.sil.org) and Tavultesoft (http://www.tavultesoft.com). This is compiler for keyboard sources written in Keyman keyboard language (.kmn files). Resulting binaries (.kmfl) can be used with SCIM KMFL IMEngine (textproc/scim-kmfl-imengine). The powerful KMN keyboard language supports contextual deadkeys, pre- and post-processing of keystrokes, rules grouping, 'storing' of character classes for use in similar rules, custom and Unicode character constants, SIL Ethnologue language codes, etc. Official Tavultesoft repository contains keyboards that cover more than 220 languages. Significant number of them are open source. Ported keyboards are textproc/scim-kmfl-*. WWW: http://kmfl.sourceforge.net/ PR: ports/117167 Submitted by: Nikola Lecic <nikola.lecic at anthesphoria.net>
Notes
Notes: svn path=/head/; revision=201638
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/kmflcomp/Makefile55
-rw-r--r--textproc/kmflcomp/distinfo6
-rw-r--r--textproc/kmflcomp/files/pkg-message.in19
-rw-r--r--textproc/kmflcomp/pkg-descr18
-rw-r--r--textproc/kmflcomp/pkg-plist15
6 files changed, 114 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 5ca9f7d8a54d..7fca646d7166 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -242,6 +242,7 @@
SUBDIR += jrefentry
SUBDIR += kbedic
SUBDIR += kdiff3
+ SUBDIR += kmflcomp
SUBDIR += ku-aspell
SUBDIR += l2a
SUBDIR += la-aspell
diff --git a/textproc/kmflcomp/Makefile b/textproc/kmflcomp/Makefile
new file mode 100644
index 000000000000..184c36e40aeb
--- /dev/null
+++ b/textproc/kmflcomp/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: kmflcomp
+# Date created: 10 October 2007
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kmflcomp
+PORTVERSION= 0.9.6
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://anthesphoria.net/files/distribution/
+MASTER_SITE_SUBDIR= kmfl
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
+ KMFL-Compiler.sxw
+DIST_SUBDIR= kmfl
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= Compiler of Keyman keyboard sources to use with SCIM KMFL IMEngine
+
+USE_BISON= yes
+USE_XORG= x11
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+DOCSDIR= ${PREFIX}/share/doc/kmfl/${PORTNAME}
+DOCS= ${DISTDIR}/${DIST_SUBDIR}/KMFL-Compiler.sxw \
+ ${WRKSRC}/AUTHORS \
+ ${WRKSRC}/COPYING \
+ ${WRKSRC}/ChangeLog
+
+SUB_FILES= pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^install-data-am: install-kmflcompdocDATA|install-data-am:|' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|-L/usr/X11R6/lib|-L${X11BASE}/lib|' \
+ ${WRKSRC}/kmfl_compiler/Makefile.in
+ @${REINPLACE_CMD} -E 's,"UTF(8|16LE|32LE)","UTF-\1",g' \
+ ${WRKSRC}/src/utfconv.c
+ @${REINPLACE_CMD} -E 's,(VERSION= *)"0\.9\.2",\1"0.9.6",' \
+ ${WRKSRC}/kmfl_compiler/kmfl_compiler.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} -v ${DOCS} ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/kmflcomp/distinfo b/textproc/kmflcomp/distinfo
new file mode 100644
index 000000000000..94abadc99370
--- /dev/null
+++ b/textproc/kmflcomp/distinfo
@@ -0,0 +1,6 @@
+MD5 (kmfl/kmflcomp-0.9.6.tar.gz) = e5cf7abf5a405cef3021f0f047e17b22
+SHA256 (kmfl/kmflcomp-0.9.6.tar.gz) = 313e1f9d4d016f9dfe485ecf0dad3ba29ed7ba14ae8a44da5701273c4c27ced8
+SIZE (kmfl/kmflcomp-0.9.6.tar.gz) = 379369
+MD5 (kmfl/KMFL-Compiler.sxw) = d9bf9f5a45824354205ce8a4721b807d
+SHA256 (kmfl/KMFL-Compiler.sxw) = dedb0aee0b7d931dff48d0bcd3f9fa5c2c71d4684f9aa53e064df5bfb8b04841
+SIZE (kmfl/KMFL-Compiler.sxw) = 56675
diff --git a/textproc/kmflcomp/files/pkg-message.in b/textproc/kmflcomp/files/pkg-message.in
new file mode 100644
index 000000000000..2794c379b73e
--- /dev/null
+++ b/textproc/kmflcomp/files/pkg-message.in
@@ -0,0 +1,19 @@
+
+------------------------------------------------------------------------
+ Please note that kmflcomp only compiles keyboard sources written in
+ Keyman keyboard language (.kmn) into .kmfl binaries. KMFL is source
+ compatible with keyboards developed for Keyman. Binary keyboards
+ compiled for Keyman will not run under KMFL. KMFL is also Unicode
+ based, and does not support legacy code pages and encodings.
+
+ The Keyman keyboard language is documented in
+
+ %%PREFIX%%/share/doc/kmfl/kmflcomp/KMFL-Compiler.sxw
+
+ Tavultesoft documentation is available on
+
+ http://tavultesoft.com/keymandev/documentation/help/main/guide.php
+
+ You need textproc/scim-kmfl-imengine and textproc/scim-kmfl-* ports
+ in order to use actual keyboards through SCIM.
+------------------------------------------------------------------------
diff --git a/textproc/kmflcomp/pkg-descr b/textproc/kmflcomp/pkg-descr
new file mode 100644
index 000000000000..f1256f8ed510
--- /dev/null
+++ b/textproc/kmflcomp/pkg-descr
@@ -0,0 +1,18 @@
+KMFL aims to bring Tavultesoft Keyman functionality to *nix operating
+systems. KMFL is being jointly developed by SIL International
+(http://www.sil.org) and Tavultesoft (http://www.tavultesoft.com).
+
+This is compiler for keyboard sources written in Keyman keyboard
+language (.kmn files). Resulting binaries (.kmfl) can be used with
+SCIM KMFL IMEngine (textproc/scim-kmfl-imengine).
+
+The powerful KMN keyboard language supports contextual deadkeys,
+pre- and post-processing of keystrokes, rules grouping, 'storing'
+of character classes for use in similar rules, custom and Unicode
+character constants, SIL Ethnologue language codes, etc.
+
+Official Tavultesoft repository contains keyboards that cover more
+than 220 languages. Significant number of them are open source.
+Ported keyboards are textproc/scim-kmfl-*.
+
+WWW: http://kmfl.sourceforge.net/
diff --git a/textproc/kmflcomp/pkg-plist b/textproc/kmflcomp/pkg-plist
new file mode 100644
index 000000000000..ffd47197b1f4
--- /dev/null
+++ b/textproc/kmflcomp/pkg-plist
@@ -0,0 +1,15 @@
+bin/kmflcomp
+include/kmfl/kmfl.h
+include/kmfl/kmflcomp.h
+include/kmfl/kmflutfconv.h
+lib/libkmflcomp.a
+lib/libkmflcomp.la
+lib/libkmflcomp.so
+lib/libkmflcomp.so.0
+@dirrm include/kmfl
+%%PORTDOCS%%%%DOCSDIR%%/KMFL-Compiler.sxw
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrmtry share/doc/kmfl