aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-09-30 11:23:16 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-09-30 11:23:16 +0000
commit06ff9c0db3e2f8a8485359e7c69efe29a0d6efb6 (patch)
tree85c5069a385683a7397bad646022cf23f7c4eef4 /textproc
parentac0f4424c042aa617b609f270e8e61a83ec8fda8 (diff)
downloadports-06ff9c0db3e2f8a8485359e7c69efe29a0d6efb6.tar.gz
ports-06ff9c0db3e2f8a8485359e7c69efe29a0d6efb6.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Pod-WSDL/Makefile43
-rw-r--r--textproc/p5-Pod-WSDL/distinfo3
-rw-r--r--textproc/p5-Pod-WSDL/pkg-descr16
-rw-r--r--textproc/p5-Pod-WSDL/pkg-plist16
5 files changed, 79 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index c6f36341c49a..e4867c0477e2 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -424,6 +424,7 @@
SUBDIR += p5-Pod-Simple
SUBDIR += p5-Pod-Stripper
SUBDIR += p5-Pod-Tree
+ SUBDIR += p5-Pod-WSDL
SUBDIR += p5-Pod-XML
SUBDIR += p5-Pod-Xhtml
SUBDIR += p5-RADIUS-UserFile
diff --git a/textproc/p5-Pod-WSDL/Makefile b/textproc/p5-Pod-WSDL/Makefile
new file mode 100644
index 000000000000..2493cd704091
--- /dev/null
+++ b/textproc/p5-Pod-WSDL/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: textproc/p5-Pod-WSDL
+# Date created: 30 September 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-WSDL
+PORTVERSION= 0.04
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Pod
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Create WSDL documents from (extended) pod
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer \
+ ${SITE_PERL}/XML/XPath.pm:${PORTSDIR}/textproc/p5-XML-XPath
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Pod::WSDL.3 \
+ Pod::WSDL::AUTOLOAD.3 \
+ Pod::WSDL::Attr.3 \
+ Pod::WSDL::Doc.3 \
+ Pod::WSDL::Fault.3 \
+ Pod::WSDL::Method.3 \
+ Pod::WSDL::Param.3 \
+ Pod::WSDL::Return.3 \
+ Pod::WSDL::Type.3 \
+ Pod::WSDL::Utils.3 \
+ Pod::WSDL::Writer.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.1 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Pod-WSDL/distinfo b/textproc/p5-Pod-WSDL/distinfo
new file mode 100644
index 000000000000..88f9f6587962
--- /dev/null
+++ b/textproc/p5-Pod-WSDL/distinfo
@@ -0,0 +1,3 @@
+MD5 (Pod-WSDL-0.04.tar.gz) = b8ec238ab7e0a2aa12be2345e2f2ef48
+SHA256 (Pod-WSDL-0.04.tar.gz) = efe0016a255b84431b8a65cd6dc30b627859d08aa8c05a39a5c1a8489eeaa3ea
+SIZE (Pod-WSDL-0.04.tar.gz) = 25781
diff --git a/textproc/p5-Pod-WSDL/pkg-descr b/textproc/p5-Pod-WSDL/pkg-descr
new file mode 100644
index 000000000000..8bddeb8941ed
--- /dev/null
+++ b/textproc/p5-Pod-WSDL/pkg-descr
@@ -0,0 +1,16 @@
+How does Pod::WSDL work? If you instantiate a Pod::WSDL object with the
+name of the module (or the path of the file, or an open filehandle)
+providing the web service like this
+
+ my $pwsdl = new Pod::WSDL(source => 'My::Module',
+ location => 'http://my.services.location/on/the/web');
+
+Pod::WSDL will try to find "My::Module" in @INC, open the file, parse it
+for WSDL directives and prepare the information for WSDL output. By
+calling
+
+ $pwsdl->WSDL;
+
+Pod::WSDL will output the WSDL document. That's it.
+
+WWW: http://search.cpan.org/dist/Pod-WSDL/
diff --git a/textproc/p5-Pod-WSDL/pkg-plist b/textproc/p5-Pod-WSDL/pkg-plist
new file mode 100644
index 000000000000..4971a89a0214
--- /dev/null
+++ b/textproc/p5-Pod-WSDL/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/Pod/WSDL.pm
+%%SITE_PERL%%/Pod/WSDL/AUTOLOAD.pm
+%%SITE_PERL%%/Pod/WSDL/Attr.pm
+%%SITE_PERL%%/Pod/WSDL/Doc.pm
+%%SITE_PERL%%/Pod/WSDL/Fault.pm
+%%SITE_PERL%%/Pod/WSDL/Method.pm
+%%SITE_PERL%%/Pod/WSDL/Param.pm
+%%SITE_PERL%%/Pod/WSDL/Return.pm
+%%SITE_PERL%%/Pod/WSDL/Type.pm
+%%SITE_PERL%%/Pod/WSDL/Utils.pm
+%%SITE_PERL%%/Pod/WSDL/Writer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/WSDL/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/WSDL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod
+@dirrmtry %%SITE_PERL%%/Pod/WSDL
+@dirrmtry %%SITE_PERL%%/Pod