aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-08-01 07:15:38 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-08-01 07:15:38 +0000
commit464ce24e2ce8c332dc990d78ca284f4a1a17abf7 (patch)
treeacacbaf55352d8821c06134dce5bafd1e3d121b7 /textproc
parent9b422a0d5a5b751fd997815299c67ddea95f4078 (diff)
downloadports-464ce24e2ce8c332dc990d78ca284f4a1a17abf7.tar.gz
ports-464ce24e2ce8c332dc990d78ca284f4a1a17abf7.zip
MFH: r543817
games/py-mnemosyne: Take Maintainer'ship, fix runtime error and add missing dependencies Latest version of games/py-mnemosyne requires new dependencies. This commit adds the missing dependencies: - audio/py-gtts - security/py-gtts-token (required by audio/py-gtts) - textproc/py-googletrans The games/py-mnemosyne port needs to be limited to Python 3.7+ to keep the dependency chains intact. This is because textproc/py-googletrans depends on www/py-httpx which is only for Python 3.7+. PR: 247595 Submitted by: kai Reported by: gspurki@gmail.com Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D25895 Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2020Q3/; revision=543891
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-googletrans/Makefile22
-rw-r--r--textproc/py-googletrans/distinfo3
-rw-r--r--textproc/py-googletrans/pkg-descr13
4 files changed, 39 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 79acb1774668..3acf7518dfe8 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1255,6 +1255,7 @@
SUBDIR += py-genshi
SUBDIR += py-gensim
SUBDIR += py-gfm
+ SUBDIR += py-googletrans
SUBDIR += py-grako
SUBDIR += py-guess-language
SUBDIR += py-hexdump
diff --git a/textproc/py-googletrans/Makefile b/textproc/py-googletrans/Makefile
new file mode 100644
index 000000000000..2dfd7d01105a
--- /dev/null
+++ b/textproc/py-googletrans/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= googletrans
+DISTVERSION= 3.0.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Free Google Translate API that translates totally free of charge
+
+LICENSE= MIT
+# LICENSE_FILE isn't packaged in the sdist, yet
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httpx==0.13.3:www/py-httpx@${PY_FLAVOR}
+
+USES= python:3.7+ # due www/py-httpx that requires 3.7+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-googletrans/distinfo b/textproc/py-googletrans/distinfo
new file mode 100644
index 000000000000..ce1cd0ed225d
--- /dev/null
+++ b/textproc/py-googletrans/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1594055380
+SHA256 (googletrans-3.0.0.tar.gz) = 44caeea42d91ff6ead5c2d49db2b88de66c45c2fe874c8ec03eb9b4ceb3a533d
+SIZE (googletrans-3.0.0.tar.gz) = 17489
diff --git a/textproc/py-googletrans/pkg-descr b/textproc/py-googletrans/pkg-descr
new file mode 100644
index 000000000000..186c4ac9188b
--- /dev/null
+++ b/textproc/py-googletrans/pkg-descr
@@ -0,0 +1,13 @@
+Googletrans is a free and unlimited Python library that implemented the
+Google Translate API. This uses the Google Translate Ajax API to make calls to
+such methods as detect and translate.
+
+Features:
+
+* Fast and reliable - it uses the same servers that translate.google.com uses
+* Auto language detection
+* Bulk translations
+* Customizable service URL
+* HTTP/2 support
+
+WWW: https://github.com/ssut/py-googletrans